Help answer threads with 0 replies.
Go Back > Forums > Linux Forums > Linux - Newbie
User Name
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!


  Search this Thread
Old 05-24-2003, 05:38 AM   #1
LQ Newbie
Registered: May 2003
Location: MS, US of A
Distribution: Gentoo
Posts: 2

Rep: Reputation: 0
mounting windows drive

i'm running red hat 9 and i'm trying to mount my windows drive.

mount -f vfat /dev/hda1 /mnt/win1 works but doesn't last after restarting.


i installed the mp3 patch from in hopes of listening to some mp3s. the patch seems to install and can be viewed from the input plugins preferences to confirm the installation, but when i try playing mp3s it scrolls down the whole list and doesn't play anything.

Old 05-24-2003, 07:33 AM   #2
Registered: May 2003
Location: Hong Kong
Distribution: Android on HTC Hero
Posts: 256

Rep: Reputation: 30

1.) you need to edit the fstab table for the mounting to be done automatically. the files is located at /etc/fstab. add a line at the very end as


(replace the underscore with real spaces as the format indicated by the line in the fstab file)

then it will auto mount after restart (of course u have to make sure your /mnt/win1 is there already)

2.) for the sound drivers are u sure that you ahve installed it properly? and did u install the right rpm package for the right kernel? to check your kernel build, in an x terminal type "uname -r" and obtain the correct rpm from that site again.

hope this helps,

Old 05-24-2003, 10:10 AM   #3
Registered: Apr 2003
Location: root@localhost
Distribution: Fedora Core 5, Ubuntu, Debian
Posts: 537

Rep: Reputation: 30
Re: mounting windows drive

Originally posted by ditto
i'm running red hat 9 and i'm trying to mount my windows drive.

mount -f vfat /dev/hda1 /mnt/win1 works but doesn't last after restarting.
If you want to automount your windows partition edit your fstab...

here is a step by step instruction:

su root

create a directory /mnt/win

gedit /etc/fstab

you will see a list of mounts, just add the following line (remember to change the names according to your settings.) to your fstab:

/dev/hda1 /mnt/win vfat user,umask=222 00

this gives you read only access to your win partition....

umask=000 (this gives you full write access to the drive/win partition)

umask=022 (only root has full write access to the drive/win partition)

I recomend that you only use read access to avoid accidental problems and errors to your win partition...

good luck...

Last edited by jt1020; 05-24-2003 at 10:14 AM.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
mounting a windows drive evannextel Linux - Newbie 3 06-21-2004 05:21 PM
Mounting a windows drive jon_k Linux - Hardware 14 07-18-2003 09:58 PM
mounting windows drive chrismiceli Linux - Networking 2 06-28-2003 02:11 AM
Mounting a Windows Drive digsby0007 Linux - Software 4 05-09-2003 05:18 PM
Mounting windows drive celtic32 Linux - General 10 09-09-2002 12:32 PM > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 09:35 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration