-   Linux - Newbie (
-   -   Mounting Problems (

broxys 06-19-2003 05:17 PM

Mounting Problems
i have a 120gb usb hd that has been working fine under XP. I've had redhat for about a month so i'm still new. I tried to (and can) mount my USB hd with the following:
[root@broxys(/home/oliver) | 06:11 PM]
#mount /dev/sda1 /mnt/usbhd

I originally had been trying to mount it in my /etc/fstab but that didn't seem to work right. (Anyone know why?) And now when i Boot, the cdrom doesn't get mounted right for whatever reason.
(when i try to mount it i get this error:
root@broxys(/home/oliver) | 06:11 PM]
#mount /dev/cdrom
mount: special device /dev/cdrom does not exist
[root@broxys(/home/oliver) | 06:14 PM]
#mount /mnt/cdrom
mount: special device /dev/cdrom does not exist

My /etc/fstab is below.
Can anyone help?

[oliver@broxys(~) | 06:06 PM]
$cat /etc/fstab
LABEL=/ / ext3 defaults 1 1
none /dev/pts devpts gid=5,mode=620 0 0
none /proc proc defaults 0 0
none /dev/shm tmpfs defaults 0 0
/dev/hda3 swap swap defaults 0 0
/dev/hda5 /mnt/d: vfat defaults 0 0
/dev/cdrom /mnt/cdrom iso9660 noauto,owner,kudzu,ro 0 0


acid_kewpie 06-19-2003 06:17 PM

well, just what is says really. there is no /dev/cdrom. try a "ls -l /dev/cdrom" and it'll say "no such file or directryo - i hope.

you need to find where the cd drive actually is connected, e.g. /dev/hdc for secondary master on an ide channel andcreate a symlink:

ln -s /dev/hdc /dev/cdrom

which will then creaet that entry. and that mount command should work. alternatively just replace the /dev/cdrom entry with /dev/hdc. you'd then call

mount /mnt/cdrom

in just the same way. /dev/cdrom is just a slight sugaring of the device, to make it more friendly than "hdc" or wherever drive actually is.

broxys 06-19-2003 06:29 PM

alright thx. chris. i think the issue definitely is when i was poking around in fstab i confused the /dev/? with /dev/cdrom. so the million dollar question is How do i find out where the cd drive is actually connected?
thx a bunch.

broxys 06-19-2003 07:12 PM

i actually think i've got it all covered now. thx very much for the help. it was /dev/scd0.

broxys 07-10-2003 12:33 PM

A new question:
alright. so now that everything with the cdrom is working relatively fine.

the harddrive is now having some issues:
i stil can mount it fine with a mount command:
#mount /dev/sda1 /mnt/usbhd
alright. so how do i mount it in fstab?
with the following fstab configuration i get an error that does not allow me to boot, it gives me the option to login as root to rectify the problem.
/dev/sda1 /mnt/usbhd vfat noauto,user 1 2
or if i try to mount from the fstab while that is in fstab i get:
#mount /dev/sda1
mount: wrong fs type, bad option, bad superblock on /dev/sda1,
or too many mounted file systems

so. uh.. any ideas?


All times are GMT -5. The time now is 11:47 PM.