LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Mounting problem! (https://www.linuxquestions.org/questions/linux-newbie-8/mounting-problem-18219/)

BoldKiller 04-10-2002 06:54 PM

Mounting problem!
 
Ok, here I go!

I am trying to run linux on a 486. I want to use it as a server. The server has :

- 1 hard drive (a new one 60 gigs uf i remember corectly)
- 1 Ethernet card
- 1 cd-Rom + 1 floppy
- 1 video card
- VGA monitor
- 3 button serial mouse (no name)
- 32 megs of RAM

Here is my problem:
A few weeks ago I installed Red Hat 7.0. Everything was working fine except that I could not mount a flloppy (see : weird floppy problem (http://www.linuxquestions.org/questi...threadid=17923) ) About 2 days ago, I downloaded Red Hat 7.2 (From www.linuxiso.org) did a check sum on the 2 ISO, burn them. No problem so far. Installed linux (server configuration, deleting old partition). No problem so far. System restart, I log in. The problems started then.

Just to see I tried to mount a floppy. Still no luck (Have not yet tried mtools)

Then I wanted to start the X server using Window Maker.
Since the system told me window maker was not installed, I wanted to install it from the CD'S.

I used mount /mnt/cdrom

Response : mount: /dev/cdrom is not a valid block device

(I also tried mount -t iso9660 /dev/cdrom /mnt/cdrom , it gives me same message.)
I know the CD-Rom is working since I used it to install and it worker fine under 7.0.

Sorry for the really long post, but I want to be precise so I can get help ASAP. I mean I can't even see how well Linux would work since basic file acces function seem to malfunction!!

Thanks in advance!!

acid_kewpie 04-10-2002 06:59 PM

well have you checked to see if /dev/cdrom exists? try just mounting directly via the /dev/hd[a/b/c/d] device instead

BoldKiller 04-10-2002 07:27 PM

1- I checkk /dev/cdrom with a ls command, It exist.

2- What do you mean by mounting /dev/hd[a/b/c/d] can I mount a cdrom by refering to it's IDE name??

(just to make sure, if CD is primary slave it's name would be hdb? If I understand corectly how this work.)

To stay on the same subject, let say I have a primary and a secondary master. Would the 2 drives be refer as hda and hdc ( hdb being reserve to the primary slave and hdd for the secondary slave??)

By the way : Thanks for the quick answer!!

Oh one more question, How is /dev/cdrom define to point to the corect device?? Is it in a configuration file, if so witch one??

acid_kewpie 04-10-2002 07:36 PM

yeah you got the principle fine. /dev/cdrom is always (well.... 99% of the time) just a symlink to the device name.. hdb for you. it's only done for clarity. the chances are thatt cdrom actaully points to hdc. if you can mount it with the ide device name then you should re create the symlink (ln -sf /dev/hdb /dev/cdrom) and it all should be ok.

BoldKiller 04-10-2002 09:01 PM

:(Still no luck!!:(

Have tried mount /dev/hdb /mnt/cdrom and mount -t iso9660 /dev/hdb /mnt/cdrom .

Still got the same message :
mount: /dev/hdb is not a valid block device

( have tried it with hdc (you never know!!) and got the expected Unknown device message. )

I'm really getting tired of that problem!! I mean (sorry aboout that but) Windows never gave me such problem!!!! (Of course it has a lot of other problem but still!)

:smash:

Please help me find a solution!!!!:cry: :cry:

linuxcool 04-10-2002 10:23 PM

Try running as root depmod -ae and then try mounting it again.

DMR 04-11-2002 06:43 PM

Quote:

Originally posted by BoldKiller
(just to make sure, if CD is primary slave it's name would be hdb? If I understand corectly how this work.)

To stay on the same subject, let say I have a primary and a secondary master. Would the 2 drives be refer as hda and hdc ( hdb being reserve to the primary slave and hdd for the secondary slave??)

You've got your device naming a little inside-out:

Primary Master= /dev/hda
Primary Slave= /dev/hdb
Secondary Master= /dev/hdc
Secondary Slave= /dev/hdd
If you have an ATA controller card, continue the above pattern starting with /dev/hde.

CD-ROMs are usually installed as the Secondary Master. If that's the case for you, your CD should be hdc, not hdb.

Post the contents of your /etc/fstab file.

BoldKiller 04-13-2002 10:11 PM

thanks for that DMR but that was just to be able to fully understand how Linux manages disk.

As for CD being on the secondary drive, I doubt it very much since it is a 486 we are talking about and the controler is a single IDE controller.

But thanks anyway for the post, now I thinks I fullly understand the naming convention for Linux.

By the way, tried reinstalling Linux, just to see. Still no luck, i'm thinking if going back to 7.0. Just to see if it is a problem with the way the new version handdle the IDE drives. Maybe something was change and it is not compatible with my old controller card??!?! Anyway, as Spock once said: " when you have illimanated all that is impossible all there is left is the improbable!!"

(just got to love this quote when working in computers!!)

I'll keep you posted on my progress.
Again, thanks everyone for the help!!

digital bots 04-13-2002 10:24 PM

well i have kinda the same problem this is how i fixed it. Thou i have a dvd and it doesnt mount but i am sure you dont have a dvd drive so this should work on your cdroms. go into /etc/fstab then try this.

/dev/hdb3 swap swap defaults 0 0
/dev/hdb2 / ext2 defaults 1 1
/dev/hdb1 /usr/local ext2 defaults 1 1
none /dev/pts devpts gid=5,mode=620 0 0
none /proc proc defaults 0 0
/dev/hdd /cdrom1 iso9660 defaults 0 0
/dev/hdc /cdrom iso9660 defaults 0 0
/dev/fd0 /floppy vfat defaults 0 0

linuxcool 04-13-2002 10:29 PM

BoldKiller, did you try my suggestion to run as root depmod -ae. There is a known bug in red hat 7.2 concerning the ' cdrom is not a valid block device '. Sometimes running ' depmod -ae ' will fix it.

BoldKiller 04-13-2002 10:45 PM

actully, I check it out (with man command) but I dont understand what that command does. Can you please explain to me a bit what it does??

thanks in advance.

BoldKiller 04-13-2002 11:16 PM

WOW, I'm really ashame of myself!!

the depmod -ae worked great. It fixed the cd-rom and the floppy problem. Thanks alot Linuxcool. Sorry I did not tried that before but I dont like to run commands I dont know about.

Again thanks alot Linuxcool you just allowed me to consider Linux as a good think again. Because in the beginning, I was really optimistic about this great software but lately I was starting to be a little (a lot ) frustrated and was thinking of throwing it at the ends of my arms!!

P.S. Could someone clarify for me what the depmod -ae command does.

Thanks again to all the great people who took time to help me.
I really appreciate it!!
Now I can get on with the test I want to conduct. Testing the network capacity of Linux!!!!

linuxcool 04-13-2002 11:44 PM

You're welcome. :)

I don't understand depmod much myself. According to the man page for it, the ' a ' option causes it to create a file that is used by ' modprobe ' to load the correct modules. Maybe someone else can do a much better job of explaining it.

Red Hat said something about it being a problem in their installer that was the cause for the ' not a valid block device ' error and it would be fixed in the next release.

Also, if you reinstall, you will have to run depmod -ae again.


Good luck!!! :D

Shak 05-20-2002 04:38 PM

I have the same problem

I tried depmod -ae the command does not exist for bash in rh 7.3

:(

Help Please!

Shak

linuxcool 05-21-2002 05:45 AM

Did you run the command as root? It must be run as root. If depmod -ae doesn't work, try /sbin/depmod -ae.


All times are GMT -5. The time now is 06:30 PM.