-   Linux - Newbie (
-   -   Mounting extended windows partition (

silkmaze 08-18-2003 10:54 AM

Mounting extended windows partition
Help. I have a Dell 2 hd's. The first one, 80GB is partitioned into 2x40, the second, a 60GB is partitioned into 1x40 and 1x20.

when I type in fdisk -l /dev/hda I get:

Disk /dev/hda: 80.0 GB, 80026361856 bytes
255 heads, 63 sectors/track, 9729 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/hda1 * 1 5100 40965718+ c Win95 FAT32 (LBA)
/dev/hda2 5101 5113 104422+ 83 Linux
/dev/hda3 5114 5178 522112+ 83 Linux
/dev/hda4 5179 9729 36555907+ f Win95 Ext'd (LBA)
/dev/hda5 5179 7728 20482843+ 83 Linux
/dev/hda6 7729 9003 10241406 83 Linux
/dev/hda7 9004 9663 5301418+ 83 Linux
/dev/hda8 9664 9728 522081 82 Linux swap

I want to mount hda5, thats where I have all my data, you know, stuff I've downloaded, etc.

I have created a mount point under /mnt called XP_P2P.
I then did the following

chmod a+rw /mnt/XP_P2P

No problems so far. then I mounted or tried to with

mount /dev/hda5 /mnt/XP_P2P -t vfat

and got the following message

mount: /dev/hda5 already mounted or /mnt/XP_P2P busy
mount: according to mtab, /dev/hda5 is mounted on /usr

I off I shuffled to /usr, no XP_P2P, I went back to /mnt and the mount point, XP_P2P was there, but it was empty.

So I'm kinda stumped. Where is all the data from my XP partition? Where IS my XP partition?

Anyone, Help please!!!

arunshivanandan 08-18-2003 10:57 AM

i think your hda5 is not a windows partition.

silkmaze 08-18-2003 10:57 AM

Ok, quick update.

I changed the mount to hda4, not 5, and got the following message.

mount: wrong fs type, bad option, bad superblock on /dev/hda4,
or too many mounted file systems
(aren't you trying to mount an extended partition,
instead of some logical partition inside?)

How am I supposed to mount a extended partition? Can I do it at all?


arunshivanandan 08-18-2003 10:59 AM

an extended partition is a primary partition divided into logical try mounting the logical partitions.[they are hda5,6,etc]

silkmaze 08-18-2003 04:34 PM

The logical partitions are already mounted, they are linux partitions. The extended partition is the XP one, that I see under XP as drive D: . I in the listing it is listed as Win95 Ext'd , not a FAT32. That's my problem. It should be seen as a Fat32 partition, it is under XP, but since linux doesn't see it that way, I get that "wrong fs type" error when I tried to mount it..

silkmaze 08-20-2003 06:18 AM

Ok, I finally got it . I changed the mounting of the hda1 to hdb1 and it worked. My C drive is hda1 and the D drive is hdb1. It worked perfectly.

Thanks for your help.

All times are GMT -5. The time now is 01:31 PM.