LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Mounting an NTFS drive (https://www.linuxquestions.org/questions/linux-newbie-8/mounting-an-ntfs-drive-111143/)

e_cubed99 11-01-2003 01:06 PM

Mounting an NTFS drive
 
Hi there. I'm a newbie to the whole linux game. I currently have a windows formatted NTFS drive running windows XP and a linux drive running redhat. I am trying to mount the NTFS drive in linux so i can access my data. i ran fdisk -l and the drive is called hda2. i tried the command mount /dev/hda2 and it didn't work. i was told "mount: can't find /dev/hda2 in /etc/fstab or /etc/mtab"

Any advice on how to deal with this would be greatly appreciated.

ps - a much smaller problem i have, when in the linux lab to run an a.out all i have to do is type a.out. on my computer i have to type ./a.out - how do i change it to be just a.out?

Thanks to anyone willing to help me out!

Ginux 11-01-2003 01:22 PM

Hi there... I would suggest to read this thread for the NTFS question, http://www.linuxquestions.org/questions/history/101687
you should try mount -t ntfs /dev/hda2 /mnt/xp <--- you have to create the xp dir. under /mnt before you do this.

I didn't understand the second question... but I think you should copy the command in /usr/bin or /usr/sbin but I'm not sure, maybe someone else could help you better.

Ginux

e_cubed99 11-01-2003 01:38 PM

ok, i tried that. it didn't like NTFS.

[root@eilbere eric]# mount -t ntfs /dev/hda2 /mnt/xp
mount: fs type ntfs not supported by kernel

i went to the link you supplied and tried d/l ing that patch and running it, but i was told that something went wrong and to check if i had proper permissions on the file. i don't know the ins and outs of how to update my kernel yet, i'm still a newbie.


ayn suggestions on how to deal with this one?

Ginux 11-01-2003 01:41 PM

Then try

modprobe ntfs

then the mount command, if that doesn't work then you should recompile the kernel with ntfs support.

e_cubed99 11-01-2003 01:45 PM

[root@eilbere eric]# modprobe ntfs
bash: modprobe: command not found


ummmm

Ginux 11-01-2003 01:51 PM

Sorry....
Type /sbin/modprobe ntfs
if it responds
modprobe: Can't locate module ntfs
Then you'll have to recompile

e_cubed99 11-01-2003 02:04 PM

cannot find the module . . .

how do i re-compile and get that module?

quatsch 11-01-2003 02:05 PM

redhat doesn't support ntfs out of the box. You have to install a package. Get it here:
http://linux-ntfs.sourceforge.net/info/redhat.html

michaelk 11-01-2003 02:06 PM

If your running RH see this:
http://linux-ntfs.sourceforge.net/info/redhat.html

You will need to add a mountpoint and an entry in /etc/fstab for users to mount the drive. You should be able mount the drive when logged in as root:

mount -t ntfs /dev/hda2 /mnt/mount_point (You will need to create a mount point).

e_cubed99 11-01-2003 02:24 PM

ok, now it is mounted. that worked. but it tells me that i do not have permission to access it when i try to do so from the gui or the console. the folder has a circle with a line through it on the gui, and in the console i get told "bash: cd: xp: Permission denied"

I'm sorry that i'm not the quickest at this stuff, and thank you very much for helping me out here. I really appreciate it.

E_Cubed99

**edit **

when i log in as root in the terminal i can acces the files, but i cannot do so from the gui. is there a way i can modify the permissions from the console so i can view it in the gui? or is there a way to log in as root in the gui?

**end of edit**

michaelk 11-01-2003 02:37 PM

With the partition unmounted make sure its permissions are set for all. Add an entry to your /etc/fstab file. It will automatically mount on boot.

/dev/hda1 /mnt/windows ntfs users,umask=0222,auto,ro 0 0

e_cubed99 11-01-2003 03:05 PM

THANK YOU VERY MUCH!!

It works! YAY!


All times are GMT -5. The time now is 08:50 PM.