LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-19-2003, 05:07 PM   #16
fancypiper
LQ Guru
 
Registered: Feb 2003
Location: Sparta, NC USA
Distribution: Ubuntu 10.04
Posts: 5,141

Rep: Reputation: 58

Quote:
Originally posted by thefetus
I've been reading for the last 2 days....none of it makes sense to me, hence me posting here.
Open an application that looks like a tv. It will have terminal in it's name if you let the mouse hover over the icon. That is an x terminal. Give the command su - and answer with root's password.

Give this command:

fdisk -l

What I get:
Code:
Wed Nov 19 03:01pm fancy@tinwhistle ~$ su -
Password: 
Wed Nov 19 05:01pm root@tinwhistle ~ # fdisk -l

Disk /dev/hda: 255 heads, 63 sectors, 4865 cylinders
Units = cylinders of 16065 * 512 bytes

   Device Boot    Start       End    Blocks   Id  System
/dev/hda1   *         1      1217   9772056    c  Win95 FAT32 (LBA)
/dev/hda2   *      1217      1229     99855   83  Linux
/dev/hda3          1230      1656   3429877+  83  Linux
/dev/hda4          1657      4865  25776292+   5  Extended
/dev/hda5          1657      1719    506016   82  Linux swap
/dev/hda6          1720      2146   3429846   83  Linux
/dev/hda7          2147      2573   3429846   83  Linux
/dev/hda8          2574      3719   9205213+  83  Linux
/dev/hda9          3720      4865   9205213+  83  Linux

Disk /dev/hdb: 255 heads, 63 sectors, 9729 cylinders
Units = cylinders of 16065 * 512 bytes

   Device Boot    Start       End    Blocks   Id  System
/dev/hdb1   *         1       973   7815591   83  Linux
/dev/hdb2           974      1946   7815622+  83  Linux
/dev/hdb3          1947      2919   7815622+  83  Linux
/dev/hdb4          2920      9729  54701325   83  Linux
What is the partition and filesystem that you want the icon for and where do you want it mounted?
 
Old 11-19-2003, 05:08 PM   #17
thefetus
Member
 
Registered: Nov 2003
Posts: 51

Original Poster
Rep: Reputation: 15
I'm completely lost in understanding "which desktop are you using:

my main menu functions is a red hat icon, i dont see a foot, and i dont see a k thingy

all i know is im using redhat 9.

i opened up konquerer and tried to open /mnt/windows and it told me i dont have permission rights to do so
 
Old 11-19-2003, 05:09 PM   #18
thefetus
Member
 
Registered: Nov 2003
Posts: 51

Original Poster
Rep: Reputation: 15
fancypiper, I've already mounted and done all of that...I simply want to Make a link to this hard drive so it appears on my desktop. Thanks tho.
 
Old 11-19-2003, 05:09 PM   #19
fancypiper
LQ Guru
 
Registered: Feb 2003
Location: Sparta, NC USA
Distribution: Ubuntu 10.04
Posts: 5,141

Rep: Reputation: 58
What Microsoft filesystem is it? Is it fat32 or NTFS?
 
Old 11-19-2003, 05:10 PM   #20
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Jessie"
Posts: 6,087

Rep: Reputation: 407Reputation: 407Reputation: 407Reputation: 407Reputation: 407
You could be more original in your choice of mountnames(!)

If windows is the one you are having trouble reading from it's because
Only root has permission to do this at the moment (check the leftmost, permissions column).
To change this, log in as root, and issue the command

chmod 0766 /mnt/windows
That should help.

If you get clever, you can do this in fstab automatically.
 
Old 11-19-2003, 05:13 PM   #21
thefetus
Member
 
Registered: Nov 2003
Posts: 51

Original Poster
Rep: Reputation: 15
[root@localhost fetus]# chmod 0766 /mnt/windows
chmod: changing permissions of `/mnt/windows': Read-only file system


---
did it and it still says i dont have enough permission to read file:/mnt/windows
 
Old 11-19-2003, 05:15 PM   #22
thefetus
Member
 
Registered: Nov 2003
Posts: 51

Original Poster
Rep: Reputation: 15
the filesystem is NTFS
 
Old 11-19-2003, 05:19 PM   #23
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Jessie"
Posts: 6,087

Rep: Reputation: 407Reputation: 407Reputation: 407Reputation: 407Reputation: 407
NTFS is a bit experimental from the linux end. Do NOT try writing to it!

You should be able to read from it though. I suspect that you have something wrong in /etc/fstab.
Maybe you could post the contents of that, and someone who uses NTFS will be able to help you put the correct entry into /etc/fstb that will allow you to read that NTFS partition as a regular user.
 
Old 11-19-2003, 05:20 PM   #24
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Jessie"
Posts: 6,087

Rep: Reputation: 407Reputation: 407Reputation: 407Reputation: 407Reputation: 407
Or, as root, try

chmod +r /mnt/windows

and then try and read it.
 
Old 11-19-2003, 05:20 PM   #25
thefetus
Member
 
Registered: Nov 2003
Posts: 51

Original Poster
Rep: Reputation: 15
LABEL=/ / ext3 defaults 1 1
LABEL=/boot /boot ext3 defaults 1 2
none /dev/pts devpts gid=5,mode=620 0 0
none /proc proc defaults 0 0
none /dev/shm tmpfs defaults 0 0
/dev/hda3 swap swap defaults 0 0
/dev/cdrom /mnt/cdrom udf,iso9660 noauto,owner,kudzu,ro 0 0
/dev/fd0 /mnt/floppy auto noauto,owner,kudzu 0 0
/dev/hdb1 /mnt/windows


---
the last line is supposed to be the auto-mount (which isnt working but no big deal for now)
 
Old 11-19-2003, 05:22 PM   #26
thefetus
Member
 
Registered: Nov 2003
Posts: 51

Original Poster
Rep: Reputation: 15
nope that other command didnt work (btw, i really appreciate your awesome effort to help me, you've helped me a lot so far, so thank you)
 
Old 11-19-2003, 05:25 PM   #27
fancypiper
LQ Guru
 
Registered: Feb 2003
Location: Sparta, NC USA
Distribution: Ubuntu 10.04
Posts: 5,141

Rep: Reputation: 58
I believe you are interested in the umask options for mounting.

NTFS - Common mount options
 
Old 11-19-2003, 05:26 PM   #28
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Jessie"
Posts: 6,087

Rep: Reputation: 407Reputation: 407Reputation: 407Reputation: 407Reputation: 407
I just fired up a PC with NTFS mounted and looked in /etc/fstab.

Try changing the last line of your /etc/fstab to:

/dev/hdb1 /mnt/windows ntfs iocharset=iso885915,ro,umask=0 0 0

and reboot. That should mount it properly and fix your permissions
 
Old 11-19-2003, 05:28 PM   #29
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Jessie"
Posts: 6,087

Rep: Reputation: 407Reputation: 407Reputation: 407Reputation: 407Reputation: 407
It's getting late, and I cany copy straight. Make the last line look like this:

/dev/hdb1 /mnt/windows ntfs iocharset=iso8859-15,ro,umask=0 0 0

sorry for the typo!
 
Old 11-19-2003, 05:28 PM   #30
thefetus
Member
 
Registered: Nov 2003
Posts: 51

Original Poster
Rep: Reputation: 15
i visited that site, fancypiper, and when i run those commands, its telling me i already mounted (which i did), am i supposed to simpley add that to the /etc/fstab file ?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
can't open files inside mounted usb drive NanoFxJ Linux - Hardware 2 05-19-2005 08:59 AM
Can't see files on mounted drive JMakar Linux - Hardware 2 04-15-2005 11:50 AM
USB Drive - Mounted OK, but files aren't recognized Dr3n Linux - Hardware 6 03-14-2005 07:00 PM
can't see files in mounted drive freeindy Linux - General 6 04-24-2004 09:40 AM
Files not showing up in mounted drive JCDenton Linux - Newbie 9 08-02-2003 12:17 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 07:53 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration