LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   mount -t cifs is not working on RHEL (https://www.linuxquestions.org/questions/linux-newbie-8/mount-t-cifs-is-not-working-on-rhel-773299/)

knockout_artist 12-03-2009 04:00 PM

mount -t cifs is not working on RHEL
 
Hi,

I tried to mount window's share on "2" linux boxes.


FC9:
Code:


# sudo  mount -t cifs  //d-data/share    -o username=name,password=passwd tmp-data/

works fine.


How ever on RH5
Code:


#mount -t cifs  //d-data/share    -o username=name,password=passwd tmp-data/

mount: wrong fs type, bad option, bad superblock on //d-data/share ,
      missing codepage or other error
      In some cases useful info is found in syslog - try
      dmesg | tail  or so

# dmesg | tail
 CIFS VFS: cifs_mount failed w/return code = -22

# lsmod | grep fs
nfsd                  285065  17
exportfs              38849  1 nfsd
auth_rpcgss            81889  1 nfsd
cifs                  281297  0
hfsplus              111817  0
nfs                  290189  0
lockd                  99185  3 nfsd,nfs
fscache                52385  1 nfs
nfs_acl                36673  2 nfsd,nfs
autofs4                57033  2
sunrpc                197897  15 nfsd,auth_rpcgss,nfs,lockd,nfs_acl

# lsmod | grep fat

vfat                  46401  0
fat                    85873  1 vfat

I did install samaba on the RH too.

any ideas?

Thanks

acid_kewpie 12-03-2009 04:40 PM

according to a couple of quick googles, -22 means an invalid argument. People on other forums seem to replace the hostname with an IP address and it works, few seem to know why though. Some others found installing the smbfs package on their ubuntu boxes made cifs work as expected with hostnames too.

knockout_artist 12-04-2009 08:36 AM

Thanks Chris,

But replacing host with does not work either.

Now I get this:

Code:


 mount: //XX.XX.X.X/share/ is not a valid block device

and
CIFS VFS: cifs_mount failed w/return code = -6

Same command works like a charm on FC9.

acid_kewpie 12-04-2009 12:19 PM

well that's a different error code isn't it? Have you tried googling for that code?


All times are GMT -5. The time now is 01:23 PM.