-   Linux - Newbie (
-   -   Mount, READ and WRITE reiserfs and ext3 partitions (

smiley_lauf 04-02-2006 03:32 PM

Mount, READ and WRITE reiserfs and ext3 partitions
I have been unsuccessful in getting fstab to load, amd make the other linux partitions writable.
The closest reference I could get to what I needed to do was here

but would prefer some specific instructions on getting my hda6 reiserfs and hda7 ext3 partions writable.

Cuurent fstab looka like this for hda6 and hda7:

/dev/hda6      /media/hda6    reiserfs defaults        0      2
/dev/hda7      /media/hda7    ext3  defaults        0      2

In both the cases I am able to read but not write. I am in ubuntu.

Can anyone help?

many thanks

gilead 04-02-2006 03:45 PM

If you look at your mount points you'll probably see ownership of root:root and permissions of drwxrwxr-x. Changing the ownership/permissions of the mount points before mounting won't work because when you mount the partitions, ownership will revert to root. The easiest way to make directories writable on the partitions is to change the ownership/permissions of the mount points or their top level directories after they are mounted.

For example, after mounting try the following, using a user:group from your system:

chown -R smiley:users /media/hda6
chmod -R ug+w /media/hda6

I don't have a spare partition to test this at the moment - so back up first if you have a complicated ownership/permissions structure on those drives...

smiley_lauf 04-02-2006 05:19 PM

sorry how do I check the ownership/permissions structure on those drives? I can them post this here and we ca take it from there?

Thanks Steve,

gilead 04-02-2006 05:30 PM

Open a terminal window and type ls -ld /media/hda6 /media/hda7 - that should do it. The other commands are also for a terminal window.

smiley_lauf 04-02-2006 05:44 PM

Let's start with the hda6 drive reiserfs ofrmat (I have ext3 on another machine so am unable to chekc that right now)Here is the output. Thanks


drwxr-xr-x 23 root root 688 2006-03-30 12:19 /media/hda6
Is this a complicated o/p structure? if not can I go ahead and try the code you gave me above? How do I make this happen each time aI boot, I am assuming I have to do this each time after I boot???? I may be wrong. Once again, many thanks,

gilead 04-02-2006 07:13 PM

Sorry, I should have shown that as ls -lR /media/hda6 /media/hda7 | more to display all of the files. Because the entries are in /etc/fstab the file systems should already be mounted. If that's the case, the ls command should show the info.

smiley_lauf 04-02-2006 07:32 PM

the | more option creates heaps of output, which part of the output shoudl I show you? Sorry, I am being very slow here?

gilead 04-02-2006 07:58 PM

No problem - what I'm doing is trying to find out whether there is just one owner of the files on those partitions or whether there are many owners. If the file listings are showing the owner as root:root for everything then it's a reasonably simple situation.

Since your mount point is under media, I'm assuming that those are data files (documents, music, video etc.) and not system files (executables, libraries, etc.) so it won't be a problem to change the ownership to a user:group of your choosing. If they are system files (for another Linux distribution for example) DON'T DO THE FOLLOWING.

If the files are data files, you can run the chown and chmod commands from earlier. It's a one-off step that won't need to be repeated. Just make sure you use a user/group that exists on your system:

chown -R smiley:users /media/hda6
chmod -R ug+w /media/hda6
chown -R smiley:users /media/hda7
chmod -R ug+w /media/hda7

The risks here are:
- If the files are not data files and in fact belong to another Linux system, changing ownership/permissions can break the normal operation of that system and is very bad;
- If there are multiple owners of files (e.g. you own one directory, a friend owns another and the person who sold you the PC owns a third directory), that separation of ownership is lost and everything is owned by one person. This is inconvenient but only a "little" bad in the scheme of things :)

smiley_lauf 04-02-2006 08:32 PM

Thanks, I am afraid they are system files (another linux OS), so I guess i am stuffed?? Can we not specify which directory on the partition say /home/smiley, ?


gilead 04-02-2006 08:41 PM

Yep, you can certainly do that - if you use something like:

chown -R smiley:users /media/hda6/home/smiley
chmod -R ug+w /media/hda6/home/smiley

It should work just fine.

smiley_lauf 04-02-2006 09:08 PM

ok, I will give it a tryright now, and report back asap

smiley_lauf 04-02-2006 09:12 PM


chown: `smiley:users': invalid user
and I am sure of the spelling and case sensitivity. So what am I not doing right?

gilead 04-02-2006 09:36 PM

You'll need to run the command as root - possibly it doesn't like the ':users' part (although it shouldn't matter). Although you've probably done this, can you confirm the username with grep smiley /etc/passwd and then try:

chown -R smiley /media/hda6/home/smiley

smiley_lauf 04-02-2006 09:56 PM


$ sudo chown -R smiley /media/hda6/home/smiley
chown: `smiley': invalid user

Sorry no luck.

gilead 04-02-2006 10:43 PM

It looks like a typo and that smiley doesn't exist in /etc/fstab. The way to confirm it is to combine the check for the username with the chown statement. If smiley exists in /etc/passwd the following will work:

chown -Rc $(grep smiley /etc/passwd | cut -d: -f1) /media/hda6/home/smiley

All times are GMT -5. The time now is 12:07 PM.