-   Linux - Newbie (
-   -   mount perimissions on external HD (

wgato 11-13-2010 04:35 PM

mount perimissions on external HD
i've read so many threads and pages regarding this problem, I dont even know if I've having the same issue as when I started. But I am going to start over from the beginning and ask for help this time.

I have a debian machine with an external harddrive. I have a windows machine on the same network from which I can read the files from the debian drive, but I cant write to it.
At some point in time (several months ago?) I could.

currently, I have this line in my /etc/fstab:
/dev/sdb1 /media/MUSIC/ vfat user,uid=1000,gid=1000,rw,umask=000 0 0

and i've tried a hundred different mount commands (but not as many as i've tried fstab lines) but generally have been using this at start up:
sudo mount /dev/sdb1 /media/MUSIC/
(i am under the impression that i should not have to use 'sudo' when doing this, since the fstab line includes 'user' but if i dont, the command fails)

no matter what I've tried, the permissions come out as owned by root:
drwxr-xr-x 905 root root 163840 2010-10-17 17:45 Music

attempting (as root) to change ownership of the directory also does not work:
chown: changing ownership of `/media/MUSIC/': Operation not permitted

i've confirmed that i have the uid and gid number correct with
id wgato

Could someone please help me?

Thank you very much for your time

Awatto 11-13-2010 04:48 PM

Please try the following set of options instead:


vfat users,rw,owner,umask=000 0 0
That is USERS, not USER. If that works, modify them to fit your user/group ID if you need it specific to them.

Your drive is formatted as FAT, and therefore you can only change the permissions of the drive (through umask), chown, chmod etc will not work.

wgato 11-13-2010 05:26 PM

thank you, that was foolish typo on my part, the actual line is:

/dev/sdb1 /media/MUSIC/ vfat user,uid=1000,gid=1000,rw,umask=000 0 0

but it doesnt seem to 'take' even after reboot. I can only mount the drive with the sudo command and cannot write to it unless i'm root on the debian machine.

i read, but didnt fully grasp, that you cant have users permissions on drives using a FAT file system. Good to know that chown/chmod is a dead end.

i'm not sure what i did different (ARGH), but i can now mount the drive as a regular user.
but i still cant write to it unless i'm root.

mryuck 11-13-2010 05:57 PM


attempting (as root) to change ownership of the directory also does not work:
chown: changing ownership of `/media/MUSIC/': Operation not permitted
Unmount /dev/sdb1. Then you will be able to change permissions and ownership of /media/MUSIC.

As Awatto said, its USERS not USER to allow normal users to mount the drive.

mount -t vfat -o umask=000 /dev/sdb1 /media/MUSIC
To mount the drive.

wgato 11-14-2010 12:15 AM

oh wow. that worked. thank you so much.
i spent the entire day on this.

thank you, thank you, thank you.

All times are GMT -5. The time now is 12:36 AM.