-   Linux - Newbie (
-   -   mount is not working (

Asmita_Nag 05-21-2010 05:23 AM

mount is not working
this is my first post in this forum. I am new to the world of FC9 and just started experimenting with it.
1.Today morning when I started FC9 all my Windows-xp' s drives were properly mounted; I inserted a USB drive and that was mounted properly.

2.After that I was trying to install qtsdk and it was facing some problem.
I was tensed and removed my USB drive without Unmounting.

3 Then I rebooted my machine, now neither my Xp-partitions nor my USB drive is getting mounted.

4. I opened the file /etc/fsatb
and added a line there:
/dev/sda2 /mnt/Folder ntfs umask=000,defaults 0 0

5. did mount-a
6. The error message I got:
mount: can't open /etc/mtab for writing: Stale NFS file handle
7 I tried to open mtab file
[B]Could not open the file /etc/mtab

So, 1. What I need to do now?
2. Is formatting the only one option left?
Asmita Nag.

timmeke 05-21-2010 07:27 AM

/etc/mtab should be on a local drive, the error message suggests it's on a network (NFS) share.
Could you do

ls -la /etc
and post the results?

What is interesting, is that /etc/fstab can be opened (normally mounts are on folder-level, so fstab & mtab would be part of the same mounted
filesystem, except if mount --bind were used). If there is a remote share involved, a reboot of the NFS server (or restart of nfsd) & a reboot of your machine should cancel any NFS connections.

The mtab file could be locked for writing (access blocked by the umount of the USB drive), but the reboot should have fixed that.
The same should be true for the stale NFS handle.

A copy of the contents of /etc/fstab would be nice too, as well as a summary of the drives (XP & other) you are talking about.

What you could try, is to boot up interactively or in a special mode without mounting any drives (perhaps even from a LiveCD).

Asmita_Nag 05-21-2010 12:19 PM

Thanks Timmeke!
1. My machine is a stand-alone one and is not connected to any network
2. I ran the command but can't post the detailed result (Actually USB drive is not working, so I could not bring the result) but what i noticed:

-????????? ? ? ? ? ? mtab
-rw-r--rww 1 root root 635 2010-05-21 19:51 fstab
-rw-r--rww 1 root root 586 2010-05-21 19:50 fstab~

these are some important extract from the result.

3. If it does not help, then I will copy the content of fstab too.
4. I did not try any interactive booting or special-mode booting. How can I do that?

Thanks & Regards,
Asmita Nag.

timmeke 05-21-2010 06:41 PM

is just a backup copy of fstab, saved by the text editor.

The mtab with question marks is more worrysome.
I would suggest switching to root user, and then trying

rm -f /etc/mtab
touch /etc/mtab

Make sure the new mtab file is read-write accessible for root user.
Then reboot - Linux should fill the mtab file when it mounts filesystems.

Do you know which boot loader (grub, lilo) you're using?
Usually, there is a quick hint (e.g. press "I" for interactive setup), press "F2" for boot menu,...).
I suggest you google around for the exact way to do it with FC9.

Asmita_Nag 05-22-2010 12:54 AM

Thanks again!

I tried to do rm and touch. In both the cases, it is saying that
rm: cannot remove '/etc/mtab' :Stale NFS file handle
touch: cannot touch '/etc/mtab' :Stale NFS file handle

Thanks & Regards,
Asmita Nag.

linuxlover.chaitanya 05-22-2010 01:13 AM

That is strange because the error you get is related to the NFS shares being removed even when they are still shared on clients. But as you do not have NFS server it seems bit weird. I googled for it and could not find very relative answers. But the options told are to use -O option while mounting.
Look at these if you have not:

John VV 05-22-2010 02:10 AM


I am new to the world of FC9 and just started experimenting with it....

1. My machine is a stand-alone one and is not connected to any network
so this is why you have installed / are running a old and no longer supported version of fedora

fedora 9 hit End Of Life about a year ago
the current is 12 and 13 will be released in a few days.

was the usb a ntfs formatted ? most are fat32

and if ntfs ( i do not recall if kmod-ntfs was still in use in 9 )
or the ( at the time the very EXPERIENTIAL) ntfs-3g . what is installed on the no-longer supported fedora 9

All times are GMT -5. The time now is 02:51 AM.