Welcome to the most active Linux Forum on the web.
Go Back > Forums > Linux Forums > Linux - Newbie
User Name
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!


  Search this Thread
Old 01-26-2002, 03:54 PM   #1
LQ Newbie
Registered: Dec 2001
Posts: 12

Rep: Reputation: 0
mount: /dev/fd0 is not a valid block device

Hi all,
I am using RH6.1 when i try to mount floppy i get the above mentioned error message.
/etc/fstab seems to be ok
/dev/fd0 /mnt/floppy ext2 user,noauto 0 0
I searched google and couldnt fix that with what i learnt there. what is the reason for getting that.
i see many people having the same prob with cdrom

Also i have another problem
when i try to mount cdrom i get no medium found.
even there i made sure there is /mnt/cdrom exists
and /etc/fstab is ok.

Also when i try to see what is going on in /var/log/messages it says permission denied.
I dont see any specific messages in there( after logging as root)about mounting cdrom or floppy. whether i am fine or have some trouble.

can sb. help me out pl.

Old 01-26-2002, 04:26 PM   #2
Registered: Jan 2002
Location: Cheyenne Wyoming
Distribution: Debian/Raspbian/Mint
Posts: 717

Rep: Reputation: 32
what kind of floppy? dos or linux?

"mount -t msdos /dev/fd0 /mnt/floppy"
"mount -t vfat /dev/fd0 /mnt/floppy"
"mount -t iso9660 /dev/cdrom /mnt/cdrom"

Try those as root
Old 01-27-2002, 05:53 AM   #3
Senior Member
Registered: Dec 2000
Location: Gothenburg, SWEDEN
Distribution: OpenSUSE 10.3
Posts: 1,028

Rep: Reputation: 45
I don't know if Red Hat's kernel supports auto detection of file system but you could try to edit your fstab for floppy, replace ext2 with auto.
If the kernel supports it then the system will try to figure out if the disk is formated for dos or for linux.
Old 01-28-2002, 12:58 PM   #4
LQ Newbie
Registered: Dec 2001
Posts: 12

Original Poster
Rep: Reputation: 0
Reg. Hanzerik

I tried what hanzerik said,

for mount -t vfat /dev/fd0 /mnt/floppy
mount: wrong fs type, bad option, bad superblock on /dev/fd0,
or too many mounted file systems

for mount -t iso9660 /dev/cdrom /mnt/cdrom
mount: block device /dev/cdrom is write-protected, mounting read-only
mount: No medium found
Old 03-23-2002, 06:47 PM   #5
Registered: Mar 2002
Location: Victoria, BC, Canada
Distribution: None (
Posts: 103

Rep: Reputation: 15
you can't mount a drive if you don't have a disk in it.
Old 09-23-2004, 03:13 PM   #6
LQ Newbie
Registered: Jul 2004
Posts: 4

Rep: Reputation: 0
Check to make sure that you've built the floppy drive into your kernel and not that you've loaded it as a module... I did the same thing... You'll have to recompile the kernel but that's not a hard process...

Oh and my /etc/fstab file line looks like this.

/dev/fd0 /mnt/floppy msdos noauto,user 0 0

Last edited by kan4132; 09-23-2004 at 03:16 PM.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
mount:/dev/fd0 is not a valid block device yat Linux - General 2 11-26-2010 11:45 AM
Post subject: mount /dev/fd0 is not a valid block device lil_becky Debian 3 05-16-2008 02:25 PM
/dev/fd0 is not a valid block device intmail Slackware 2 07-21-2005 06:52 AM
mount /dev/fd0 is not a valid block device jolly_good2000 Linux - Hardware 12 07-31-2003 06:27 AM
/dev/fd0 is not a valid block device allnight Linux - General 7 02-21-2002 08:42 PM > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 12:56 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration