Welcome to the most active Linux Forum on the web.
Go Back > Forums > Linux Forums > Linux - Newbie
User Name
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!


  Search this Thread
Old 04-10-2004, 08:18 PM   #1
LQ Newbie
Registered: Apr 2004
Location: Washington, DC
Distribution: RedHat Linux Professional Workstation
Posts: 4

Rep: Reputation: 0
mount cdrom won't work, consultations please!

can anyone help with a RedHatLinux PRO Workstation, cdrom mount consultation?

For reasons I can't seem to make headway on, my cdrom and cdrom1 devices are not mounting properly, though the floppy mounts easily from either Unix prompt or KDE/Gnome.

>mount /dev/cdrom and >mount -t iso9660 /dev/cdrom1 /mnt/cdrom1 -r
give an error message,
mount: wrong fs type, bad option, bad superblock on /dev/cdrom, or too
many mounted filesystems.

>mount shows /mnt/floppy, but no cdrom's.

/etc/fstab shows

/dev/cdrom /mnt/cdrom udf,iso9660 noauto,owner,kudzu,ro 0,0
/dev/cdrom1 /mnt/cdrom1 udf,iso9660 noauto,owner,kudzu,ro 0,0
/dev/fd0 /mnt/floppy auto noauto,owner,kudzu 0,0

When the machine boots up, a statement is given,

"starting automount: No mount points defined"

Is it obvious what am I doing wrong? The machine should be basically unused, new.

Thank you for your incredible help!!
Rich , Washington, DC 20011,
Old 04-10-2004, 08:28 PM   #2
Registered: Feb 2004
Location: New York City
Distribution: Debian
Posts: 97

Rep: Reputation: 15
what type of cd are you trying to mount? It is important to note that you cannot mount a audio cd because of its type. So I hope that is the case that you are trying to mount an audio cd (which can't be done). Otherwise give us some more information.
Old 04-10-2004, 08:49 PM   #3
LQ Veteran
Registered: Mar 2003
Location: Boise, ID
Distribution: Mint
Posts: 6,642

Rep: Reputation: 85

1. Are you trying to mount an audio CD? As souljah indicated, don't. Music CD's don't need to be mounted.
2. Do you actually have a data CD (not music, and not a blank) in the CD before you try to mount it? Attempting to mount an empty CD drive won't do anything.
3. Do you have one CD drive or two? Based on your comments and fstab is sounds like there are two. Could it be that you've got the disk in /dev/cdrom1 but you are mounting /dev/cdrom?
4. Have you tried to use just the basic mount command: mount /dev/cdrom /mnt/cdrom
Don't worry about setting it to read-only, since by definition a CD-ROM is read only, and skip the bit about the specifying the file type. In my experience you only need to specify the file type if the system can't figure it out on its own.
5. Are you using SCSI emulation? Perhaps you can try: mount /dev/scd0 /mnt/cdrom

Good luck with it -- J.W.
Old 04-10-2004, 09:22 PM   #4
LQ Newbie
Registered: Apr 2004
Location: Washington, DC
Distribution: RedHat Linux Professional Workstation
Posts: 4

Original Poster
Rep: Reputation: 0
dear JW and Souljah, Thank you!!! they are audio cds! stupid me!
however, is there an easy explanation why neither RHL's Media Player
nor KSCD cd player, do not play these audio cds?
there are two cd units, cdrom and cdrom1; they both had audio cds in
them. however, neither of them give the musical titles and
nothing is played! the two cd players "panels" look fine and linux
mount shows neither is mounted.

do i need to buy software or is there just something else which
i've clearly neglected? thank you for such thoughtful answers!!!
Rich, DC
Old 04-10-2004, 09:50 PM   #5
Registered: Jan 2004
Posts: 74

Rep: Reputation: 15
Are the files mp3 if so Red Hat by default will not run them why I don't know something about hacks songs or something like that.

If you want to run software my suggestion which I did was to a search for xmms on google then download that software and run it as in install it you can actually do a yum install xmms but don't because that doesn't solve your problem.

You need to install it from source
Old 04-10-2004, 10:52 PM   #6
Registered: Feb 2004
Location: New York City
Distribution: Debian
Posts: 97

Rep: Reputation: 15
Both kde and gnome both have their own cd playing software, you don't need to mount it (because cds do not have filesystems to mount). Personally, I use cdcd to play cds (but it is from command line). KDE has KsCD which should work. I dunno everyone has their own preference.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
CDROM refuses to mount, /dev/cdrom does not exist shane25119 Linux - Hardware 10 08-02-2009 11:43 PM
mount /dev/hdc /dev/cdrom doesn't work ShrikesHarvest Linux - Newbie 10 02-21-2009 08:05 AM
Cant mount cdrom in normal user, tried to set permissions, no work. Kindly help me. RHLinuxGUY Slackware 2 09-13-2004 10:35 PM
I can't mount CDROM dxtr Linux - Hardware 8 06-23-2004 10:21 PM
mount /media/cdrom doesn't work HDD Linux - Hardware 4 03-05-2004 10:42 AM > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 03:53 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration