LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-24-2006, 01:21 AM   #1
dzapffe19
LQ Newbie
 
Registered: Jun 2006
Posts: 23

Rep: Reputation: 15
mount cd drive


I just want to watch my dvd on my suse 10.1 laptop...




davis@linux-yl0f:~> su -
Password:
linux-yl0f:~ # mount /media/cdrom
mount: can't find /media/cdrom in /etc/fstab or /etc/mtab
linux-yl0f:~ # mount /dev/cdrom
mount: can't find /dev/hdc in /etc/fstab or /etc/mtab
linux-yl0f:~ # mount /media/cdrom /media/cdrom
mount: mount point /media/cdrom does not exist
linux-yl0f:~ # mount /dev/cdrom /media/cdrom


**************after that last command it does not respond, or at least it sits there a long time... so I closed it



Fujitsu c2010
Suse 10.1

Thanks,
Davis

Last edited by dzapffe19; 06-24-2006 at 01:23 AM.
 
Old 06-24-2006, 01:44 AM   #2
SlackDaemon
Member
 
Registered: Mar 2006
Distribution: RedHat, Slackware, Experimenting with FreeBSD
Posts: 222

Rep: Reputation: 30
mounting a cd/dvd drive

Hi,

If your dvd drive is a combo try:

mount -t iso9660 /dev/cdrecorder /media/cdrom -o ro

if it is just a regular DVD drive try:

mount -t iso9660 /dev/cdrom /media/cdrom -o ro

depending on what distribution you are using you may not be able to view a DVD movie without installing a third-party packages and making some extra configurations.
 
Old 06-24-2006, 02:13 AM   #3
dzapffe19
LQ Newbie
 
Registered: Jun 2006
Posts: 23

Original Poster
Rep: Reputation: 15
Thanks!

Now, xine is dropping frames

I think I need to enable DMA, how?




Password:
linux-yl0f:~ # hdparm /dev/hda

/dev/hda:
multcount = 16 (on)
IO_support = 0 (default 16-bit)
unmaskirq = 0 (off)
using_dma = 1 (on)
keepsettings = 0 (off)
readonly = 0 (off)
readahead = 1024 (on)
geometry = 38760/16/63, sectors = 39070080, start = 0
linux-yl0f:~ # hdparm /dev/hdc

/dev/hdc:
IO_support = 0 (default 16-bit)
unmaskirq = 0 (off)
using_dma = 0 (off)
keepsettings = 0 (off)
readonly = 0 (off)
readahead = 1024 (on)
HDIO_GETGEO failed: Inappropriate ioctl for device
linux-yl0f:~ # hdparm /dev/cdrom

/dev/cdrom:
IO_support = 0 (default 16-bit)
unmaskirq = 0 (off)
using_dma = 0 (off)
keepsettings = 0 (off)
readonly = 0 (off)
readahead = 1024 (on)
HDIO_GETGEO failed: Inappropriate ioctl for device
linux-yl0f:~ #



**********************************************
You can enable DMA mode with the following command:

hdparm -d1 device_of_your_drive_that_supplies_video_data

In some cases where this fails it helps to specify the dma mode to use, for example:

hdparm -d1 -X 66 device_of_your_drive_that_supplies_video_data

In RedHat 8.0 an additional entry in /etc/modules.conf

options ide-cd dma=1

should help (reboot for this change to take effect).
****************************************************************

How do I use that? Whats device_of_my_drive_that_supplies_video_data?





Thanks,
Davis

Last edited by dzapffe19; 06-24-2006 at 02:17 AM.
 
Old 06-24-2006, 02:36 AM   #4
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 677Reputation: 677Reputation: 677Reputation: 677Reputation: 677Reputation: 677
First of all, SuSE 10.1 uses udev. The dvd should be mounted automatically under the /media directory.

You can turn DMA on for your DVD drive in YaST.
Start the YaST Control Center. Select Hardware in the left column, then click on the "IDE DMA Mode" icon in the window on the right hand side.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
mount: unknown filesystem type 'ntfs' when trying to mount windows drive... DiZASTiX Linux - Hardware 12 09-28-2008 08:29 PM
Mount usb drive, umount and mount another drive arubin Linux - Hardware 9 01-17-2007 04:46 AM
when i mount my USB Flash Drive A Messenge has come that mount: can't find /dev/sda/h feda82 Red Hat 2 12-24-2005 08:16 AM
when i mount my USB Flash Drive A Messenge has come that mount: can't find /dev/sda/h feda82 Red Hat 1 12-24-2005 05:25 AM
when i mount my USB Flash Drive A Messenge has come that mount: can't find /dev/sda/h feda82 Red Hat 2 12-24-2005 03:15 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 12:26 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration