LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Mount 256MB of flash memory from digital voice recorder to retieve deleted files (https://www.linuxquestions.org/questions/linux-newbie-8/mount-256mb-of-flash-memory-from-digital-voice-recorder-to-retieve-deleted-files-725162/)

RednecKLinuxNub1 05-11-2009 06:16 AM

Mount 256MB of flash memory from digital voice recorder to retieve deleted files
 
I have not tried anything on my own and don't know where to start..IF..anyone has any solutions.
I am trying to figure out a way to mount the 256MB or flash memory from an Olympus digital recorder so that I can recover the files that were deleted off of the device. Nothing has been recorded over on the device since the files were deleted. These files were in 3 separate folders out of a total of 4 folders. The recorded file format is CELP+ADPCM (wave), according to the manufactures specs. Olympus VN-4100pc.
Is any of this possible? Please advise.

onebuck 05-11-2009 07:31 AM

Hi,

Welcome to LQ!

You could use 'test-disk' to recover the files. 'SystemRescueCd' is a good forensic tool that contains several good tools along with 'test-disk'.

These links and others can be found at 'Slackware-Links'. More than just SlackwareŽ links!

BTW, be sure to make a backup in case of trouble attempting to recover the files from the storage device.

RednecKLinuxNub1 05-11-2009 08:37 AM

No files showing to backup or try to recover...
 
I have downloaded test-disk and also tried using photorec but the problem is that the drive or flash memory is not being recognized by the system.

I don't know how to mount the drive and have been reading conflicting answers on multiple posts regarding how it can be done...if it can be done.

As far as backing up the drive, same thing. There is no device that is showing until I run the Olympus Digital Wave Player app that it came with, even then only the emptied folders are showing in the application but not the system.

michaelk 05-11-2009 08:46 AM

The recorder does not connect to the PC as a mass storage device so any disk recovery tools will not work. In addition I know no other way of accessing the unit without using the windows software/drivers and AFAIK there is no support for linux or Macs.

I know of no way of recovering deleted files.

Unfortunately I think you are out of luck.

RednecKLinuxNub1 05-11-2009 08:53 AM

Thanks for letting me know. Would a company specializing in data recovery be able to retrieve the files?

michaelk 05-11-2009 09:16 AM

I have no idea on how the device works or how it stores data to flash. I am sure there is someone out there that can retrieve it but it will be very expensive.

RednecKLinuxNub1 05-11-2009 11:52 AM

Thanks again for your advise.

michaelk 05-11-2009 12:05 PM

Good luck. Hopefully the data is still in flash memory.

NeddySeagoon 05-11-2009 02:33 PM

michaelk,

FLASH memory is not normally erased until you need to write to it. The erase is part of the write process.
This means its likely that you data is still in the memory but you have lost all the links to it.

If the FLASH is a card of some sort, put in into a card reader then use dd to make an image of the /dev/sd.. that apprears. The same thing should work if the Olympus digital recorder appears as a USB storage device.
You need SCSI disk support and usb_storage available. Check the output of lsmod.

Once you can find the device file /dev/sd.. as root, make a copy in a file with dd
Code:

dd if=/dev/sd.. of=/Olympus.img
read man dd to understand what this does. Now put the FLASH away in a safe place and work with the file.

To be ultra cautious, make a copy of the file to work with. The tools others have mentioned are pretty good at recovering things.

michaelk 05-11-2009 03:04 PM

NeddySeagoon,
Most likely the data is still intact but since the inner workings are basically hidden from the user it is not possible to say with any confidence. The flash memory is integral to the device and is not accessible in any manner. The only way to access data is via windows software. The only way I see of recovering the data is to dissect the memory from the recorder and read the 1s & 0s from the individual cells.

onebuck 05-12-2009 08:16 AM

Hi,

If the memory is a flash that is independent that can be removed from the device then it indeed can be used as long as there is a device to read it with. If you have a card reader that will allow you to insert then a utility such as 'test-desk' can be used. I made the assumption that is what you were attempting instead of mounting a camera device.

As long as the device can be read or recognized then it should be able to be repaired. If it were a camera or whatever that has the memory contained then that device will have to be recognized. Most memory modules be it a flash drive, card or whatever will/can be read with the proper device drivers. It does not require you to have the device driver (original device) that the memory was contained or utilized by.

Most systems will have the driver for a card reader that supports the type of card that can be used. Once you insert then the device interface will provide the means to read/write to the device contained within the card reader. The I/O interface for a card reader is typically a USB assignment therefore the memory can be handled by utilities as long as the memory follows the normal conventions.

NeddySeagoon 05-12-2009 12:34 PM

michaelk,

How does the device connect to the PC?
If its usb, boot linux plug in the device and post the output of
Code:

dmesg | tail -n 20
That will show how linux sees it just now.

Also post the content of /proc/bus/usb/devices. That will show exactly what usb devices you have connected.

We can take it from there.

michaelk 05-12-2009 04:44 PM

To help the OP... It is a USB device.
http://htyp.org/Olympus_VN-480PC

dmesg:
[ 598.260000] usb 2-2: new full speed USB device using uhci_hcd and address 4
[ 598.440000] usb 2-2: configuration #1 chosen from 1 choice

lsusb:
Bus 002 Device 004: ID 07b4:020d Olympus Optical Co., Ltd Digital Voice Recorder VN-240PC

/proc/bus/usb/devices
T: Bus=02 Lev=01 Prnt=01 Port=01 Cnt=02 Dev#= 4 Spd=12 MxCh= 0
D: Ver= 1.10 Cls=ff(vend.) Sub=ff Prot=ff MxPS= 8 #Cfgs= 1
P: Vendor=07b4 ProdID=020d Rev= 1.00
S: Manufacturer=OLYMPUS IMAGING CORP.
S: Product=DIGITAL VOICE RECORDER
C:* #Ifs= 1 Cfg#= 1 Atr=80 MxPwr=100mA
I:* If#= 0 Alt= 0 #EPs= 3 Cls=ff(vend.) Sub=ff Prot=ff Driver=(none)
E: Ad=81(I) Atr=02(Bulk) MxPS= 64 Ivl=0ms
E: Ad=02(O) Atr=02(Bulk) MxPS= 64 Ivl=0ms
E: Ad=83(I) Atr=03(Int.) MxPS= 8 Ivl=50ms

I was wrong... there is a linux driver but it looks like it only works in extra high quality mode for this particular device:
http://code.google.com/p/odvr/

Might want to email the project owner and see if he has any ideas. However without being able to access the flash memory directly I do not know of any way to recover lost data.

onebuck 05-12-2009 08:56 PM

Hi,

I agree that if you cannot get to the memory directly then the OP has a problem. Since Linux doesn't support the device then other means to recover via M$ could be possible.

NeddySeagoon 05-13-2009 03:31 PM

michaelk,

The linux driver appears to depend on the device cooperating to find the data in the FLASH within the device.
That won't help as the pointers to the data are gone. You need low level access to the FLASH memory.

Maybe thats a trick the driver author knows how to perform ?
It has to be worth an email.

That the linux driver does not support all the sound qualities is not important. If you can get block level access to the device, you can read the files out, recreate the indexes and write everything back without ever understanding the internal file structure of the device. Now you can use the normal (windows?) driver to read the files.


All times are GMT -5. The time now is 10:38 AM.