LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-15-2018, 06:48 AM   #1
Rakshita
LQ Newbie
 
Registered: Oct 2018
Location: India
Posts: 4

Rep: Reputation: Disabled
Unhappy Most stable version of Linux or Ubuntu for my system that hangs and has to be quite often forced shutdown.


Hello,
1.) I am new to the Linux environment and still in a learning process. I have started to encounter some issues regarding the Linux environment.
2.) I am a network admin in an MNC that has a no. of PC's that are working on Linux or Ubuntu environment.
3.) Most of the systems have the following specifications:

Ram : 3GB(1Gb+2Gb)
Processor: Pentium(R) Dual-Core CPU E5300 @ 2.60GHz × 2
Graphics: Intel® G33
OS Type: 64-bit
Disk: 156.4 GB

4.) The problem is that the PCs often encounter this problem that the hang multiple times daily and completely freezes. Force shutdown is the only way out that I have been implementing. But this degrades the RAM performance and every third time I have to remount the RAM from the system.
5.) I have tried Linux mint Cinnamon, Linux Mint Qiana, Linux Mint Rosa, Linux Mint Sylvia, Linux Mint Maya but all have the same issue.
6.) I have seen this problem mostly during the Google Ad Words and Upwork. Sometimes Firefox causes a serious hang to the system too. The System has all the installs and updates on "Never". When the system hang is at a peak, I often go for a
$ sudo apt-get update and upgrade

Please help me out. Thanks in advance.
 
Old 10-15-2018, 06:55 AM   #2
//////
Member
 
Registered: Nov 2005
Location: Land of Linux :: Finland
Distribution: VirtualBox win 10 guest | OpenBSD 6.5 bridge | Fedora 30 | windows 10 pro 64bit
Posts: 391

Rep: Reputation: 181Reputation: 181
i would install Debian, its famous for being the most stable distro.
 
1 members found this post helpful.
Old 10-15-2018, 07:00 AM   #3
jsbjsb001
Senior Member
 
Registered: Mar 2009
Location: Earth? I would say I hope so but I'm not so sure about that... I could just be a figment of your imagination too.
Distribution: Currently OpenMandriva. Previously openSUSE, PCLinuxOS, CentOS, among others over the years.
Posts: 3,104

Rep: Reputation: 1595Reputation: 1595Reputation: 1595Reputation: 1595Reputation: 1595Reputation: 1595Reputation: 1595Reputation: 1595Reputation: 1595Reputation: 1595Reputation: 1595
Based on what you're saying it sounds more like a hardware problem, particularly if you have tried multiple distributions and are still getting the same problems.

You should run memtest86+ to check the RAM for any faults. Maybe your hard drive(s) as well.
 
2 members found this post helpful.
Old 10-15-2018, 07:42 AM   #4
Rakshita
LQ Newbie
 
Registered: Oct 2018
Location: India
Posts: 4

Original Poster
Rep: Reputation: Disabled
Thank you for your kind reply. I will be trying the Debian version as suggested by @//////. Yes, I have already tried that but I will be trying it again @jsbjsb001. I will let you know if the problem persists.
Thank you once again.

Last edited by Rakshita; 10-15-2018 at 07:43 AM.
 
Old 10-15-2018, 08:35 AM   #5
hazel
Senior Member
 
Registered: Mar 2016
Location: Harrow, UK
Distribution: LFS, AntiX, Slackware
Posts: 3,406
Blog Entries: 9

Rep: Reputation: 1897Reputation: 1897Reputation: 1897Reputation: 1897Reputation: 1897Reputation: 1897Reputation: 1897Reputation: 1897Reputation: 1897Reputation: 1897Reputation: 1897
Mint is really designed for desktop machines, not servers. If you want to stay in the Debian family, use the Stable branch of Debian (I think that's currently Debian Stretch). If you want to look further afield, OpenSuse and Centos are both server-oriented.
 
Old 10-15-2018, 01:58 PM   #6
fatmac
Senior Member
 
Registered: Sep 2011
Location: Upper Hale, Surrey/Hants Border, UK
Posts: 3,123

Rep: Reputation: Disabled
When were the file systems last checked, the ram reseated, also the hard drive cables & connections checked(?). Do you have a good constant power supply(?).
 
Old 10-16-2018, 07:53 AM   #7
Rakshita
LQ Newbie
 
Registered: Oct 2018
Location: India
Posts: 4

Original Poster
Rep: Reputation: Disabled
Hello,
1. Thank you for your support and help. I am exploring the world of Linux. I got interested in Linux tara 19. I have downloaded it and launched it. So far no crashes. Still, I was to know if it is a recommended Linux Debian or not.
2. Yes, I have checked all the cabling of the hard drives to the motherboard, RAM was checked and remounted around 3 days back. The power supply is little faulty, that's why we have UPS on every PC though. I have no need for Server-based Debians rather just for normal daily use with most of the work on heavy processing sites such as Ad Words.
3. I will be running memtest86+ once I get this issue in any of my systems.

Thank you so much everyone
 
Old 10-17-2018, 11:26 PM   #8
boombaby
Member
 
Registered: Mar 2016
Posts: 93

Rep: Reputation: Disabled

Hello, Rakshita...


While I agree a particular distro might "solve" the freeze problem, I would like to point you to a story about freeze-ups that I was having.

My freeze-ups were occuring almost on a daily basis, and required a hard boot (forced switch off, then new boot).

I posted in the forum of the distro that I am using (ie Linux MX ). Actually, the story began there with someone else who had a similar "freeze" problem to mine. However he eventually sorted his situation out (as you can read) but mine persisted, so I ended up driving the thread.

You can read the story starting here...

. . . . http://www.mxlinux.org/forum/viewtop...ad035e6fe7d2e7

As you can see Members, trying to help, stepped through all sorts of questioning & advice.

However, for me the resolution came after switching the drivers.

You can see when it started to work out here...

. . . . http://www.mxlinux.org/forum/viewtop...7d2e7&start=10

at post #19 from dolphin_oracle

See; my HP system - like yours - is Intel-based, with Intel graphics.


My final confirmation of the solution was in post #24 . Till now (Oct'18) I still have not had a single freeze-up since then (July).


Hope this helps.

boombaby
_
 
1 members found this post helpful.
Old 10-18-2018, 03:49 AM   #9
Rakshita
LQ Newbie
 
Registered: Oct 2018
Location: India
Posts: 4

Original Poster
Rep: Reputation: Disabled
Hello everyone,
Thank you so much for your positive replies.

1. I have been working with Linux 19 Tara, and found some glitches like for example when I try to switch to "Panel edit mode", I can move the applets but everything freezes. I can't even open the Start menu, all I can open is the terminal. Ultimately I reboot the system.

2. Thank you so much @boombaby for your thread, it is really interesting thread to follow. I have read the solution that you have on post #23, but I think it is neither a icon-shadowing problem nor a Libre-office problem.

3. The issue is something relating to the hardware. I have been encountering this problem only on the Google Ad-Words sites and Google Drives, and other heavy processing sites. Even though I have switched browser may times, it crashes.
But, its interesting to notice that, you had some issue in cut paste, i have similar problem when I toggle the tabs on browser.
In your words:
BEFORE (ie when I was using the linux mgmnt, not Intel driver) I noticed that on many occasions when I was at a (often-changing) website and cut-&-pasting some elements I would get freezes. After a reboot, and then returning to the website I found that it had updated its webpages. So, it seemed to me, that if the website made changes to its pages while I was working in a sub-page I COULD (but not always) get system freeze. (I couldn't explain that. I thought it might be something to do with "caching" of pages.)

Do you think something is wrong with cache files in Linux Mint Cinnamon 17/16 ?

4. Back to the situation, I have been encountering this :
System is switched on, gets to the desktop and everything. When I just start my browser, do some document's wok, all of a sudden my mouse got stuck, even light goes off (mouse), but the CPU was still running. I checked for a while, I think my system got hanged.
Then, after a quick restart, the monitor goes to sleep mode. I tried for several times and encountered the message like, "no cable connected". Finally, I remounted Ram and got still got nothing. I have no idea about this situation.

Is my hard disk faulty?

Thanks in advance
 
Old 10-18-2018, 10:23 AM   #10
jsbjsb001
Senior Member
 
Registered: Mar 2009
Location: Earth? I would say I hope so but I'm not so sure about that... I could just be a figment of your imagination too.
Distribution: Currently OpenMandriva. Previously openSUSE, PCLinuxOS, CentOS, among others over the years.
Posts: 3,104

Rep: Reputation: 1595Reputation: 1595Reputation: 1595Reputation: 1595Reputation: 1595Reputation: 1595Reputation: 1595Reputation: 1595Reputation: 1595Reputation: 1595Reputation: 1595
Quote:
Originally Posted by Rakshita View Post
...
System is switched on, gets to the desktop and everything. When I just start my browser, do some document's wok, all of a sudden my mouse got stuck, even light goes off (mouse), but the CPU was still running. I checked for a while, I think my system got hanged.
...
I take it you are using a USB mouse? If so, it sounds like you're saying that your mouse stops responding to any input, the mouse cursor stops dead on the screen, and the rest of the system freezes?

In that case, it maybe the USB ports safety mechanism kicking in because there's been a power issue of some description. If I overload the USB ports in my system, the hardware's safety mechanism kicks in, and the USB devices stop responding to any input. It protects the machine from hardware damage through power overload or similar.

While I can't say just yet exactly what the issue is, it's still looks very much like a hardware related issue from what you're describing. I don't think it's just a driver issue, not from what you're describing.

You should also check your kernel logs for any strange (or error) messages related to your mouse and the USB subsystem.

Quote:
Is my hard disk faulty?
...
A failing hard disk certainly could cause all sorts of issues. The last one I had fail on me caused at least three different issues, and it wasn't even the one my system is installed to either.

Anyhow, run the following command and post the results using CODE tags;

Code:
smartctl -a /dev/sdX
Replace the "sdX" above with the actual device node for your drive in question. It's the numbers in the "RAW_VALUE" field that tell the story. I would check all drives you may have in your system (fixed drives - not removable drives), but just post the output for your system drive for now.

Just something else I remembered doing when one of my drive's was failing, check to see if libata is complaining. If it is, then it's almost certain that either the drive controller or the drive itself is having some serious problems - most likely to be the drive itself in that case.

Code:
dmesg | grep -i ata
The above is a bit of a long shot and may return little to nothing, but worth checking - you never know. This should also give us some idea of what drives you have in your system.

Last edited by jsbjsb001; 10-18-2018 at 12:26 PM. Reason: additions
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] my system hangs on shutdown/restart/logout always in my gnewsense 4 linux installation rubankumars Linux - Software 3 07-11-2017 03:34 AM
[SOLVED] system/keyboard hangs - how can I do a proper shutdown? ggerri Linux - Newbie 8 07-31-2009 09:22 AM
What Version Of Ubuntu Is This & Is It A Stable Version? Ntvu Linux - Newbie 2 06-10-2008 03:01 AM
SUSE 9.3 KDETV Hangs on exit and system can't shutdown 1kyle SUSE / openSUSE 2 08-29-2005 02:55 AM
system hangs on shutdown jbeiter Linux - Enterprise 5 03-12-2005 09:01 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 12:41 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration