LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-16-2014, 12:54 AM   #1
gdizzle
Member
 
Registered: Jul 2012
Posts: 234

Rep: Reputation: Disabled
Moskito Maven install dependency issue???


Hi all I am new to Maven and the Java World and I am trying to build a moskito http://www.moskito.org/ example following the instructions here: http://blog.anotheria.net/msk/the-fu...oskito-step-0/

System: RHEL 6.5 64bit

java -version
java version "1.7.0"
Java(TM) SE Runtime Environment (build pxa6470sr6-20131015_01(SR6))
IBM J9 VM (build 2.6, JRE 1.7.0 Linux amd64-64 Compressed References 20131013_170512 (JIT enabled, AOT enabled)
J9VM - R26_Java726_SR6_20131013_1510_B170512
JIT - r11.b05_20131003_47443
GC - R26_Java726_SR6_20131013_1510_B170512_CMPRSS
J9CL - 20131013_170512)
JCL - 20131011_01 based on Oracle 7u45-b18

mvn -version

Apache Maven 3.1.1 (0728685237757ffbf44136acec0402957f723d9a; 2013-09-18 01:22:22+1000)
Maven home: /opt/apache-maven-3.1.1
Java version: 1.7.0, vendor: IBM Corporation
Java home: /usr/lib/jvm/java-1.7.0-ibm-1.7.0.6.0.x86_64/jre
Default locale: en_US, platform encoding: UTF-8
OS name: "linux", version: "2.6.32-431.3.1.el6.x86_64", arch: "amd64", family: "unix"


I get to this step:

Code:
mvn clean install
Code:
[INFO] Scanning for projects...
[INFO]
[INFO] ------------------------------------------------------------------------
[INFO] Building Burgershop Maven Webapp 1.0-SNAPSHOT
[INFO] ------------------------------------------------------------------------
[WARNING] The POM for blowfish:blowfish:jar:1.0 is missing, no dependency information available
[INFO] ------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 0.656s
[INFO] Finished at: Thu Jan 16 16:33:58 EST 2014
[INFO] Final Memory: 4M/8M
[INFO] ------------------------------------------------------------------------
[ERROR] Failed to execute goal on project burgershop: Could not resolve dependencies for project de.zaunberg:burgershop:war:1.0-SNAPSHOT: Failure to find blowfish:blowfish:jar:1.0 in http://repo.maven.apache.org/maven2 was cached in the local repository, resolution will not be reattempted until the update interval of central has elapsed or updates are forced -> [Help 1]
[ERROR]
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR]
[ERROR] For more information about the errors and possible solutions, please read the following articles:
[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/DependencyResolutionException


I understand that it's missing the blowfish:blowfish:jar:1.0 file from the pom.xml.


cat pom.xml

Code:
<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
  xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/maven-v4_0_0.xsd">
  <modelVersion>4.0.0</modelVersion>
  <groupId>de.zaunberg</groupId>
  <artifactId>burgershop</artifactId>
  <packaging>war</packaging>
  <version>1.0-SNAPSHOT</version>
  <name>Burgershop Maven Webapp</name>
  <url>http://maven.apache.org</url>
  <dependencies>

      <dependency>
          <groupId>org.springframework</groupId>
          <artifactId>spring-web</artifactId>
          <version>3.2.4.RELEASE</version>
      </dependency>
      <dependency>
          <groupId>org.springframework</groupId>
          <artifactId>spring-webmvc</artifactId>
          <version>3.2.4.RELEASE</version>
      </dependency>
      <dependency>
          <groupId>net.anotheria</groupId>
          <artifactId>ano-tags</artifactId>
          <version>2.1.0</version>
      </dependency>
      <dependency>
          <groupId>javax.servlet</groupId>
          <artifactId>servlet-api</artifactId>
          <version>2.5</version>
          <scope>provided</scope>
      </dependency>

      <dependency>
          <groupId>org.slf4j</groupId>
          <artifactId>slf4j-api</artifactId>
          <version>1.7.5</version>
      </dependency>
      <dependency>
          <groupId>ch.qos.logback</groupId>
          <artifactId>logback-classic</artifactId>
          <version>1.0.13</version>
      </dependency>

      <dependency>
          <groupId>junit</groupId>
          <artifactId>junit</artifactId>
          <version>4.5</version>
          <scope>test</scope>
    </dependency>
  </dependencies>
  <build>
    <finalName>burgershop</finalName>
  </build>
</project>
I have searched for blowfish:jar:1.0 at http://search.maven.org/#browse and there is no sign hence why it is failing.


How can I download and install the blowfish:blowfish:jar:1.0 file manually so I can build the application with Maven??

Thanks in advance.
 
Old 01-30-2014, 05:10 AM   #2
dvayanu
LQ Newbie
 
Registered: Jan 2014
Posts: 1

Rep: Reputation: Disabled
My third attempt to answer to this post.
I am not allowed to post urls here, but if you google for the-complete-moskito-integration-guide-step-1 you will find the answer.

In the blog you can see the same error message with following solution:

Quote:
This is because ano-util, a MoSKito lib, uses blowfish, and since there is no published blowfish version, we put it into our repository. There are multiple ways to handle it:


Exclude it from dependencies, since its not needed.
Add our repository to your settings xml or directly in the project. Our repository is at <cantposthere>
Download the artifact and put it in your repository or into a local repository.
Easiest is to add the repository into your pom.xml or settings.xml.

regards
Leon
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] pam.i686 dependency issue won't allow install boblc123 Linux - Server 4 03-05-2013 04:14 PM
Dependency Issue carlosinfl Red Hat 2 04-09-2009 10:04 AM
RH 8.0 - Minimal package install- RPM dependency issue johnrams Red Hat 3 02-17-2009 09:32 PM
massive dependency issue natv Linux - Software 3 08-12-2007 12:51 PM
how to install maven? snowyice Linux - Software 0 01-08-2006 09:16 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 04:19 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration