LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   More WineX newbie stuff (https://www.linuxquestions.org/questions/linux-newbie-8/more-winex-newbie-stuff-94380/)

sammckee 09-18-2003 11:10 PM

More WineX newbie stuff
 
Okay, I finally managed to get WineX installed. I can run Windows Solitaire, which makes the wife happy, so I know my fake C drive is working and all that.

So now I want to install Jedi Outcast, which is the main reason for having a computer in the first place (followed closely by making a living). So I pop open a console window, cd over to /mnt/cdrom2 (that's where I have the CD and it's mapped to the D drive in my Wine config file), and type

wine autorun.exe

I take a deep breath and almost jump out of my skin when what I was hoping for actually happens. I hear the sound of a lightsabre igniting, and the installation dialog pops open. I click install and see the beginning of the installation process. Then my heart sinks as it hangs. :(

Over in the console window I see this:


[javaguy@dhcp024-209-106-131 cdrom2]$ err:bitmap:X11DRV_DIB_CreateShmPixmap pitch mismatch in ShmPixmap creation
err:bitmap:X11DRV_DIB_CreateShmPixmap pitch mismatch in ShmPixmap creation
fixme:ole:CoTreatAsClass ({8c3c1b17-e59d-11d2-b40b-00a024b9dddd},{22d84ec7-e201-4432-b3ed-a9dca3604594})
err:win:WIN_FindWndPtr window 10024 belongs to other process
err:file:DeleteFileA Empty path passed
fixme:ole:RpcChannel_GetDestCtx (0x4f9fce1c)->GetDestCtx(0x4fcc1a98,0x4fcc1a9c)
err:ole:OA_BuildProxyVtbl failed to locate ancestor (0) for IID {91814ebf-b5f0-11d2-80b9-00104b1f6cea}
Please make sure a copy of stdole32.tlb is installed.
err:ole:OA_BuildProxyVtbl failed to locate ancestor (0) for IID {91814ec1-b5f0-11d2-80b9-00104b1f6cea}
Please make sure a copy of stdole32.tlb is installed.
wine: Unhandled exception, starting debugger...
err:seh:start_debugger Couldn't start debugger ("winedbg --debugmsg -all 135192392 140") (2)
Read the Wine Developers Guide on how to set up winedbg or another debugger


I did a Google for WineX and Jedi Outcast, but I didn't find any technical discussion of how to make it work, just discussion of how well it works. :(

Any idea what I missed?

Caeda 09-19-2003 12:38 AM

errle:OA_BuildProxyVtbl failed to locate ancestor (0) for IID {91814ebf-b5f0-11d2-80b9-00104b1f6cea}
Please make sure a copy of stdole32.tlb is installed.
errle:OA_BuildProxyVtbl failed to locate ancestor (0) for IID {91814ec1-b5f0-11d2-80b9-00104b1f6cea}
Please make sure a copy of stdole32.tlb is installed.

Quite obvoiusly, find a copy of stdole32.tlb, and install it.

DrOzz 09-19-2003 06:49 AM

maybe this might help
these are the setup instructions you should take when installin jedi as they are known to work....

sammckee 09-20-2003 08:29 AM

Well, the Frank's Corner link contained some obviously erroneous information..


$ mkdir jk2
$ cp -r -f /mnt/cdrom/gamedata/gamedata


Okay, so far, so good...

cd jk/resource

I assume he means jk2/resource, but there's still no such directory, nor is there one on the CD! I didn't think it would work at this point but tried running it anyway:

$ wine jk2sp.exe
err:module:map_image Could not map section .text, file probably truncated
err:wave:OSS_OpenDevice Couldn't open out /dev/dsp w/ 1 (Device or resource busy)
err:wave:OSS_WaveOutInit OpenDevice failed 4
wine: can't exec 'jk2sp.exe': error=21


The Frank's World page also has a link to the Linux Jedi Clan, which has instructions that say to use the setup.exe from the CD under wine. That's what I tried in the first place that blew up when it couldn't find the stdole32.tlb. :(

I found stdole32.tlb on my Windoze drive and copied it to my fake c drive's system32 directory, but it still says it can't find it. A Google search suggested I need to do something with regapi to set it up, but I'm at a loss to figure out how. Anyway, I posted to the Linux Jedi Clan's techie forum, since this seems to be their specialty, and I'll keep you posted on what I find out.

Mega Man X 09-20-2003 08:42 AM

Are you running wine or wineX? because the command you've run is for wine, the thread subject is about wineX, DrOzz link is for wine and they are very different (maybe not very different, but definitely made for different tasks) :).

I've winex3 myself and it did, worked without a problem in my machine with Jedi Knight. Only one known problem, the fonts used in the main screen are way to small for being visible (well, I can read, but gives me a headache...lol). If you are going to stick with Windows DirectX based games, don't push too hard with wine cause it won't do the job, get winex. At their homepage you can get a free version thru CVS, but I still would recommend paying for winex so you can get full support + compiled packages really easy to setup :)

sammckee 09-20-2003 09:50 AM

I used the script at

http://ting.homeunix.org/cvs_wine/GetWineX.html

and when I type winex it says command not found, whether it's winex, WineX, Winex or wineX. I have been told by other people on techie forums that the command for winex is simply wine, but I'm not qualified to say whether that's right or wrong. When I do a listing of my /usr/local/bin I see things called wine and wineblahblahblah, but no winex. Does the script I got not do what it says it does? I know it's pretty lame to rely on a crutch like a script, but I'm really new to Linux and need all the help I can get. ;)

I definitely want winex and not wine because I can't think of [b]any[/i] Windoze app I want to use that isn't a game.

sammckee 09-20-2003 09:54 AM

Wait!

I just looked at that page again. Normally I'm pretty good at following instructions to the letter, but obviously not this time. The command I need to use is cvswinex, not winex. :o

Mega Man X 09-20-2003 10:01 AM

it's also winex<version number> <name of the program to run>. E.g:

winex3 setup.exe

I really hope you can get it to work. Jedi Knight runs neat through it man :)

sammckee 09-20-2003 10:37 AM

Well now it says it can't launch the installshield engine (kernel.exe).

:(


All times are GMT -5. The time now is 10:41 PM.