LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   More Sound/network questions....(I know, Im sorry) (https://www.linuxquestions.org/questions/linux-newbie-8/more-sound-network-questions-i-know-im-sorry-93499/)

/redhat/n00b 09-16-2003 02:20 PM

More Sound/network questions....(I know, Im sorry)
 
Hello all,
This annoying and repetitive post hapens to be my first post here (what a first impression?)...
Ive searched the forum and read until my eyes bleed... and think I know what I need to get my sound working but I could use some basic help with the procedure.
I have installed Rh9 as a second OS (and Im happy to say I worked out all the boot issues my self with this forum as a guide!)
Now, as many (too many!) have found the damn'd SB Live 5.1 is a complete pain in the posterior!
From other's posts I snooped in my lsmod and found no refrence to the emu10k1; here is my output

# lsmod
Module Size Used by Not tainted
soundcore 6276 0 (autoclean)
parport_pc 18756 1 (autoclean)
lp 8868 0 (autoclean)
parport 36480 1 (autoclean) [parport_pc lp]
autofs 12948 0 (autoclean) (unused)
ipt_REJECT 3896 6 (autoclean)
iptable_filter 2380 1 (autoclean)
ip_tables 14648 2 [ipt_REJECT iptable_filter]
pegasus 17976 1
keybdev 2880 0 (unused)
mousedev 5428 1
hid 21700 0 (unused)
input 5792 0 [keybdev mousedev hid]
usb-uhci 25868 0 (unused)
usbcore 77696 1 [pegasus hid usb-uhci]
ext3 69984 2
jbd 51220 2 [ext3]
#

the only refrence to sound at all is sound core...
I also looked in lspci (as some one on another thread needed to provide pci info) and here is my output:

]# /sbin/lspci
00:00.0 Host bridge: Advanced Micro Devices [AMD] AMD-760 [IGD4-1P] System Controller (rev 13)
00:01.0 PCI bridge: Advanced Micro Devices [AMD] AMD-760 [IGD4-1P] AGP Bridge
00:04.0 ISA bridge: VIA Technologies, Inc. VT82C686 [Apollo Super South] (rev 40)
00:04.1 IDE interface: VIA Technologies, Inc. VT82C586/B/686A/B PIPC Bus Master IDE (rev 06)
00:04.2 USB Controller: VIA Technologies, Inc. USB (rev 16)
00:04.3 USB Controller: VIA Technologies, Inc. USB (rev 16)
00:04.4 Non-VGA unclassified device: VIA Technologies, Inc. VT82C686 [Apollo Super ACPI] (rev 40)
00:09.0 Serial controller: US Robotics/3Com 56K FaxModem Model 5610 (rev 01)
00:0a.0 Multimedia audio controller: Creative Labs SB Live! EMU10k1 (rev 07)
00:0a.1 Input device controller: Creative Labs SB Live! MIDI/Game Port (rev 07)
01:05.0 VGA compatible controller: nVidia Corporation NV11 [GeForce2 MX/MX 400] (rev b2)
#

as you can see here there is a refrence to the card, and the emu10k1.
It may also be imprtaint to note that I get a defalt error msg when I log on that says (and Im sure youve heard it before)
"Error while initializing the sound driver
Device /dev/dsp cant be opened (no such device)"
I was thinking i need the sourceforge emutools or driver but I dont know which package to download. My system is identified as i686 and there is no package for i686, just i386, or various versions. I am using the 2.4.20-8 kernel
Do I need the tools or just the driver... and which one? Or neither (since the SB 5.1 is found in my lspci?)

Now, I must admit that identifying the correct package will also lead to a question about install... I think i am ok with unzip and then tar... but what is the extension.bz2? as some files are indicated as such? If I could get to the readme file in the driver Im sure I could follow the instructions (as i did with my dual boot).

My second question is MUCH easier ..... On the RH site they have a listing of compatible and cerified hardware for all BUT RH9... I need to get a NIC and I was wondering if anyone could recomend one that is as trouble free as possible for RH9/2.4.20-8kernel
Thanks for enduring my lengthy post, and repetitive questions...

aqoliveira 09-16-2003 02:43 PM

Hi

the bz2 extention means the file was compressed with bzip2 cmd. to unzip this file u must use the bunzip2 cmd or u can type tar -jxvf if the file was tar then compressed with that utility (bzip2).

For you second quetion I suggest for u to goto the RH site and see what hardware is compatible with RH9. I have never had problems with 3Com cards somehow all RH versions I have installed has worked fine with them

Well good luck.
chow


All times are GMT -5. The time now is 02:48 AM.