LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   More NTLDR is missing - Sorry :) (https://www.linuxquestions.org/questions/linux-newbie-8/more-ntldr-is-missing-sorry-190816/)

forge107 06-07-2004 04:15 PM

More NTLDR is missing - Sorry :)
 
Ok, I've been through most of the posts in this forum about this, otherwise I wouldn't be posting a fresh one...but I'm still having problems.

Basically, new to Linux, installed SuSE 9.1 and now I'm getting the famed
--------------------------------------
root (hd0,0)
FS is FAT Partition type is OxC
NTLDR is missing
--------------------------------------
thing going on and I get the general impression I need to mess around with my Grub.conf and probably my boot.ini to sort it out. Just got a 40gb HD with 3 Partitions, Windows XP (FAT 32), Linux Swap and Linux


---------------------
"fdisk -l" is as follows :-
---
Disk /dev/hda: 41.1 GB, 41110142976 bytes
16 heads, 63 sectors/track, 79656 cylinders
Units = cylinders of 1008 * 512 = 516096 bytes

Device Boot Start End Blocks Id System
/dev/hda1 * 1 60440 30461728+ c W95 FAT32 (LBA)
/dev/hda2 60443 62523 1048824 82 Linux swap
/dev/hda3 62524 79656 8635032 83 Linux
--------------------

my grub.conf is as follows :-
---
root (hd0,2)
install --stage2=/boot/grub/stage2 /boot/grub/stage1 d (hd0) /boot/grub/stage2 0x8000 (hd0,2)/boot/grub/menu.lst
quit
--------------------

I'd rather try and get my Windows partition going again without having to wipe anything is possible so any help anyone could drop by would be appreciated more than you know :D

bruno buys 06-07-2004 04:41 PM

So, to reinstall winXP bootloader, boot the machine with xp's cd. Choose repair (instead of install) > recovery console. It will ask for the admin password. Log into the xp installation. There's a small utility called something like fixboot or fixmbr. Just run, it will create a new mbr and you will be able to boot xp again.

forge107 06-07-2004 04:45 PM

Won't that kill Grub and stop me booting into Linux though? I just want to be able to Select Windows from the Grub menu and have it boot that way :)

bruno buys 06-07-2004 04:54 PM

Oh! Sure it will, friend! I'm sorry. I misunderstood your problem. I thought you wanted to remove suse and let win be alone. Don't do that!

Can you post your menu.1st here for us?

forge107 06-07-2004 05:02 PM

Sure, sorry it took a minute, still finding my way around :)

------------------
# Modified by YaST2. Last modification on Wed Jun 2 17:57:34 2004


color white/blue black/light-gray
default 1
timeout 8
gfxmenu (hd0,2)/boot/message

###Don't change this comment - YaST2 identifier: Original name: linux###
title Linux
kernel (hd0,2)/boot/vmlinuz root=/dev/hda3 vga=0x317 splash=silent desktop resume=/dev/hda2 showopts
initrd (hd0,2)/boot/initrd

###Don't change this comment - YaST2 identifier: Original name: windows###
title Windows
root (hd0,0)
chainloader +1

###Don't change this comment - YaST2 identifier: Original name: floppy###
title Floppy
root (fd0)
chainloader +1

###Don't change this comment - YaST2 identifier: Original name: failsafe###
title Failsafe
kernel (hd0,2)/boot/vmlinuz root=/dev/hda3 showopts ide=nodma apm=off acpi=off vga=normal noresume nosmp noapic maxcpus=0 3
initrd (hd0,2)/boot/initrd
-----------------------------


Oh, and for good measure, here is my windows boot.ini :)

[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /fastdetect

v00d00101 06-07-2004 05:14 PM

Try this:

make a copy of the master boot reccord:

dd if=/dev/hda of=/linux.mbr bs=512 count=1

copy linux.mbr to a floppy disk

repair windows xp

once in win xp, copy the linux.mbr file to your c: drive

edit c:\boot.ini and add a new line using linux.mbr as a ref to linux, under the [operating systems] header:

c:\linux.mbr="Linux"

Now when u boot it will go staright to the NT bootloader where u can select, or you can make linux the default, by adding the following to the [boot loader] section:

default=c:\linux.mbr

bruno buys 06-07-2004 05:15 PM

Hmmm.. its been a while I don't dualboot... But people here have been trying with the options "rootnoverify" and "makeactive". Did you try these?
A search in this forum will point you to several chainloader and ntldr threads.


All times are GMT -5. The time now is 06:31 PM.