-   Linux - Newbie (
-   -   More ndiswrapper problems (

Aenima427 03-27-2006 01:22 PM

More ndiswrapper problems
I have recompiled my kernel to enable wireless radio, and successfully installed ndiswrapper 1.9, so everything should work, right? Nope. Running

ndiswrapper -l
lists my driver and shows

Driver installed, hardware present

ndiswrapper -m
says that alias wlan0 ndiswrapper is already in /etc/modprobe.conf, and I have verified this.

modprobe ndiswrapper
should be all I have to do to get my card working. But, when I modprobe nothing happens. My dmesg looks like this


4299391.937000 ndiswrapper version-1.9 loaded (preemt=no, smp=yes)
4299391.943000 usb core: registered new driver ndiswrapper

It should be loading the driver netwpn11 and activating wlan0, which it does sometimes. In fact, once it even started at boot. My wireless card connected to my AP (right ESSID) and after running dhcpcd it started loading a web page. But right after the page started loading, my computer froze solid. I haven't been able to recreate the fault since. When the driver loads properly and I run iwconfig I get a warning before it displays wlan0 saying

Driver compiled with Wireless Extensions 19.  Driver only support Wireless Extensions 17, so it might be broken
That's not exactly right, but since I haven't been able to reproduce the conditions I don't know the exact verbage. How can I roll back to Wireless Extensions 17? emerge --search wireless-extensions doesn't turn up anything (I searched for many variations of wireless-extensions to see if anything turned up). I am using Gentoo, with kernel 2.6.15

sirclif 03-27-2006 06:11 PM

i had a similar problem once, and it turned out that i wasn't setting my wap's key before i tried setting the essid. if you wap is encrypted, make sure you run

iwconfig wlan0 key xxxxxxx


iwconfig wlan0 essid myEssid

i also got the warninging you posted, but like i said, it was just somethign stupid i was doing (or i guess not doing)

Aenima427 03-28-2006 04:51 AM

My AP is not encrypted right now, so unfortunately that's not the problem. I didn't even have to set the essid, it connected automatically the two times it connected. I asked the LUG at college about the problem, but none of them had any ideas that I haven't already tried. I am going to try rolling back Wireless Tools to an earlier version (even though I'm not running the latest version right now), maybe that will fix the Wireless Extension version problem. If that doesn't work I'm out of ideas, and I can't find anything on the net. If anyone here has any advice...please help :)

Unfortunately, this will probably have to wait till Thursday night, since spring break is over and I'm back to having almost no free time during the week.

All times are GMT -5. The time now is 04:22 PM.