LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-02-2018, 09:36 PM   #16
jfhendfg
Member
 
Registered: Jun 2015
Posts: 150

Original Poster
Rep: Reputation: Disabled

Quote:
Originally Posted by AwesomeMachine View Post
How did you get the xorg.conf file?
I created the xorg.conf file by following these steps:

Quote:
Switch to console mode: Ctrl + Alt + F1.
Kill x server: sudo service lightdm stop.
Generate new xorg.conf file: sudo X -configure. This will create xorg.conf.new file in your current directory.
Rename and move: sudo mv xorg.conf.new /etc/X11/xorg.conf.
Return to GUI: sudo start lightdm.
I believe there's a syntax error in that first command you gave me.
 
Old 06-02-2018, 09:44 PM   #17
jfhendfg
Member
 
Registered: Jun 2015
Posts: 150

Original Poster
Rep: Reputation: Disabled
And no I'm not just making an assumption, pretty sure there's a syntax error there, thanks:

Quote:
ps aux | grep gdm|X | awk '{print $2}' | xargs sudo kill $1
/usr/lib/xorg/Xorg.wrap: Only console users are allowed to run the X server

Usage:
kill [options] <pid> [...]

Options:
<pid> [...] send signal to every <pid> listed
-<signal>, -s, --signal <signal>
specify the <signal> to be sent
-l, --list=[<signal>] list all signal names, or convert one to a name
-L, --table list all signal names in a nice table

-h, --help display this help and exit
-V, --version output version information and exit

For more details see kill(1).
 
Old 06-02-2018, 10:00 PM   #18
jfhendfg
Member
 
Registered: Jun 2015
Posts: 150

Original Poster
Rep: Reputation: Disabled
Doesn't work in console mode either, syntax error. I'm doing it from copy and paste so it's however you typed it.

TV model is a Sanyo.

At this point I just want to revert the changes caused by the creation of xorg.conf, it wasn't there before but today after creating it, yeah, this day has turned awfully sour.

I just wanted my darn screen resolution to stay persistent and now I can't turn off my monitor OR watch videos ///////wrists
 
Old 06-02-2018, 10:14 PM   #19
mrmazda
Senior Member
 
Registered: Aug 2016
Location: USA
Distribution: openSUSE, Debian, Knoppix, Mageia, Fedora, others
Posts: 2,551

Rep: Reputation: 833Reputation: 833Reputation: 833Reputation: 833Reputation: 833Reputation: 833Reputation: 833
What exactly is it that you have been having to change the resolution manually to?

What does 'inxi -G -c0' show when X is correctly functioning?

What exactly is your TV model?
 
Old 06-02-2018, 10:16 PM   #20
jfhendfg
Member
 
Registered: Jun 2015
Posts: 150

Original Poster
Rep: Reputation: Disabled
Just deleted xorg.conf, again, and ran this in console mode

Quote:
/etc/init.d/lightdm stop
cd /etc/X11/
Xorg -configure
No results, kind of, VLC video playback appears to be back to normal, at least.
However, if I turn the monitor off then back on, blank screen.
This time I left a paused video in the background, after I turned the TV back on, I pressed the play button, TV gets the signal, which I guess is better than CtrlAltF1/F7.

Still have to manually set the resolution back though HAHAHAHAHAHAHAHAHAHAHAHA
 
Old 06-02-2018, 10:17 PM   #21
mrmazda
Senior Member
 
Registered: Aug 2016
Location: USA
Distribution: openSUSE, Debian, Knoppix, Mageia, Fedora, others
Posts: 2,551

Rep: Reputation: 833Reputation: 833Reputation: 833Reputation: 833Reputation: 833Reputation: 833Reputation: 833
Code:
sudo X -configure
virtually never resolves Xorg trouble since at least a decade ago.
 
Old 06-02-2018, 10:25 PM   #22
jfhendfg
Member
 
Registered: Jun 2015
Posts: 150

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by mrmazda View Post
What exactly is it that you have been having to change the resolution manually to?

What does 'inxi -G -c0' show when X is correctly functioning?

What exactly is your TV model?
It defaults to 1920x1080, my preference is 1360x768.

inxi -G -c0

Quote:
Graphics: Card: Intel Atom Processor Z36xxx/Z37xxx Series Graphics & Display
Display Server: X.Org 1.19.2 driver: intel
Resolution: 1360x768@60.02hz
GLX Renderer: Mesa DRI Intel Bay Trail x86/MMX/SSE2
GLX Version: 3.0 Mesa 13.0.6
Model is FW32DO6F, but I have a very very very very very very very very very very very very very very very very very very very very strong feeling that this issue is going to reoccur no matter what type of TV I'm using, considering that my set up is howdoyousay Media PC(?) I've used/and use several other TVs when I travel, and I've never seen this issue before,

and I guarantee you I turned off the TV while my system was still running and turned the TV back on and didn't have this issue, but there's the model number anyway 8)
 
Old 06-02-2018, 10:26 PM   #23
AwesomeMachine
LQ Guru
 
Registered: Jan 2005
Location: USA and Italy
Distribution: Debian testing/sid; OpenSuSE; Fedora; Mint
Posts: 5,513

Rep: Reputation: 1007Reputation: 1007Reputation: 1007Reputation: 1007Reputation: 1007Reputation: 1007Reputation: 1007Reputation: 1007
I didn't know you can paste in the console. Anyway, stopping the service works too. It probably doesn't work because you don't have sudo configured. But the main thing is that you obtained your xorg.conf from the xorg command designed to make one.

That isn't foolproof, but it's generally good enough. In your case there were problems. OK, make sure there are no files in /etc/X11/xorg.conf.d. If there are, rename them *.old. And try again without xorg.conf.
 
Old 06-02-2018, 10:28 PM   #24
jfhendfg
Member
 
Registered: Jun 2015
Posts: 150

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by mrmazda View Post
Code:
sudo X -configure
virtually never resolves Xorg trouble since at least a decade ago.
that's funny. Someone should really tell that to all the people that have told me to do that at the end of all these xorg "reset" instructions haha.
 
Old 06-02-2018, 10:33 PM   #25
jfhendfg
Member
 
Registered: Jun 2015
Posts: 150

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by AwesomeMachine View Post
I didn't know you can paste in the console. Anyway, stopping the service works too. It probably doesn't work because you don't have sudo configured. But the main thing is that you obtained your xorg.conf from the xorg command designed to make one.

That isn't foolproof, but it's generally good enough. In your case there were problems. OK, make sure there are no files in /etc/X11/xorg.conf.d. If there are, rename them *.old. And try again without xorg.conf.

You're right you can't copy and paste directly to it, I had to get creative on that one, don't feel like explaining it right now. Nope, sudo is most definitely configured. If it isn't then I'm going to morph into a dragon out of shock at how I've used this system for 3 years without it aha.

Thanks anyways man.

I'm NOT going to try this, but hypothetically, if creating xorg.conf started all of this, and deleting the .conf didn't fix it, and I don't want whatever the heck it is it did,
.....what if I deleted everything in X11? Or is all of that deeper than xorg.conf?

Again, I repeat, I just created xorg.conf yesterday as a fix for a previous issue, and I never had it before, and during that time without it, the blank on-off issue wasn't there, and video playback was always perfect.

So yeah, is X11 just a part of xorg(.conf) ?
Or is xorg.conf an outside thing for configuring the prexisting X11 folder components?

IDK, just a thought.
 
Old 06-02-2018, 11:05 PM   #26
mrmazda
Senior Member
 
Registered: Aug 2016
Location: USA
Distribution: openSUSE, Debian, Knoppix, Mageia, Fedora, others
Posts: 2,551

Rep: Reputation: 833Reputation: 833Reputation: 833Reputation: 833Reputation: 833Reputation: 833Reputation: 833
ToDo:
1-delete xorg.conf
2a-reboot with the following appended to the kernel cmdline:
Code:
video=1360x768@60
2b-if 2a didn't produce the desired result, redo it substituting
Code:
video=1366x768@60
3-If either produced the desired result, reconfigure your bootloader to include either it exactly, or if using Grub2, whatever is its equivalent, maybe GRUB_GFXMODE_LINUX=136#x768 in /etc/default/grub and running update-grub (I don't use Grub2).

BTW, Googling for FW32DO6F specs didn't produce the specs I wanted. Even the Sanyo PDF manual omits the horizontal sync and vertical refresh specifications. If these ToDo instructions don't work, we can try generic ones in a new scratch-built xorg.conf. Most of what Google did find that I looked at says your (720p) TV's preferred mode is 1366x768, not 1360x768. Your xrandr output shows the TV's preferred mode is 1920x1080, while all the specs say its native mode is 136#x768 (normal for a 720p). This discrepancy is almost certainly the root of why you've been suffering as you have for 3 years.

Last edited by mrmazda; 06-02-2018 at 11:51 PM. Reason: forgot things
 
Old 06-03-2018, 12:03 AM   #27
mrmazda
Senior Member
 
Registered: Aug 2016
Location: USA
Distribution: openSUSE, Debian, Knoppix, Mageia, Fedora, others
Posts: 2,551

Rep: Reputation: 833Reputation: 833Reputation: 833Reputation: 833Reputation: 833Reputation: 833Reputation: 833
The Intel Xorg driver doesn't explicitly report which connections are in use, like the other drivers do, but your Xorg.0.log suggests you have both the VGA and the HDMI ports connected to the same display/TV. If that's the case, you probably should disconnect the VGA cable.
 
Old 06-03-2018, 07:51 AM   #28
jfhendfg
Member
 
Registered: Jun 2015
Posts: 150

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by mrmazda View Post
ToDo:
your (720p) TV's preferred mode is 1366x768, not 1360x768. Your xrandr output shows the TV's preferred mode is 1920x1080, while all the specs say its native mode is 136#x768 (normal for a 720p). This discrepancy is almost certainly the root of why you've been suffering as you have for 3 years.
As far as my preference being the problem, I didn't create that option. Nope. That's just the second resolution option given by arandr and xfce's display setting . But sure I'll try it.

Quote:
Originally Posted by mrmazda View Post
you probably should disconnect the VGA cable.
N/A
 
Old 06-03-2018, 07:56 AM   #29
jfhendfg
Member
 
Registered: Jun 2015
Posts: 150

Original Poster
Rep: Reputation: Disabled
Before I do that I'd just like to regress again, I didn't create that resolution option, it's just the option given to me by the system and FYI 1920x1080 is completely unreadable for me considering I use this system at about 10ft distance.
Thanks.

https://ibb.co/iEkTtJ
https://ibb.co/gE9XLy
 
Old 06-03-2018, 08:17 AM   #30
jfhendfg
Member
 
Registered: Jun 2015
Posts: 150

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by mrmazda View Post
ToDo:
1-delete xorg.conf
2a-reboot with the following appended to the kernel cmdline:
Code:
video=1360x768@60
2b-if 2a didn't produce the desired result, redo it substituting
Code:
video=1366x768@60
Ok so before booting I pressed E to edit the commands and tried each mode given, first one didn't make a difference, second didn't make a difference either except an invalid command #2 remark before booting.

By no difference I mean I'm still logging into the correct resolution that I prefer, that actually was never a problem I'm pretty sure it always logged me in with the correct resolution, (I may have stated otherwise somewhere)

BUT the issue I'm trying to fix still persists.

When I turn the monitor off, then back on again, the screen is completely blank as if the TV isn't receiving a signal (this started after creating xorg.conf, it used to NOT do this, and yes, I deleted xorg.conf)
Then after I CtrlAltF1\F7 the signal is back,
HOWEVER we return to the original issue where it's at the wrong resolution (1920x1080) and I have to open arandr to select my preference.
 
  


Reply

Tags
debian, monitor, persistent, resolution, xfce


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Red Hat 2.4 stays blank with cursor after log in Crisppx Linux - Server 4 07-03-2014 06:07 PM
primary monitor stays blank when I suspend and resume Laertiades Linux - Newbie 2 03-24-2013 10:34 AM
The screen stays blank when I try to init 3 hasshaus Fedora 3 07-19-2005 06:56 PM
Screen stays blank after re-opening lid. . . K2712 Fedora 3 05-10-2005 06:59 PM
X stays blank ctim Slackware 7 06-27-2004 12:34 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 09:38 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration