LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-27-2004, 11:40 AM   #16
~zoey~
Member
 
Registered: Aug 2004
Location: South Dakota
Distribution: ubuntu & PCLOS
Posts: 119

Rep: Reputation: 15

I need to get to Xconfigure in order to get the monitor settings changed so that I can see something on the screen.

I think that in order to do that I need to get from runlevel 5 to runlevel 3 but I don't know how to do that.

I know that X needs to be turned off so that I can work on the settings.

My bootloader is GRUB if that has anything to do with anything!

Thanks. zoey
 
Old 08-27-2004, 05:15 PM   #17
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,067
Blog Entries: 11

Rep: Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910
You could try to reboot and pass "single" as a
parameter to grub.
 
Old 08-27-2004, 05:54 PM   #18
Crunch
Member
 
Registered: Feb 2003
Location: York, PA
Distribution: Slackware, FreeBSD, OpenBSD
Posts: 162

Rep: Reputation: 30
I hope you see this one when you come back so the post doesn't get drowned out =)

Since you're back at terminal now you're going to possibly need to kill the Xserver since it is already running (from my knowledge, since I've read somewhere in this thread that it was.)

You should do this by issuing the 'ps' command. This issues the process status of your system (don't worry about doing it just yet =))

I'm going to fill you in a little about commands and arguments since you're a new user and all...
Anyone who notices any problems just correct me if I'm wrong, thanks... much appreciated.

On the shell there are arguments, you see your little shell?
It should be something such as (this is default Bash):
Quote:
bash-2.0b$
Something along those lines, I can't quiet remember. Now... your shell reads each command given to it by commands and arguments. (This will lead into pipes later... I'll touch base with that a little.)

I'm going to disect this line by line so you understand what's going on...
Arguments in the shell:

bash-2.0b$ ls <--- Command. Argument 0 (Yep, zero.)
^-The shell

The shell checks for the command. you issued one command at the 0 argument (mark?).

Now... if you were to do the same thing, but do this....

Quote:
bash-2.0$ ls -l
...
bash-2.0$
The shell will interpet this as you executing one command... with 2 arguments. Although since we are starting from zero, this will be...


arg(0) arg(1)
ls -l

(The '-' character isn't counted 'officially'... don't worry about that though =))

Hope this makes sense... pipes will come in handy with the command we talked about earlier, 'ps'.
The ps command shows information about processes that are currently running on your box.

If you have any indepth questions about what options the commands hold within the shell (yeah commands hold arguments too, hope this isn't confusing), check the man pages.
(e.g. man command_here)

Right now we're going to finally issue the ps command with the grep command using pipes (I'll throw in awk too... don't worry about this yet. I know this is bad for me to do this but this just kinda shortens the process).

Quote:
bash-2.0$ ps -a | grep "xinit" | awk '{print $2 $11}'
process_id_here
bash-2.0$
This right here will show you your active process running xinit. That's most likely your Xserver. You might see two, but if you see one running as "grep," don't worry about that one. Focus on the one that has "xinit."
NOTE: You never want to kill 'init' and 'xinit' are completely different. 'xinit' has a dynamic process ID. 'init' doesn't. 'init' will most likely always have the constant ID of '1'.

Oh, and only be concerned with the number... if you see something such as, "28323xinit," just type the number below...

Now we're just going to hang up the process with, 'kill'.

Quote:
bash-2.0b$ kill -HUP process_id_here
The process ID being the ID of your xinit... now since you have terminated that... this should enable you to run your Xserver for the configuration via 'xf86cfg'. There is also another command that is text based too... 'xf86config'. 'xf86config' is located the same place as 'xf86cfg' which is '/usr/X11R6/bin'.
After you're done configuring your X server configuration... you're not going to use xinit since xinit (as I believe) parses a different file seperate from /etc/XF86Config (correct me if I'm wrong here anyone).
Just issue the 'startx' command. =)

I hope I didn't ruthlessly confuse you at all. That was just a crash course to the shell =)
Sorry I kinda got out of control there...

Wish you good luck on your journey. Have fun =)
Oh, and if you have permissions problems... just su to root and follow from steps 'ps', but log back out before using 'startx'.

Last edited by Crunch; 08-27-2004 at 05:56 PM.
 
Old 08-27-2004, 06:16 PM   #19
~zoey~
Member
 
Registered: Aug 2004
Location: South Dakota
Distribution: ubuntu & PCLOS
Posts: 119

Rep: Reputation: 15
Tinkster said You could try to reboot and pass "single" as a
parameter to grub.


Did that and I think that I was in without X, but bash still didn't like any of my commands. The reason that I think I was in without X is that it didn't take very long to shutdown. So thank you Tinkster, you have been hanging in there.

Now to Crunch's instructions. Whoa!!! I will print them out and study them, but I am a 67 year old grandmother who has been into computing for a little over a year. I love it especially the challenge, but it will take me awhile to figure Linux out.

I just wish that I could get logged on correctly to my second computer and start learning. There is very little challenge left in XP [except for trying to keep it safe!].

I appreciate the fact that you all are trying to help, and I will probably manage to blunder through eventually, so thanks again to you both.

zoey
 
Old 08-27-2004, 06:46 PM   #20
J.W.
LQ Veteran
 
Registered: Mar 2003
Location: Boise, ID
Distribution: Mint
Posts: 6,642

Rep: Reputation: 85
Quote:
Originally posted by ~zoey~
....I am a 67 year old grandmother who has been into computing for a little over a year...
I gotta say, if you've only been using PC's for about a year, and you have already mastered XP, you're now getting into Linux, and even at this early stage you can have intelligent discussions about bootloaders, shell scripts, and configuring X, there's only one thing to say:

Lady, YOU ROCK!!! -- J.W.
 
Old 08-27-2004, 07:02 PM   #21
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,067
Blog Entries: 11

Rep: Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910
Quote:
Originally posted by ~zoey~
Did that and I think that I was in without X, but bash still didn't like any of my commands. The reason that I think I was in without X is that it didn't take very long to shutdown. So thank you Tinkster, you have been hanging in there.
Well, now that you're there, you could
try the "X -configure" again :}

And as J.W. pointed out: well done! :)


Cheers,
Tink
 
Old 08-27-2004, 07:05 PM   #22
~zoey~
Member
 
Registered: Aug 2004
Location: South Dakota
Distribution: ubuntu & PCLOS
Posts: 119

Rep: Reputation: 15
Thanks a bunch to Jw, but I gotta say that XP isn't that tough and so far I have gotten exactly nowhere with Linux. zoey
 
Old 08-27-2004, 07:52 PM   #23
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,067
Blog Entries: 11

Rep: Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910
I think our posts mate have overlapped (timing), and you might
not have noticed mine...


Cheers,
Tink
 
Old 08-27-2004, 08:12 PM   #24
~zoey~
Member
 
Registered: Aug 2004
Location: South Dakota
Distribution: ubuntu & PCLOS
Posts: 119

Rep: Reputation: 15
Tink, I did try the X -configure command when I booted up as linux single, and bash didn't say that X was running, as a matter of fact it didn't do anything, just sat there and blinked at me. I waited a long time but the configuratilon box never came up. I did hit enter.

I wonder if I have more problems than bad monitor settings. Bash doesn't recognize any shutdown commands except for "halt".

I get this for most commands [from a book or a forum, I'm not making them up!];

bash:whatever command:command not found.

I'm not seeing errors during bootup although it does run by pretty fast.

What do you think?

zoey
 
Old 08-27-2004, 08:18 PM   #25
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,067
Blog Entries: 11

Rep: Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910
Quote:
Originally posted by ~zoey~
Tink, I did try the X -configure command when I booted up as linux single, and bash didn't say that X was running, as a matter of fact it didn't do anything, just sat there and blinked at me. I waited a long time but the configuratilon box never came up. I did hit enter.

I wonder if I have more problems than bad monitor settings. Bash doesn't recognize any shutdown commands except for "halt".

I get this for most commands [from a book or a forum, I'm not making them up!];

bash:whatever command:command not found.

I'm not seeing errors during bootup although it does run by pretty fast.

What do you think?

zoey
Are you doing all of this as user root or
a normal user?


What does
echo $PATH give you?

Cheers,
Tink
 
Old 08-27-2004, 08:19 PM   #26
Crunch
Member
 
Registered: Feb 2003
Location: York, PA
Distribution: Slackware, FreeBSD, OpenBSD
Posts: 162

Rep: Reputation: 30
To check what's going on at boot up try typing the following into your shell.

Quote:
$ dmesg |more
This will show your output during boot... if you want to append this to a file, just do this...

Quote:
$ dmesg >> filename.txt
Edit: Ouch. Post laps again... someone already answered it.

Last edited by Crunch; 08-27-2004 at 08:20 PM.
 
Old 08-27-2004, 08:42 PM   #27
~zoey~
Member
 
Registered: Aug 2004
Location: South Dakota
Distribution: ubuntu & PCLOS
Posts: 119

Rep: Reputation: 15
This is getting interesting. I have both computers on one monitor, keyboard and mouse and I am getting better at making the switch.

echo $SPATH brought up a long line with a lot of usrs and bins plus home and my name in the middle, then another short line with a blinking cursor.

I log in as myself then type in su and put in the root password.

Does that tell you anything?

zoey
 
Old 08-28-2004, 01:50 AM   #28
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,067
Blog Entries: 11

Rep: Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910
Try
"su -" ... the "-" is important, otherwise you keep
your normal user's environment - that is, not path
to any of the sbin directories.


Cheers,
Tink
 
Old 08-28-2004, 09:51 AM   #29
~zoey~
Member
 
Registered: Aug 2004
Location: South Dakota
Distribution: ubuntu & PCLOS
Posts: 119

Rep: Reputation: 15
I typed "su -" and this is what I got -bash:su-:command not found.

zoey
 
Old 08-28-2004, 10:04 AM   #30
Baldrick65
Member
 
Registered: Aug 2003
Location: Dunedin NZ
Distribution: Mint 13 Cinnamon
Posts: 653

Rep: Reputation: 31
Are you sure you put the space between the su and the -? I get that error when I forget to put the space in.

Baldrick
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
dual monitor setup gui way lil213 Mandriva 5 07-04-2006 02:52 PM
monitor & GUI problem stormadvisor SUSE / openSUSE 10 12-23-2004 06:26 PM
system monitor gui? shazaam Linux - Newbie 4 01-25-2004 03:36 AM
Monitor Problem: no GUI will work. KernelPayne Linux - Hardware 2 10-11-2003 03:46 AM
new monitor displays text, not GUI... davejavu Linux - Hardware 10 09-02-2003 01:55 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 11:28 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration