LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Modules not detected in slackware (https://www.linuxquestions.org/questions/linux-newbie-8/modules-not-detected-in-slackware-19561/)

Kuman_Nakal 04-26-2002 06:12 PM

Modules not detected in slackware
 
Hi..
I installed slackware 8.0 like two days ago.
i'm aware that the kernel is 2.2, so that i want to upgrade it to 2.4.18. I download the kernel from www.kernel.org
this is what i did:
cd linux
make mrproper
make menuconfig
make dep
make bzImage
make modules
make modules_install
cp linux/arch/i386/boot/ bzImage /vmlinuz-2.4.18
cp linux/System.map /boot/System.map
edit lilo.conf
lilo
reboot

i am able to boot using the new kernel. the problem is all the modules is not detected. At first, i though that i should edit the etc/modules.conf.

alias net-pf-4 off
alias net-pf-5 off

(original)

But later on i realized that the module is loaded on the startup with the error msg " modules is not located.
Then i tried to lsmod. No modules showed up.
When i tried to modprobe all the modules... it says modules not located...
Now i'm confused because i still can boot up to my old kernel and everything works just fine+xwindow is up.

Pls help me to set up my new kernel....

Thanks

ph34r3d 04-26-2002 07:13 PM

You did compile the new kernel in /usr/src/linux correct?

Make sure you compiled it in there, then run "make distclean"
then recompile everything, and remake all the dep


I always just do:


make menuconfig
make dep
make modules
make modules_install
make clean
make bzlilo; make bzImage

when I reboot, everything works fine...


All times are GMT -5. The time now is 08:51 AM.