-   Linux - Newbie (
-   -   Modules don't seem to load on boot (

ViNsAniTy 04-19-2004 03:01 PM

Modules don't seem to load on boot
Hi all,

I am trying to install a linux application that for one reason or another needs to be installed on a RedHat 7.1 system with the 2.4.7 kernel. The RedHat 7.1 has the 2.4.2-2 kernel so I had to go throughthe task of compiling and linking the 2.4.7 kernel. Which by the way was my first time compiling a kernel.

Anyways, I did all that mumbo jumbo following a tutorial for compiling the kernel I found here. Now I have the new kernel up and running, but I'm having a lot of problems with my network card.

I've read through most of the threads that deal with NICs and I have found the following information

- the driver my NIC uses is "tulip"

- in the 2.4.7 kernel I ran ifconfig with root and it only returned the lo entry

- when I do lsmod it doesn't return anything

- when I try to load the tulip module I get a "kernel module version mismatch"

As I'm still new to Linux I'm not even sure if I was trying to load the right "tulip" module.

After messing around for quite sometime now I am positive it is a problem with the modules. I tried recompiling with the option "oldconfig", which didn't seem to work.

Could anyone give me some insight into what the problem is. Again, I wish I could use a new version of RedHat, but the application I'm installing INSISTS on RH7.1 with kernel 2.4.7. (I have tried to install it on RH9, and it didn't work)

Thanks in advance.

Tinkster 04-19-2004 03:44 PM

Have a look at the output of dmesg

Copy and paste the output of lspci...

If there's a version-mismatch that probably
means that you've compiled a new version
of the kernel, and somehow the paths for
the modules were the same ... so you may
be still loading the original kernel, but the
modules may match the new one (or the
other way round).


ViNsAniTy 04-19-2004 04:21 PM

Since eth0 still isn't working for my linux box I'll try to reproduce the output for lspci from my windows goes....

00:00.0 Host bridge: Intel Corporation 440BX/ZX - 82443BX/ZX Host bridge (AGP disabled) (rev 03)
00:07.0 ISA bridge: Intel Corporation 82371AB PIIX4 ISA (rev 01)
00:07.1 IDE interface: Intel Corporation 82371AB PIIX4 IDE (rev 01)
00:07.3 Bridge: Intel Corporation 82371AB PIIX4 ACPI (rev 02)
00:08.0 VGA compatible controller: S3 Inc. 86c764/765 [Trio32/64/64V+]
00:0a.0 Ethernet controller: Digital Equipment Corporation DECchip 21140

...I could be linking all the modules wrong, I'm not even sure how to check that...oh, btw just in case it matters RH7.1 ran fine before the kernel recompile, as in all the modules were loaded correctly, and I had eth0 up and running...

Thanks for the help!

ViNsAniTy 04-20-2004 09:08 AM


sorry, I really need some help here, any input would be wonderful...

Match 04-21-2004 01:40 PM

I'm a newbie, but I had the same problem with no modules being loaded on bootup. Try the command "update-modules". I think that's what worked for me.

All times are GMT -5. The time now is 12:55 AM.