-   Linux - Newbie (
-   -   Modprobe issue on boot (Slackware Zipslack) (

Mathijs 02-16-2005 01:21 PM

Modprobe issue on boot (Slackware Zipslack)
Hi there!

I've recently installed Slackware on my PC, to be more precise: ZipSlack.

Since I want to have a really really basic system (as small as possible) so I can get to know the basics of Linux, I started removing packages with Pkgtool

My system still boots :D :cool: !!!!
However i get a lot more erros like:

depmod: Can't open /lib/modules/2.4.29/modules.dep for writing
/etc/rc.d/rc.M: line 33: /sbin/ifconfig: No such file or directory
/etc/rc.d/rc.M: line 35: /sbin/ifconfig: No such file or directory
/etc/rc.d/rc.M: line 37: /sbin/route: No such file or directory
modprobe: Can't open dependencies file /lib/modules/2.4.29/modules.dep (No such file or directory)

How can I get rid of this? Or should I just ignore it...

mmmm 02-16-2005 02:03 PM

1. Check file /lib/modules/2.4.29/modules.dep privileges. Root should be able to write it.
2. Install package with ifconfig and route (network tools?), or hash out net configuring in /etc/rc.d/rc.M. Better install.

Mathijs 02-17-2005 11:13 AM

Okay, I've found what the cause of the error is: my kernel version difers from my filesystem...
You might wonder how that is possible, sinds you build a kernel and a filesystem together, but I'm running Zipslack and had
some problems with my DVD/Cd-W/RW player/writer. I didn't read that much about Slackware as there was not that much info at hand, so in order to solve the prob I installed an older version of Zipslack, but did not change my Boot disk...

After wards I found out you had to get a different kernel, with bigger SCSI/IDE driver caps... I installed Lilo and used the kernel on the bootdisk as boot kernel...

Like this the directory 2.4.29 should be 2.4.26 as my kernel looks for that one

Solutions that popped up in my head:
- Rename the directory TRIED THIS: however, my libs etc. aren't made for kernel 2.4.29 but .26 ERRORS POP-UP!!!!!
- Reinstall everything: NOT AN OPTION I've already made too many changes and don't feel lke overdoing that...
- Copy/Paste a different kernel from out of Windows ---> TRYING THIS ONE NOW!!!!

if you have a better idea, pleeez let me know!


Mathijs 02-19-2005 12:10 PM

Okay, it worked!!
Thanks for the help anyway!

All times are GMT -5. The time now is 02:05 AM.