-   Linux - Newbie (
-   -   modem on ttyS1 ?? (

skguha 08-17-2005 11:17 PM

modem on ttyS1 ??

I am using Slackware 10.1 and did a full install.

/dev/modem points to /dev/ttyS1

but when i do

setserial /dev/ttyS1
i get the following output

/dev/ttyS1, UART: unknown, Port: 0x02f8, IRQ: 3
i read that the UART should be 16550A for modem to work. My pc is a dell optiplex gx280. How do i get my modem to work?


Michael Johnson 08-17-2005 11:36 PM

The error says that there is no UART on port /dev/ttyS1. This is very unusual. Check your BIOS and make sure it is not disabled. Have you tried
setserial /dev/ttyS0
and see if you get the UART.

skguha 08-17-2005 11:45 PM

the result of setserial /dev/ttyS0 is as follows

/dev/ttyS0, UART: 16550A, Port: 0x03f8, IRQ: 4
setserial /dev/ttyS4

/dev/ttyS4, UART: 16550A, Port: 0xd8c8, IRQ: 3
setserial /dev/ttyS5

/dev/ttyS5, UART: 16550A, Port: 0xd8d0, IRQ: 3
for all other ttyS* , i get UART unknown......

What does it mean??

pls explain....

skguha 08-17-2005 11:54 PM

when i type

cat /proc/tty/driver/serial
i get the following

serinfo:1.0 driver:5.05c revision:2001-07-08
0: uart:16550A port:3F8 irq:4 baud:9600 tx:0 rx:0
4: uart:16550A port:D8C8 irq:3 baud:9600 tx:0 rx:0
5: uart:16550A port:D8D0 irq:3 baud:9600 tx:0 rx:0

also the ouput of

cat /proc/interrupts

  0:    642774          XT-PIC  timer
  1:        16          XT-PIC  keyboard
  2:          0          XT-PIC  cascade
  3:          0          XT-PIC  usb-uhci
  5:          0          XT-PIC  usb-uhci
  8:          1          XT-PIC  rtc
  9:          0          XT-PIC  ehci_hcd, usb-uhci
 10:    126335          XT-PIC  eth0, Intel ICH6, usb-uhci
 11:          0          XT-PIC  pciehp
 14:      60916          XT-PIC  ide0
 15:        69          XT-PIC  ide1
NMI:          0
ERR:          0

what do i do now?

Michael Johnson 08-18-2005 12:01 AM

You have working serial ports on /dev/ttyS0, /dev/ttyS4, /dev/ttyS5, but no serial ports on /dev/ttyS1, /dev/ttyS3 and anything above /dev/ttyS5.
My suggestion is to connect your modem on /dev/ttyS0, /dev/ttyS4 or /dev/ttyS5
Did you check your BIOS settings?

skguha 08-18-2005 12:15 AM

i havent restarted my comp yet to check the bios settings....will do so and report it.....

also will connect to /dev/ttyS4 and see if it works...

but the /dev/modem points to /dev/ttyS1 ..... how do i change that??

Michael Johnson 08-18-2005 08:08 PM

you will need to be root and just remove /dev/modem and relink it to the device you wish use.
#rm /dev/modem
#ln -s /dev/ttyS4 /dev/modem
when do an ls on /dev/modem it should show you the link
#ls -l /dev/modem
Hope this helps
for documantation see
$man ln

All times are GMT -5. The time now is 11:49 PM.