LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Missing modules.dep (https://www.linuxquestions.org/questions/linux-newbie-8/missing-modules-dep-154768/)

DragonDon 03-07-2004 09:08 PM

Missing modules.dep
 
Ok, new install (Slackware 9.1) and now trying to get the network card running.

The NIC is not listed in the boot message (checked with dmesg | more).

The NIC is an ISA D-Link 220.

According to Ethernet How-To, this is supported using the ne2000 driver.

My problem....I know the driver is on the system (verified with "locate ne20") but now unsure howt o compile or add it into the system. I would prefer it to be loaded up all the time but if adding it in as a module is easier then that will work fine.

The /etc/modules.conf is empty.

Perhaps I need to take yet another step back.

This is a brand new install.

I had heard that the kernel should be recompiled after installing everything but...I have not seen any easy instructions.

The Kernel How-To assumes that you are upgrading and goes through the process of downloading/taring various files. I can't do that till I get the NIC running ;)

Now, I tried to recompile the Kernel and got a number of error messages right after typing 'make dep'.

The last line said:

"make: *** [scripts/mkdep] Error 1"

It sounds like something may hev been missing from my initial install.

Suggestions?

watashiwaotaku7 03-07-2004 11:32 PM

have you tried simply using netconfig? otherwise, the quick concise and dirty instructions for recompiling a kernel are cd into the top level of the kernel source, "make menuconfig", do all of your adjustments, (tip: most likely if the source was installed with slack then it will be preconfigured in a very generic way and all you have to do is go to the networking section and add your card), "make clean dep bzImage modules modules_install" "cp arch/i386/boot/bzImage /boot/bzImage-whatyouwanttocallit " "pico /etc/lilo.conf", edit lilo.conf to have a new entry exactly like your current slackware entry except changing the label and the name of the kernel image your booting (this lets you get away with not making a boot disk) then "/sbin/lilo" and reboot

DragonDon 03-09-2004 12:35 PM

Hi!

Well, tried make menu config...missing Ncurses. So I installed NCurses....now missing NCurses libraries....

I restarted the system just to make sure the Kernel was loaded up with it properly and still missing some libraries.

It's like it needs to be compiled but it won't because there is something missing to do the compile.....ugh.

I did go through and made pretty sure I had installed all the GCC modules but no change.

Anyone know what are all the libraries that NCurses needs?

watashiwaotaku7 03-11-2004 05:10 PM

us make xconfig instead then, or if all else fails use make config for the longer harder way (harder only because you cant go back and easily make changes)

DragonDon 03-11-2004 08:16 PM

Well, make xconfig doesn't work either.....ugh...

I did learn that I need most likely glibc-dev libraries.

So, checked out the CD 1...couldn't find it...., looking at CD 2....not sure if anything on it will help but who knows....

I'm going to try a new thread to see if that gets more info.


All times are GMT -5. The time now is 04:43 PM.