LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   missing fstab, /mnt entries (https://www.linuxquestions.org/questions/linux-newbie-8/missing-fstab-mnt-entries-607053/)

tobiusmaximus 12-15-2007 10:11 PM

missing fstab, /mnt entries
 
Hi, I have a few dumb questions. Believe it or not I've dug into google and howto's
on them for days and not come up with anything.
First, when an email client opens vim for the body of the message,
what in heck do I do when I'm done typing it?
Second, I've installed fedora core 6 removing only x and the GUI's, and
have no access to floppy, cd, or pendrive from shell. They are
all listed in /dev, but no entries in fstab for removeable
media and no entries -period- in /mnt or /media. If I
'service hal restart', the cd, floppy are checked but still
no entries.
Any clues?
p.s. I have tried to hack together entries manually and
got as far as the floppy being mounted only to have a flood
of i/o errors. Even if I got the entries right and it worked, what's
broke that they are not there to begin with?
Any help much appreciated!

jailbait 12-15-2007 11:06 PM

I can tell you how to set up your floppy and CD but I don't know how to set up a pendrive.
Here are couple of entries to put in /etc/fstab. Put them at the end of the list.

/dev/cdrom /media/cdrom auto ro,noauto,user,exec 0 0
/dev/fd0 /media/floppy auto rw,noauto,user,sync 0 0


You need to log in as root and make two new directories:

mkdir /media/cdrom
mkdir /media/floppy

Then to give all users permission to use the CDand floppy you need:

chmod 555 /media/cdrom
chmod 777 /media/floppy

Your CD is not really at /dev/cdrom. You need to make a link from /dev/cdrom to whatever the device name for your CD really is. Suppose that your CD is on /dev/hdd (slave on IDE cable 2). Then as root you would make your CD link like so:

ln -s /dev/hdd /dev/cdrom

"what's broke that they are not there to begin with?"
The Fedora installer detects every device on your system and sets them up. Obviously your installer did not set up the floppy and cd. The most common reason for the installer to miss devices is if they are not powered on at install. As a last resort you could reinstall again and see if the installer finds every device the next time.

--------------------
Steve Stites

jschiwal 12-16-2007 02:04 AM

I think that kde or gnome is involved in automatically mounting removable devices. You removed X11 so I think you may want to add entries to /etc/fstab.

It would be better to use udevinfo to uniquely identify each device, because you don't know which device will be assigned when you plug it in. If it is in /dev/sdb one time, it might be /dev/sdc the next.

With the pendrive plugged in, find out which device it is that time. Then use "udev -q env -n /dev/<device>" and use either the UUID or the LABEL in the /etc/fstab entry. For the vfat filesystem, include the "uid=" & "gid=" options so that you are the owner of the mounted partition. Also use "noauto", otherwise you may hang when booting up. Using the "user" option will allow you to mount the pendrive as a normal user.

tobiusmaximus 12-16-2007 09:37 AM

this post is here because lynx is a %*&$^.

tobiusmaximus 12-16-2007 09:41 AM

Thanks, yall. I got the cdrom working last night. The deal now
and why there ought to be some utility is what about cd
burning, etc. Linux lists different devices for every
aspect of functionality (cdwrite, cdrw etc) and there's a
bunch of them for every device.
What about the email???
No vim manual or email client stuff I've read has said a
damned thing about what to do with a message when your done. If I save it,
it takes me back to the email client and says 'message lost'.
Does vim have built in functionality for email? I've read
until my left eye is squirting blood. I am going to go kick
my neighbor's dog.

tobiusmaximus 12-16-2007 10:07 AM

I have two options. Both not quite simple, yet not very easy.
I can:
A: Spend 5 hours squinting at google search results and
manually entering and testing entries.
B: Spend 5+ hours installing mandriva which properly lists
all devices for my configuration and copying them down, then
re-installing fedora and manually entering and testing on this
pentium pro.
C: I could jam a screwdriver in the motherboard with the power
on, yelling, DEATH TO THE MACHINES LONG LIVE THE NEO-LUDDITES!!!!!

tobiusmaximus 12-16-2007 10:14 AM

But I cant-
D: Email anyone and &%^*( and complain about it,
What about vim and email?

tobiusmaximus 12-17-2007 04:53 PM

Quote:

Originally Posted by jschiwal (Post 2992003)
I think that kde or gnome is involved in automatically mounting removable devices. You removed X11 so I think you may want to add entries to /etc/fstab.



I RTFM and found the trouble with Fedora anyway (TFM paraphrased) NO AUTOMATIC FSTAB EDITING "fstab-syn has been removed, in favor of desktop solutions for removeable media. Command line users may
migrate to gnome-mount...."

chrism01 12-17-2007 06:35 PM

Which email client are you using. Thunderbird is often the default, but it doesn't use vim.

tobiusmaximus 12-20-2007 06:07 PM

Quote:

Originally Posted by chrism01 (Post 2994017)
Which email client are you using. Thunderbird is often the default, but it doesn't use vim.

Mutt, for one. Vim is invoked for writing the email itself, and I have zero clue what to do with it. I finally just exit or save! MYFRIKINGEMAIL and forget about it. Nothing in man or info or the gagillion searches I've done on using vim with email. Nothing in mutt either.


All times are GMT -5. The time now is 10:27 PM.