LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-03-2012, 09:16 PM   #1
m4west
LQ Newbie
 
Registered: Aug 2012
Posts: 8

Rep: Reputation: Disabled
Mint keyboard configuration


Iam new to linux and have installed Mint on an Asus tower.
The keyboard is essentially designed for windows and the only problem I have is the , and . are in the wrong position ( you have to press , for . and vice versa). How can I correct this
 
Old 11-04-2012, 05:20 AM   #2
pierre2
Member
 
Registered: May 2009
Location: Perth, AU
Distribution: LinuxMint
Posts: 369
Blog Entries: 8

Rep: Reputation: 85
Sounds like a locality error.

what did you give as your keyboard locality?
- USA is the default - are you using a UK keyboard?
 
1 members found this post helpful.
Old 11-04-2012, 10:27 AM   #3
DavidMcCann
Senior Member
 
Registered: Jul 2006
Location: London
Distribution: CentOS, Salix
Posts: 4,581

Rep: Reputation: 1428Reputation: 1428Reputation: 1428Reputation: 1428Reputation: 1428Reputation: 1428Reputation: 1428Reputation: 1428Reputation: 1428Reputation: 1428
It's a good idea to put your location in your profile. What do you get in you enter these commands in the terminal emulator?
locale
setxkbmap -print
 
1 members found this post helpful.
Old 11-06-2012, 04:31 PM   #4
m4west
LQ Newbie
 
Registered: Aug 2012
Posts: 8

Original Poster
Rep: Reputation: Disabled
The replys I have as below
LANG=C
LANGUAGE=
LC_CTYPE="C"
LC_NUMERIC=en_GB.UTF-8
LC_TIME=en_GB.UTF-8
LC_COLLATE="C"
LC_MONETARY=en_GB.UTF-8
LC_MESSAGES="C"
LC_PAPER=en_GB.UTF-8
LC_NAME=en_GB.UTF-8
LC_ADDRESS=en_GB.UTF-8
LC_TELEPHONE=en_GB.UTF-8
LC_MEASUREMENT=en_GB.UTF-8
LC_IDENTIFICATION=en_GB.UTF-8
LC_ALL=
robert@robert-A7N8X-X ~ $ setxkbmap -print
xkb_keymap {
xkb_keycodes { include "evdev+aliases(qwerty)" };
xkb_types { include "complete" };
xkb_compat { include "complete" };
xkb_symbols { include "pc+gb+inet(evdev)+terminate(ctrl_alt_bksp)" };
xkb_geometry { include "pc(pc105)" };
};
robert@rob
 
Old 11-06-2012, 04:43 PM   #5
m4west
LQ Newbie
 
Registered: Aug 2012
Posts: 8

Original Poster
Rep: Reputation: Disabled
Just checked the keyboard on my windows computer - EMBARRASSING
Looks like the problem is with this keyboard as the ., are reversed there
Oh well just get some tipex out modify.Good old EBay!!!!!!
Thanx for your help Robert
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Mint 13 - wireless configuration problem taylorkh Linux Mint 4 04-27-2013 08:51 PM
[SOLVED] Need program to run keyboard macros in any app. under Mint jbrucek Linux - Newbie 1 10-16-2012 02:11 PM
Issues setting keyboard shortcuts on Linux Mint Debian Edition ratman1 Linux - Newbie 1 06-19-2012 10:53 AM
USB keyboard & mouse stop working intermittently on Linux Mint 12 boot macked Linux - Hardware 1 01-17-2012 04:24 AM
Mint 10 Keyboard Not Responding Until Re-start. Novatian Linux Mint 0 11-17-2010 10:17 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 01:48 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration