Share your knowledge at the LQ Wiki.
Go Back > Forums > Linux Forums > Linux - Newbie
User Name
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!


  Search this Thread
Old 10-17-2011, 09:10 AM   #1
LQ Newbie
Registered: Jun 2011
Location: WI, USA
Distribution: Mint
Posts: 12

Rep: Reputation: Disabled
Mint dual-boot install doesn't have boot option at start up

I installed Mint 11 on my xp laptop and selected the dual boot option. The install seemed to go very well on the 300 gb hard drive. The drive was partitioned nearly equally with a slightly larger portion given to windows. When I was given the notice to restart the machine, I did so and the computer launched directly to windows. I thought that I must have missed the os boot option while looking at something else. I re-booted the computer but have the same situation. The new partition shows in "my computer" but, of course windows cannot read it. Is there a way to remedy this?
Old 10-17-2011, 09:27 AM   #2
LQ Addict
Registered: Jul 2002
Location: East Centra Illinois, USA
Distribution: Debian stable
Posts: 5,908

Rep: Reputation: 356Reputation: 356Reputation: 356Reputation: 356
I have no experience with Mint, but I suspect that the following error occured. During installation, you were given the option of installing grub to the MBR (master boot record) of the hard drive, or to the boot sector of the Mint partition. If the default was to install to the boot sector of the partiton, or if you selected that option, that would explain your problem.

Insert the Mint install disk and power up. Does the Mint install disk offer the option to boot from hard drive? If so, select that option. Once in Mint, you can run grup-install (hd0) to install grub to the MBR (do some research to verify the command I just gave you).

Note that you may have to manually edit the grub2 configuration files to add windows to the boot menu.

Or, you could re-install Mint. When the installation reaches the grub install, be careful to select installing grub to the MBR.
1 members found this post helpful.
Old 10-17-2011, 09:40 AM   #3
LQ Guru
Registered: Apr 2008
Distribution: PCLinux, Slackware
Posts: 9,854

Rep: Reputation: 2277Reputation: 2277Reputation: 2277Reputation: 2277Reputation: 2277Reputation: 2277Reputation: 2277Reputation: 2277Reputation: 2277Reputation: 2277Reputation: 2277
I haven't used Mint 11 but, in Mint 10 the Allocate Drive Space window had an option with a drop-down box at the bottom "Device for Boot Loader Installation" which is where you would select the drive. Booting straight into windows after the installation would lead me to agree with bigrigdriver about what happened. I've always used manual partitioning so I'm not sure what options you get with the "dual boot option". The link below gives an explanation of reinstalling Grub2 on Ubuntu but Mint uses Grub2 also so the methods should work. Check Section 12.2:
1 members found this post helpful.


dual boot, install, mint, partitioning, xp

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
No 'Alongside' option when trying to install Ubuntu 11.04 to dual boot with Windows 7 UnfairBear Linux - Newbie 17 06-20-2019 03:00 PM
[SOLVED] Deleting the dual boot option menu at the beginning of Start-Up josecolella Linux - Newbie 1 03-07-2011 04:05 AM
Install Mint 7 on existing XP Pro/ubuntu 9.04 dual boot blues2use Linux Mint 5 11-05-2009 10:28 PM
Help needed to install Redhat Fedora 4 with dual boot option anon108 Linux - Laptop and Netbook 1 08-04-2009 06:38 AM
Installed ubuntu dual boot, but grub doesn't start instead XP starts normally abhishekpapanna Ubuntu 6 12-07-2008 02:40 PM > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 12:44 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration