LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-06-2017, 07:10 PM   #16
Gary987
Member
 
Registered: Oct 2003
Distribution: Gentoo, Mint, Ubuntu, Vector
Posts: 174

Rep: Reputation: 17

what does aplay -L show?

Something like this at the top?

aplay -L

null
Discard all samples (playback) or generate zero samples (capture)
pulse
PulseAudio Sound Server
default:CARD=SB
HDA ATI SB, ALC892 Analog
Default Audio Device
sysdefault:CARD=SB
HDA ATI SB, ALC892 Analog
Default Audio Device
front:CARD=SB,DEV=0
HDA ATI SB, ALC892 Analog
Front speakers
surround21:CARD=SB,DEV=0

...............................................................
 
Old 02-06-2017, 07:11 PM   #17
Gary987
Member
 
Registered: Oct 2003
Distribution: Gentoo, Mint, Ubuntu, Vector
Posts: 174

Rep: Reputation: 17
And does this command make any noise? (assumming you have this wav file at that location)


aplay -D default /usr/share/sounds/alsa/Front_Center.wav
 
Old 02-06-2017, 07:19 PM   #18
Gary987
Member
 
Registered: Oct 2003
Distribution: Gentoo, Mint, Ubuntu, Vector
Posts: 174

Rep: Reputation: 17
duplicate
 
Old 02-06-2017, 11:36 PM   #19
Lawn Ranger
LQ Newbie
 
Registered: Feb 2017
Location: Up north
Distribution: Mint 18.1
Posts: 27

Original Poster
Rep: Reputation: Disabled
Hi, Gary. I sure appreciate your help on this.


aplay -D default /usr/share/sounds/alsa/Front_Center.wav
No sound



aplay -l shows:

default
Playback/recording through the PulseAudio sound server
null
Discard all samples (playback) or generate zero samples (capture)
pulse
PulseAudio Sound Server
sysdefault:CARD=SB
HDA ATI SB, ALC892 Analog
Default Audio Device
front:CARD=SB,DEV=0
HDA ATI SB, ALC892 Analog
Front speakers
surround21:CARD=SB,DEV=0
HDA ATI SB, ALC892 Analog
2.1 Surround output to Front and Subwoofer speakers
surround40:CARD=SB,DEV=0
HDA ATI SB, ALC892 Analog
4.0 Surround output to Front and Rear speakers
surround41:CARD=SB,DEV=0
HDA ATI SB, ALC892 Analog
4.1 Surround output to Front, Rear and Subwoofer speakers
surround50:CARD=SB,DEV=0
HDA ATI SB, ALC892 Analog
5.0 Surround output to Front, Center and Rear speakers
surround51:CARD=SB,DEV=0
HDA ATI SB, ALC892 Analog
5.1 Surround output to Front, Center, Rear and Subwoofer speakers
surround71:CARD=SB,DEV=0
HDA ATI SB, ALC892 Analog
7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
iec958:CARD=SB,DEV=0
HDA ATI SB, ALC892 Digital
IEC958 (S/PDIF) Digital Audio Output
dmix:CARD=SB,DEV=0
HDA ATI SB, ALC892 Analog
Direct sample mixing device
dmix:CARD=SB,DEV=1
HDA ATI SB, ALC892 Digital
Direct sample mixing device
dsnoop:CARD=SB,DEV=0
HDA ATI SB, ALC892 Analog
Direct sample snooping device
dsnoop:CARD=SB,DEV=1
HDA ATI SB, ALC892 Digital
Direct sample snooping device
hw:CARD=SB,DEV=0
HDA ATI SB, ALC892 Analog
Direct hardware device without any conversions
hw:CARD=SB,DEV=1
HDA ATI SB, ALC892 Digital
Direct hardware device without any conversions
plughw:CARD=SB,DEV=0
HDA ATI SB, ALC892 Analog
Hardware device with all software conversions
plughw:CARD=SB,DEV=1
HDA ATI SB, ALC892 Digital
Hardware device with all software conversions
hdmi:CARD=NVidia,DEV=0
HDA NVidia, HDMI 0
HDMI Audio Output
hdmi:CARD=NVidia,DEV=1
HDA NVidia, HDMI 1
HDMI Audio Output
dmix:CARD=NVidia,DEV=3
HDA NVidia, HDMI 0
Direct sample mixing device
dmix:CARD=NVidia,DEV=7
HDA NVidia, HDMI 1
Direct sample mixing device
dsnoop:CARD=NVidia,DEV=3
HDA NVidia, HDMI 0
Direct sample snooping device
dsnoop:CARD=NVidia,DEV=7
HDA NVidia, HDMI 1
Direct sample snooping device
hw:CARD=NVidia,DEV=3
HDA NVidia, HDMI 0
Direct hardware device without any conversions
hw:CARD=NVidia,DEV=7
HDA NVidia, HDMI 1
Direct hardware device without any conversions
plughw:CARD=NVidia,DEV=3
HDA NVidia, HDMI 0
Hardware device with all software conversions
plughw:CARD=NVidia,DEV=7
HDA NVidia, HDMI 1
Hardware device with all software conversions
sysdefault:CARD=USB
Jabra SPEAK 510 USB, USB Audio
Default Audio Device
front:CARD=USB,DEV=0
Jabra SPEAK 510 USB, USB Audio
Front speakers
surround21:CARD=USB,DEV=0
Jabra SPEAK 510 USB, USB Audio
2.1 Surround output to Front and Subwoofer speakers
surround40:CARD=USB,DEV=0
Jabra SPEAK 510 USB, USB Audio
4.0 Surround output to Front and Rear speakers
surround41:CARD=USB,DEV=0
Jabra SPEAK 510 USB, USB Audio
4.1 Surround output to Front, Rear and Subwoofer speakers
surround50:CARD=USB,DEV=0
Jabra SPEAK 510 USB, USB Audio
5.0 Surround output to Front, Center and Rear speakers
surround51:CARD=USB,DEV=0
Jabra SPEAK 510 USB, USB Audio
5.1 Surround output to Front, Center, Rear and Subwoofer speakers
surround71:CARD=USB,DEV=0
Jabra SPEAK 510 USB, USB Audio
7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
iec958:CARD=USB,DEV=0
Jabra SPEAK 510 USB, USB Audio
IEC958 (S/PDIF) Digital Audio Output
dmix:CARD=USB,DEV=0
Jabra SPEAK 510 USB, USB Audio
Direct sample mixing device
dsnoop:CARD=USB,DEV=0
Jabra SPEAK 510 USB, USB Audio
Direct sample snooping device
hw:CARD=USB,DEV=0
Jabra SPEAK 510 USB, USB Audio
Direct hardware device without any conversions
plughw:CARD=USB,DEV=0
Jabra SPEAK 510 USB, USB Audio
Hardware device with all software conversions
 
Old 02-11-2017, 01:41 PM   #20
Gary987
Member
 
Registered: Oct 2003
Distribution: Gentoo, Mint, Ubuntu, Vector
Posts: 174

Rep: Reputation: 17
try aplay -D sysdefault /usr/share/sounds/alsa/Front_Center.wav

Probably that would play nothing as well..


When you play something... Does it show in pavucontrol under playback... ie what application is running and is the signal bar flucating as it plays?
 
Old 02-11-2017, 01:44 PM   #21
Gary987
Member
 
Registered: Oct 2003
Distribution: Gentoo, Mint, Ubuntu, Vector
Posts: 174

Rep: Reputation: 17
Sometimes on my rig the soundcard fails to initialize on boot, but yours seems to be showing that all is well ?
 
Old 02-11-2017, 01:45 PM   #22
Lawn Ranger
LQ Newbie
 
Registered: Feb 2017
Location: Up north
Distribution: Mint 18.1
Posts: 27

Original Poster
Rep: Reputation: Disabled
Hi, Gary. I tried the aplay thing but no luck. Pulseaudio shows activity and allows me to select the built-in audio but no sound. I gave up and bought a sound blaster, $40 and problem solved. Tired of messing with it.

I do appreciate your help even though we couldn't figure it out.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Mint 18.1 / RealTek ALC892 - no sound Lawn Ranger Linux - Newbie 2 03-15-2017 11:15 AM
Install script for Realtek 8192SU driver error Sangertz Linux - Wireless Networking 3 12-18-2013 01:35 PM
"Make" error while trying to install Realtek ALC892 sound driverin Kubuntu 12.04 lcharles Linux - Newbie 7 06-19-2013 09:57 PM
Realtek ALC892 Support in Kernel 2.6.35 ? jv2112 Linux - Hardware 1 11-13-2010 06:42 PM
[SOLVED] No Sound with Realtek ALC892 on Debian Squeeze PehJota Linux - Desktop 3 08-25-2010 01:26 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 01:34 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration