-   Linux - Newbie (
-   -   Mint 11 fails to boot after update (

Uaebuntu 09-16-2011 05:02 AM

Mint 11 fails to boot after update
Been running Mint 11 64 bit with no problems until I did a software upgrade. Now when switching on system I get GRUB Screen

GNU GRUB version 1.99~rc1-13ubuntu3-1mint1

This gives me 4 options, the first of which is highlighted

Linux Mint 11 64 bit 2.6.38-8-generic (/dev/sda1)

The others are the recovery mode and memory tests. Grub did not appear before the update and now that it does the system does not boot no matter how long you wait and the keyboard arrow keys will not move the highlight so I can't try the recovery mode.

Tried a different keyboard/USB port and same problem, it will boot from a CD Rom (systemrescuecd-x86-2.3.1) in 32 bit mode and the keyboard then works. I suspect the USB K/B driver isn't loaded so Grub now it appears can't work. I don't know how to check this and ensure it is available at boot time or bypass GRUB if it's not needed. Could be wrong so any other suggestions appreciated.

andrewthomas 09-16-2011 07:09 AM

I would try to boot into you Mint with Super Grub2 Disk:

Then follow these instructions to purge and re-install Grub2

Note: Since you can get to your normal installation (with the Super Grub2 Disk) without using a Live CD the chroot procedure is not necessary and you need only Steps 2-5.

Uaebuntu 09-16-2011 08:32 AM

Can boot from Live CD
Tried booting from the Grub 2 CD but had the same problem, the first line "Detect any OS" was highlighted but no response from the keyboard either in pressing ENTER or using the UP/DOWN arrows.

However the article you pointed me to looks promising as I have successfully booted from the live CD I used to install MINT and the keyboard works

Tried doing a GRUB repair, but no luck so will now purge and reinstall GRUB. Just want to be a bit cautious and make sure I have a bit of uninterrupted time on the computer as it looks tricky.

Uaebuntu 09-16-2011 09:01 AM

Purged and reinstalled GRUB2 same result
OK, booted from Mint 11 64 Live CD and followed the instructions to purge and re install Grub2 and have got the same result, GRUB 2 screen up, first entry highlighted but unresponsive keyboard and cannot boot.

If I mount /dev/sda1/ on the Live CD system I would be able to access all the home folders for my wife , daughter and son that have not been backed up and copy the data somewhere else like an external USB drive and then just reinstall from the live CD.

If I can reboot I could then restore my backup and copy their data back... does this make sense?

Uaebuntu 09-16-2011 09:35 AM

Woo Hoo YannBuntu
Thanks Andrew....

You got me on the right track and I have fixed the problem. The link you gave me was useful and I tried the repairs and the purge re install as suggested, but no effect. Within the link you sent was another link to a GRUB 2 repair tool for Ubuntu.

Before I did a reinstall as I was planning I thought I'd give it a try as MINT is an Ubuntu "derivative" if that is the right word AND it claimed to work from a Live CD.

The great news is that it works OK with Mint 11 AND it fixed the problem I was having with one click! To save you looking for the information I have copied the instructions from YannBuntu's site to install the boot repair application, you can do this for a HDD, Live CD or USB boot:


sudo add-apt-repository ppa:yannubuntu/boot-repair && sudo apt-get update && sudo apt-get install -y boot-repair && boot-repair
Thanks again Andrew and thanks YannBuntu

andrewthomas 09-16-2011 08:26 PM

You're welcome.

Glad to be of help.

All times are GMT -5. The time now is 04:15 PM.