-   Linux - Newbie (
-   -   Minor problems (

Gai-jin 01-05-2003 06:48 AM

Minor problems
Hi. I've just got a few minor issues that I'm not able to
resolve by myself, so any help would be greatly appreciated.

My first problem is with LILO. I've configured
it to boot Windows 2000 and Linux. It boots into Windows
2000 without problems, but when I try to boot into Linux,
I get a message "Block Error ...". As soon as the error a
ppears, it returns to the "boot: linux" prompt, so I can't
properly make out the entire error message. But I think
there is a hexadecimal number. The only way that I can boot
into Linux is if I hold down the "Enter" key for a few
seconds, after which it boots straight intoLinux without
any problems.

Next problem is with XMMS. After installing XMMS, I'm able
to play MP3s without any problems, but I'm not able to
control the volume from within XMMS. I can adjust the volume
from Kmix though, but I would prefer to do it in XMMS. Is
this a problem with how I've installed XMMS or my sound
configuration? (I've used kernel modules maestro3.o and

Here is some info about my system:
Debian Linux 3.0 r2 'Woody'
Kernel 2.4.18
XMMS 1.2.7
9GB Primary Master IDE HDD
Win2k on partition 1 - 1.5GB
Linux on partition 2 - 1.5GB
Swap on partition 3 - 64MB
30GB Secondary Master IDE HDD
ESS Allegro Sound Card

One more thing, I've noticed that Linux sets the Win2k
partition to /dev/hda2, even though it's the first partition
on the drive. Also, my second HD has only one big partition
on it, yet linux sets it to /dev/hdc5. Why is this?

Sorry for the lengthy post, and thanks in advance.

Mara 01-05-2003 04:10 PM

Booting problem: try to run fsck on the Linux partition (without mounting the partition, so from a boot cd etc).

XMMS: What heppens when you change the volume in XMMS? Nothing? Small noise? Something different?

I'm not sure why the Windows partition is hda2, maybe because there is/was something. hdc5 means it's an extended partition (extended start from 5, first extended is hdc5, second hdc6 and so on).

Gai-jin 01-05-2003 10:26 PM

I used my Debian CD to boot into the computer. The fsck command couldn't be found, but there was the e2fsck command which I decided to try out. I ran "e2fsck /dev/hda3" and it reported that it was "clean". I tried it again with the -c option to check for bad blocks. It complained that there was an inode with a zero length, after which it prompted me to fix it. After answering yes, it finished the rest of the checks with no further problems. I rebooted the computer into Linux, but LILO still reported a block error. Did I have to use fsck? If so, how can I run it after I've booted in with my CD?

I solved the XMMS problem. The permissions for /dev/mixer weren't set properly. After changing the permissions, I was able to adjust the volume from within XMMS.

And about the Windows partition being hda2: I accidentally ran e2fsck on /dev/hda1, and it reported that it might have been a zero length partiton.

Mara 01-07-2003 03:18 PM

Boot again from the cd and try e2fsck again. Is there still the inode problem?

If the partition /dev/hda1 exists, don't delete it. It may cause problems with Windows.

Gai-jin 01-07-2003 09:11 PM

All the checks completed with no problems. Is there a way for me to log the output from the LILO boot propmt, or to slow down the output. Maybe knowing the exact error message might help, but it goes by so fast that I can't make it out.

All times are GMT -5. The time now is 04:17 PM.