-   Linux - Newbie (
-   -   Microphone not working (

Blasphemous 12-11-2011 11:32 AM

Microphone not working
Can't get my laptop integrated microphone to work.
I'm using Debian Squeeze Stable.

Here's my situation according to alsamixer:


VDP76 12-11-2011 01:57 PM


please, post the results of the following commands:

arecord -l

cat /etc/modprobe.d/alsa-base.conf
What is the model of your laptop?

good luck.. ;)

Blasphemous 12-11-2011 02:13 PM


**** List of CAPTURE Hardware Devices ****
card 0: SB [HDA ATI SB], device 0: STAC92xx Analog [STAC92xx Analog]
Subdevices: 2/2
Subdevice #0: subdevice #0
Subdevice #1: subdevice #1

# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7
# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd && { /sbin/modprobe --quiet snd-ioctl32 ; /sbin/modprobe --quiet snd-seq ; }
install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi && { /sbin/modprobe --quiet snd-seq-midi ; : ; }
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 && { /sbin/modprobe --quiet snd-emu10k1-synth ; : ; }

# Prevent abnormal drivers from grabbing index 0
options bt87x index=-2
options cx88_alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
# Keep snd-pcsp from beeing loaded as first soundcard
options snd-pcsp index=-2
# Keep snd-usb-audio from beeing loaded as first soundcard
options snd-usb-audio index=-2
I'm using a HP pavilion Dv5 1102el:

I have to say that, in a previous Debian installation, the mic worked fine!

Btw, thanks for your help..

VDP76 12-11-2011 04:05 PM

as root, edit your /etc/alsa-base.conf file with the text editor of your choice and add the following line

options snd-hda-intel model=hp-dv5
reboot and check your microphone... ;)

Recently I had a similar problem and this solution worked for me...good luck! :D

FYI, you can find a complete guide to sound card related problems here.

impert 12-11-2011 05:14 PM

1 Attachment(s)
I had a battle getting my mcrophone to work,so I made a note of the settings. Change the card to suit.

Attachment 8617
Hope this helps.

jmlm_1970 03-26-2012 07:10 PM

The only solution to make microphone work is to install linux-backports-modules-alsa-generic...

Just go to:

Menu / System / Administration / Synaptic Package Manager

And search and mark for installation:


tip: if you have multiple versions click on the first and read the description which should inform what name to install...

If after the reboot and mic mute is off, still does not work, just go to terminal and type:

sudo nano /etc/modprobe.d/alsa-base.conf

and add or change the following:

options snd-hda-intel model=auto enable=yes

Then Ctrl+X, type Y to write and exit, reboot and mic will work.

Bye and have lots of fun with Ubuntu (the best).

VDP76 03-27-2012 02:26 PM

I guess that linux-backports-modules-alsa-generic package is specific for Ubuntu: may work for that, but might not be suited for Debian...

Originally Posted by jmlm_1970 (Post 4637065)
options snd-hda-intel model=auto enable=yes

why "auto" when the model is known!?? ;)

All times are GMT -5. The time now is 09:22 PM.