-   Linux - Newbie (
-   -   mgmt.o and alcatel speedtouch. (

stan03 08-12-2003 03:01 PM

mgmt.o and alcatel speedtouch.
Im sorry if this is the wrong forum, but could someone please tell me how to log in as root? I am using madrake linux and it automatically brings me to the desktop. If i log out, and hit ctr alt f1 it goes to this black screen where i can log in as root, but then cannot get to the desktop. question #2 why does linux tell me that a cannot access the usr/share directory? I am trying to intall my alcatel speedtouch usb modem, and i am supposed to put a mgmt.o file into the usr/share/speedtouch dir. when i try to do that is says access denied or something. So I can't get the .o file into the speedtouch directory... anyone have the speedtouch USB and can give me an easier way to get this thing working? Sorry for the long post, complete noobie here.

david_ross 08-12-2003 03:22 PM

To get back to the desktop try "Ctrl + Alt + F7". You can bring up a terminal screen in the gui then type:
su -

then the password when prompteed then this will give you root access. When you say it says access denied - is that as root? You will need to be root to put a file there.

stan03 08-12-2003 05:40 PM

ok, no its not as root.

Newman_SCO 08-12-2003 06:36 PM

Willing to help. If you explain what "ok, no its not as root" means

(speedtouch user)

stan03 08-12-2003 06:42 PM


Originally posted by david_ross
- is that as root? You will need to be root to put a file there.
that was in answer to that question
ok now i did this:
hit ctr alt f1 and login: root password: blah blah ok? then i do % su
password: "put in the root password"
# cp path/to/file/mgmt.o /usr/share/speedtouch/

if you get an error you might have to go:
# mkdir /usr/share/speedtouch/

now i hit ctr alt f7 an im back into the destop. and guess what... now there is a file in the destination labeled as "D" i can't delete it, i cante rename, and when i try to open it, it asks what program i want to use... and i have no idea. and i guess after i return to the desktop im no longer root becuase it says access denied for everything i try to do with that file.

Newman_SCO 08-12-2003 06:57 PM

for a start you have no need to go in to a full console mode to install the modem.

U start off in mandrake control centre yes?

U try to set up the internet connection. U select the speedtouch (detected). Next next next.

It wants a mgmt.o from the speedtouch website. (which is truely stupid I know, if u don't have another connection to the net)

Grab the mgmt.o and put it anywhere. example /home/myname/
(as you probably did, just recapping to make things clear)

Simply load a shell. (konsole for example) From the K menu.
You will find it.

as u said type su
then password

type locate
(it will display where the script is if u installed the drivers properly, the mgmt.o needs to go next to the script)

navigate to that directory. cd /etc/speedtouch/whatever

type ls
(to make sure is there)

cp /home/myname/mgmt.o /etc/wherethedirectorywas/mgmt.o

Go to the mandrake control centre. and run the modem setup again. takes it time. But u will see the modem starting to flash.

Should be connected after that mate.

Good luck to u. Have tried to be detailed.


Newman_SCO 08-12-2003 07:08 PM

Note on : locate
It might be Case sensitive.

Try locate



stan03 08-13-2003 05:58 PM

UPDATE: i got the file into the correct folder throuh nautilus. BUT now it doesn't tell me what to do and does not connect. SPEEDTOUCH USERS HELPPPP

Newman_SCO 08-13-2003 06:28 PM

I don't quite understand what u mean by "BUT now it doesn't tell me what to do "

What are u referring to?


Once you have the mgmt.o next to the

Run the internet setup wizard. Through the mandrake control centre (again)

Fill in your username and password.
Leave the DNS settings (once you connect, it will find them its self)


It no longer asks for a mgmt.o . correct?

And the modem should start a flashing light sequence when it starts configuring.

If it doesn't. Sorry.

Tried my best for u. ;)


stan03 08-13-2003 07:16 PM

before i had gotten the box telling me to put the file into the directory so i assumed thats why i couldn't connect. but now i still cant connect, and there is to box/window thing that pops up to tell me what to do next.

All times are GMT -5. The time now is 05:12 PM.