-   Linux - Newbie (
-   -   messed up xorg.conf (

losingfight 04-27-2005 12:06 AM

unable to login or do anything
I've basically been using the system by booting into run level 4 for the past few days, so that after booting the linux goes straight to gdm. For some reason when using gdm I cannot access any of the virtual terminals, but if I boot into run level 3 and use startx then I can access the virtual terminals just fine. Well, I just decided to screw up my xorg.conf and have set the color depth too high for my card. Of course I get an error from X11 and then it kicks me into the CLI, only I'm not getting any the CLI. No matter what virtual terminal I try to switch to I get the same thing: a black screen and I can't put in any commands. I've tried booting off a slackware 10.1 installation disk and then mounting /hda2, but then I can't seem to access it. So now I'm all out of ideas, but all I need is just edit my damn xorg.conf file. So if anyone can help, it'll be much appreciated. Thanks ahead of time.

dalek 04-27-2005 12:26 AM

Try one of these two commands:




With that you can get a fresh start on that config file. You may want to save the old one so you can copy it back, just in case something goes wrong and you can't get anything but a ugly error message.

Hope that helps. It has been a while since I have had to run that.


:D :D :D

Of course, it has been a while since I rebooted too.


root@smoker / # uptime
 00:23:36 up 167 days, 16:59,  3 users,  load average: 0.44, 0.20, 0.13
root@smoker / #

losingfight 04-27-2005 12:34 AM

I know exactly what the problem with the xorg.conf is, I can fix that. The problem is that when X11 tells me there is an error I'm supposed to go to the CLI. I just get a blinking box and blank screens with a blinking box at the top of each virtual terminal. I need a way to get into the default CLI without going into X or whatever. Sorry if my problem isn't quite clear.

kencaz 04-27-2005 01:10 AM

Re: unable to login or do anything

Originally posted by losingfight
I've tried booting off a slackware 10.1 installation disk and then mounting /hda2, but then I can't seem to access it.
So you booted into rescue (single user) mode and you say you were able to mount /hda2 but not access it? I have not used rescue mode in the Slackware 8 that I have and don't know if it would give you access.

If you have a LiveCD you could boot and mount your /hda2, however, it would most likely still be read-only, but I think you could use this command in su mode:

mount -o remount,rw /mnt/
may have to use:
sudo mount -o remount,rw /mnt/

This should mount all file systems in fstab to read-write, allowing you to edit your xorg.conf file.


losingfight 04-27-2005 01:21 AM

What do you mean by rescue mode? What I meant was that I managed to boot using the installation disk for slack 10.1 (is that the same as LiveCD?). After booting there it would not let me go into su mode. I used /mount -t ext2 rw /dev/hda2 /mnt i think, but then it woudln't let go into the /mnt/hda2 directory. Thanks for all the help, I got it to work.

elluva 04-27-2005 02:51 AM

It doesn't have to be this complicated. When booting slackware, you always have your first terminal, it is always accessible (CTRL + ALT + F1), it could be busy, that I don't remember, but then F6 is there as well.
So no mather what happens, you can always access those.


losingfight 04-27-2005 03:10 AM

haha, I didn't realize the sixth terminal worked. In any case I got it to work, but the other 4 terminals still don't work for some reason.

elluva 04-27-2005 03:21 AM

its no bug, just read the comments in your inittab, the guys from slackware specifically configured it that way.

losingfight 04-27-2005 03:39 AM

So, there is no way to enable tty2-5 on slackware when at runlevel 4? Not that it's the end of the world or anything, it just bugs me.

tinksmartbstupi 04-27-2005 08:50 AM

For future notice:

in slackware 10, they did this neat thing. the second install disc IS the rescue disk, and from that you can do anything you want. I've had to play with that a few times, so I can tell you it's definately a helpful tool. c

as for the vitual consoles, what I used to do is just add, I think the path is "/opt/kde/bin/kdm" to /etc/rc.d/rc.local
this way I'd have a windows manager start up, and I've have the virtual consoles.

losingfight 04-27-2005 04:27 PM

So you're saying to add the path of gdm to rc.local, but then should i be booting in run level 3? Run level 4 would seem redundant. Either way, I've tried adding the gdm path to rc.local and have booted in both run levels 3 and 4. At 3 all I get is the standard CLI, and at 4 I get an error that rc.4 cannot be executed. I've checked the rc.4 file and it's perfectly fine. So I guess i'm not quite sure how adding the gdm path to rc.local might help. Thanks for the suggestion though.

elluva 04-28-2005 03:27 AM

no, don't do this, the fourth runlevel is specifically made for this kind of thing. Take a good look at /etc/inittab, there should be a man page about this as well. You can add those terminals in that file.

elluva 04-28-2005 03:31 AM

In inittab you'll probably have a couple of lines like this:

1:2345:respawn:/sbin/getty 38400 tty1
2:23:respawn:/sbin/getty 38400 tty2
3:23:respawn:/sbin/getty 38400 tty3
4:23:respawn:/sbin/getty 38400 tty4
5:23:respawn:/sbin/getty 38400 tty5
6:23:respawn:/sbin/getty 38400 tty6

the number just before :respawn apoints the terminal to certain runlevels, e.g. 23 is runlevel 2 and 3, 2345 is runlevel 2,3,4 and 5. Get it? All you have to do is put 4 in with those you'd like.
This is a cleaner solution then starting that window manager manually.


losingfight 04-28-2005 01:23 PM

Thanks. That certainly makes a lot more sense.

All times are GMT -5. The time now is 08:06 PM.