LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   messed up my ubuntu system and don't know where to go now (https://www.linuxquestions.org/questions/linux-newbie-8/messed-up-my-ubuntu-system-and-dont-know-where-to-go-now-651537/)

breadbin 06-25-2008 07:42 AM

messed up my ubuntu system and don't know where to go now
 
i am using hardy 8.04 and trying to dual boot with xp. i would be familiar with dual booting xp and mandriva. i set up some partitions

sda1 was /
sda2 was swap
sda3 was /home
sda4 was fat32 for windows

I copied the boot sector from sda1 onto the fat32 and went to install windows, problem with it and then left with no boot options apart from a grub> prompt. sorted that with find, root and setup etc and then rearranged the partitions to have the fat32 at the start of the drive. grand everything went ok

sda1 is fat
sda2 is /
sda3 is swap
sda4 is /home

ubuntu was booting fine and so I tried xp again and now xp works perfectly but can't get into linux. the bootsector that i installed in boot.ini is just leaving me at a grub prompt.

i can use the livedvd to get back into ubuntu and tried grub, find, root and setup for the second partition etc and it seems to work ok but no menu.lst is being made. i can try booting the kernel from the grub prompt but it always hangs.

i can just reinstall it from dvd but i'll lose all the system changes i've made and theres many! so i'm trying to sort this out if i can without that.

any help would be appreciated -thanks

farslayer 06-25-2008 08:04 AM

that should write the Grub boot loader to the MBR of the HD. then just allow the Grub menu to handle your multi-boot configuration. It sounds like you were going the other way using the windows boot loader, but this should actually be less hassle in the long run.

Typically for a multi-boot system you would install Windows first, then Linux allowing Linux to take over the job as boot manager.

Better yet, follow this guide on the Ubuntu Site..
Recovering Ubuntu after installing Windows

breadbin 06-25-2008 08:15 AM

Thanks I got it working although I don't know how and its not the same as the way it was but I can work on that. I did delete the /boot directory by accident so that was another hurdle but I used the kernel off the livedvd.

Works now which is the main thing. I copied a backup of menu.lst to it and entered the new uuids in there and (hd0,1) too. all in all a learning experience!


All times are GMT -5. The time now is 08:33 AM.