LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-19-2019, 01:17 AM   #1
benziw99
LQ Newbie
 
Registered: Aug 2019
Distribution: Void
Posts: 7

Rep: Reputation: Disabled
Messages flooding login prompt


Whenever I boot my computer, the login screen is flooded with messages from ACPI, thinkpad_acpi, and nm-dispatcher. How do I prevent these messages from showing up at the login prompt? I don't want to have to use a display manager if I don't have to.

I read that I may have to start a logger at boot to log the messages in a separate file instead, but I can't figure out how to do that.

I am on Void Linux (using runit).

Any help is greatly appreciated.
 
Old 08-19-2019, 02:28 AM   #2
mrmazda
Senior Member
 
Registered: Aug 2016
Location: USA
Distribution: openSUSE, Debian, Knoppix, Mageia, Fedora, others
Posts: 2,913
Blog Entries: 1

Rep: Reputation: 955Reputation: 955Reputation: 955Reputation: 955Reputation: 955Reputation: 955Reputation: 955Reputation: 955
A way I found long ago to avoid kernel messages contaminating vttys is by creating /etc/sysctl.d/local.conf containing:
Code:
kernel.printk = 3 4 1 3
Likely there exists a less hacky way, but for me it does the job.
 
1 members found this post helpful.
Old 08-19-2019, 11:17 AM   #3
benziw99
LQ Newbie
 
Registered: Aug 2019
Distribution: Void
Posts: 7

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by mrmazda View Post
A way I found long ago to avoid kernel messages contaminating vttys is by creating /etc/sysctl.d/local.conf containing:
Code:
kernel.printk = 3 4 1 3
Likely there exists a less hacky way, but for me it does the job.
Thank you! This has gotten rid of the ACPI related messages, but I still get tons of nm-dispatcher messages flooding the login prompt.

Any idea how to get rid of those?
 
Old 08-19-2019, 11:54 AM   #4
benziw99
LQ Newbie
 
Registered: Aug 2019
Distribution: Void
Posts: 7

Original Poster
Rep: Reputation: Disabled
I've just solved the problem, turns out I just didn't have a logger, so I installed and enabled rsyslog.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
My rhel 6 terminal flooding with syslogd messages sreevaas Linux - Newbie 1 02-11-2016 08:36 AM
[SOLVED] Getting login prompt before boot messages are done Fryndr Linux From Scratch 3 06-15-2014 06:06 PM
How to stop hub_port_status failed messages flooding syslog? zimon Linux - Hardware 5 05-05-2012 02:17 PM
error messages after login in command prompt.. kirtikjr Linux - Software 2 07-13-2007 12:11 PM
evbug.c flooding /var/log/messages w/ mouse movements, help! hollywoodb Linux - Software 2 05-24-2004 10:56 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 05:29 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration