-   Linux - Newbie (
-   -   MDK 9.2: X freezes with a black screen or blue screen with "X cursor" (

Apoc 12-29-2003 02:33 AM

MDK 9.2: X freezes with a black screen or blue screen with "X cursor"
i know i posted this somewhere else in the board but maybe this will end my undying frustration...

I am having a similar problem when trying to run X with mandrake 9.2...

My monitor (NEC MultiSync HR17) and video card (S3 Savagee4) are both listed under XFdrake...

I am attempting to run X under an 800x600 16bpp configureation...but when X attempts to load I simply get a blue screen with a black "x cursor" on it...on top of that to get out of X I am having to reboot my machine...

any suggestions on how to fix this? BTW I am attempting to run a Gnome GUI

any help with this would be much appreciated

oh yeah i am using XFree 4.3

lugoteehalt 12-29-2003 07:35 AM

Could be the window manager is a simple one that just shows a blue screen with a black cross. Try right clicking - to get a menu. Try double clicking, middle clicking, etc.

As you probably know ctrl-alt-backspace should get out of X.:)

Apoc 12-29-2003 09:11 AM

well i just re installed and compiled mandrake 9.2...just to make sure that wasn't the problem...i have KDE on it now...still having the same problem

lugoteehalt 12-29-2003 01:07 PM

Just the obvious suggestion for a newbie.:)

Apoc 12-29-2003 02:38 PM

i tried right clicking but that didn't even work

E-Oreo 12-29-2003 03:23 PM

Its possible that the video card doesn't have enough RAM. When I first built my computer I bought new components except for the video card which I took from a really old computer. I got everything workin except that when I typed startx (I had it set to boot into CLI mode) the screen went like grey and only an X was in the middle. You could not move the X and had to force reboot. After a while I upgraded to a 32MB V-Card and everything worked fine. I doubt you need 32MB of VRAM but make sure you have at least 16.

acid_kewpie 12-29-2003 03:50 PM

blue screen, black cursor.... you have not got a window manager loaded at all. try leaving and running "startkde"

Apoc 12-29-2003 05:50 PM

i can try the startkde...but i have a new development...i got X to run once...but now it is back to the blue screen with the x cursor..i can move the cursor and can do ctrl+alt+bksp to get back to the if anyone else has anyother ideas let me know

Apoc 12-29-2003 06:19 PM

ok i have tried startkde now and it is telling me that
a) modmap cannot load display and
b) $Display has not been set

still lost beyond belief

lugoteehalt 12-30-2003 04:34 AM

Might this help with modmap?

$DISPLAY is presumably an environment variable just set it by doing:
You'll have to find out what from the manual or something. To check it's set do:
set | grep $
If you need to set $DISPLAY permanently put:
export $DISPLAY
I think, in your .bashrc or .bash_profile file, can't recall which one. Having said that the variable is only used inside X I think so it might be best put in ?.xinitrc or ?.xsession??

However it would be much nicer if these problems didn't arrise in the first place. So may be missing the real problem.

If it were me I'd first look in .xinitrc (is it?) or .xsession, in home directory, and see if it ends with 'exec <name of a window manager>'. Stick in something like 'exec fvwm2' (assuming fvwm2, a window manager, is on your path) to see what happens. Or remove everything except the final exec line.

An easy option might be to install Enlightenment, a window manager, because it has the alarming habit of overwriting .xinitrc with its own thing, or used to. Hope helps.:)

Pooldraft 03-30-2004 03:38 PM

Same Problem
I am having the sme problem with the blue screen and black X cursor. I am running Gnome and MDK10.0 not sure what the issue is but i am going to try the recofig option tonight. :scratch:

All times are GMT -5. The time now is 05:35 AM.