-   Linux - Newbie (
-   -   Mandriva 2007, printing problem (

alirezan1 11-15-2006 03:47 AM

Mandriva 2007, printing problem

I installed mandriva 2007 and cups doesn't work. I keep getting this error:

"Unable to retrieve the printer list. Error message received from the manager:

Connection to CUPS server failed. Check that the CUPS server is correctly installed and running. Error: the IPP request failed for an unknown reason.

I reinstalled the cups server using URPMI, didn't help. I also removed cups components altogether and compiled the latest cups (1.2.6) and still get the same error.

I can use cups online administration interface on port 631.

It is really driving me crazy. Can anybody help please? Thanks


b0uncer 11-15-2006 03:56 AM


ps -e | grep cupsd
and you should get a process (cupsd, cups daemon) if cups server is running. If that's missing, you need to start cupsd:

service start cups
service might not be in your path, so if that doesn't work, try /usr/sbin/service or /sbin/service instead.

Once you're sure that's running, try again. If it still fails, make sure that no fancy security software is blocking the service..

alirezan1 11-15-2006 11:56 AM

I think service being in the path isn't the problem:

[alireza@localhost ~]$ ps -e | grep cupsd
10641 ? 00:00:00 cupsd

How can I be sure no security software is blocking the service?

Thanks alot

All times are GMT -5. The time now is 01:08 PM.