LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Mandrake 9.1 - No desktop logged into root (https://www.linuxquestions.org/questions/linux-newbie-8/mandrake-9-1-no-desktop-logged-into-root-54911/)

dudermc 04-13-2003 10:04 PM

Mandrake 9.1 - No desktop logged into root
 
I need some help! I just installed Mandrake 9.1. Everything went well and I can log into my user created account just fine. However, if I try and start the GUI for KDE logged in as "root", I get no desktop or icons. Just the panel. Any ideas??

michaelk 04-13-2003 11:55 PM

Mandrake does that on purpose. Its just their way of saying don't use root. You could create the icons if you really wanted to.

dudermc 04-14-2003 03:27 AM

Ahh... thanks for the reply. I was kinda leaning toward that, cause I could get everything to work, the only thing that made me wonder was that everytime my mouse was over the desktop it showed the clock (which I thought it was still loading). Thanks again and cheers!

jramen 06-26-2003 02:50 PM

Yup, this made me veeery unhappy too and I thought I made a mistake during the installation, but hey, I wasn't right! :)
Maybe guys from Mandrakesoft and/or KDE development team will hate me for writting this little HOWTO, but... I really don't like anyone playing the big daddy who doesn't let me do things with my own computer I would like to! :mad:
So, here is a short "walkthrough":

At first, delete the directory /root/.kde or move it to another place.
Then edit the file /usr/bin/startkde and find these lines:

-------------- sample begins here -----------------

if [ "`whoami`" = root ] ; then
#xsetroot -cursor_name left_ptr -solid '#B20003'

cd /usr/share/mdk/kde/root-interface/
for i in *; do
if [ ! -e /root/.kde/share/config/$i ]; then
cp -fr $i /root/.kde/share/config/
fi
done
cd -

# if [ ! -d /root/.kde/share/apps/kdisplay/color-schemes/ ] ; then
# mkdir -p /root/.kde/share/apps/kdisplay/color-schemes/
# cp /usr/share/mdk/kde/root-interface/Root_interface.kcsrc /root/.kde/share/apps/kdisplay/color-schemes/
# fi

------------- sample ends here --------------------

and change those lines to look like this:

-------------- sample begins here -----------------

if [ "`whoami`" = root ] ; then
xsetroot -cursor_name left_ptr -solid '#21449c'

# cd /usr/share/mdk/kde/root-interface/
# for i in *; do
# if [ ! -e /root/.kde/share/config/$i ]; then
# cp -fr $i /root/.kde/share/config/
# fi
# done
# cd -

if [ ! -d /root/.kde/share/apps/kdisplay/color-schemes/ ] ; then
mkdir -p /root/.kde/share/apps/kdisplay/color-schemes/
cp /usr/share/mdk/kde/root-interface/Root_interface.kcsrc /root/.kde/share/apps/kdisplay/color-schemes/
fi

------------- sample ends here --------------------

Now you got rid of that silly red background during the KDE startup (setting the color to #21449c) and you should have now the correct user desktop with icons on it. ;)
Actually, I have experienced a little problem. Some of the icons were twice on the desktop, for example the "Trash bin", but it's been caused by the localization. So, maybe if you have english locales set you will not encounter this one. Anyway, if this problem arises, just delete the duplicate icon(s) and it will be fine.

zachy 08-17-2003 06:07 AM

A Simpler Solution....
 
Go to KDE Control Panel... and enable desktop icons.

Cheers !

Proud 08-17-2003 06:34 AM

zachy they altered a lot more that that. The whole desktop and Konqueror behavoir is reduced. jraman' way of removing the ~/.kde directory and editing startkde should work, as it'll be restored with a normal user's default settings instead.

zachy 08-17-2003 03:05 PM

Yeah you're right....
 
I guess you're right.... but there's another interesting problem which I am facing. Nautilus encounters an error :

(The Text view encountered an error and can't continue. You can choose another view or go to a different location.)

when previewing mime : text/plain documents. This is regardless of whether I'm logged in as root or normal user. I tried uninstalling then reinstalling nautilus but still it didn't work. Any ideas ? Also I found that there's no LPRng package installed. Thus I had to use my old package from MDK 9.0. Thank god it worked. Another problem which I couldn't solved, but worked around is, the GDM version that ships with MDK 9.1 causes X to die whenever I try to enter a password which consists of certain keyboard characters. Heck I didn't even manage to type the password in full. For example say that my password is lama. after typing l and typing a.... X dies.... and GDM regenerates (or X that is). So I just uninstalled GDM and reinstalled the version from MDK 9.0. Sigh :) HELP ME IF YOU CAN.......


All times are GMT -5. The time now is 06:51 PM.