LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Mandrake 9.1 login problem (https://www.linuxquestions.org/questions/linux-newbie-8/mandrake-9-1-login-problem-85910/)

rfaulk69906 08-26-2003 12:29 PM

Mandrake 9.1 login problem
 
I just installed Mandrake 9.1. I am dual booting with that and Windows XP. I was having a problem yesterday with the monitor just turning off. Mandrake boots up fine, but after a few minutes the monitor goes black and there's nothing you can do to get it back except turn the computer off. I was checking my video card and monitor settings this morning to see if they were right. I think I somehow changed the login process. It does not log onto KDE now. Here's what I'm getting:
Mandrake Linux release 9.1 (Bamboo) for i586
Kernel 2.4.21-0.13 mdk on an i626 /tty1
localhost login:

I can enter my username and password but have no idea where to go from here. Any help would be appreciated. I'm sure this is pretty easy to fix, but I'm pretty new at Linux.

peace 08-26-2003 12:44 PM

'startx' will start KDE.

To login to KDE automatically, edit /etc/inittab so that the default is 'X11' instead of 'multi-user'. This line:

id:3:initdefault:

Should look like this:

id:5:initdefault:

rfaulk69906 08-26-2003 05:06 PM

I was able to use XFdrake to change the settings back. I then went into /etc/inittab and edited the file so now everything starts normally. However, I'm still having the problem with the monitor going black. I was online for about half an hour and everything was fine. I went away for 20 minutes and when I came back the monitor had gone black. All my settings seem to be correct. The video card is an Intel (R) 82810 Graphics controller. The monitor I have is generic. I verified that all of the settings seem to be the same in Mandrake and Windows XP. Anyone have any suggestions?

Thanks.

Proud 08-26-2003 05:12 PM

that sounds like normal power&screen saving processes.

jschiwal 08-26-2003 05:30 PM

You might try using the Mandrake configuration program and selecting boot drake. There is a selection you can make to disable ACPI. This will add add noacpi to the lilo.conf file. I think the ACPI isn't working properly with your monitor to bring it back up again from the power saving mode.

rfaulk69906 08-26-2003 06:33 PM

I went into drakboot and disabled ACPI. After doing this I still had the problem of the monitor going black. I rebooted the computer and went back into drakboot. I unchecked the option to Force No APIC and that seems to have fixed the problem. I'm not sure what I did. I'll post another message if the problem reoccurs. Thanks for the help.

rfaulk69906 08-26-2003 07:26 PM

The monitor is still going black. It seems that even though I disabled ACPI under drakboot it keeps turning itself back on. I also went into Control Center in KDE and told it to not use standby mode or any power saving options for the monitor. Any suggestions?


All times are GMT -5. The time now is 08:35 PM.