LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-29-2005, 10:50 PM   #1
macgyver007
Member
 
Registered: Oct 2004
Location: Eastern US
Posts: 38

Rep: Reputation: 15
Mandrake 10.1 Questions - Stop Services from loading on boot.


Hey all-

As the forum says I'm a newbie, so I'm going to ask some newbie-esq questions.

I installed mandrake 10.1 on my pc. I tried disabling sounds through K-Mix which didn't work. I was wondering how I could disable the sound server from running on boot. I fooled around with Suse before and I believe there was a runlevel editor which I could select which services start on boot. I believe I found that in the Mandrakelinux control center 10. So my questions are....Is that the right place to disable it? if so what .conf file does it refer to, in other words how would I do it without the control center gui? How can I start the sound server from konsole?

Also along similar lines, I have a wifi card and a wired network card, how do I disable the eth0 (Wired card) from starting on bootup.


Also I'm experiencing a weird problem with my mouse (Dell Inspiron 8200 Laptop)...When it boots I have no mouse control.....If I change the mouse type in the Mandrake Control Panel to 2-3 different types, then back to one that represents mine, it works. However once I reboot.....its back to the same old....Any ideas?

THANKS for all of your time, I sincerely appreciate it.
 
Old 03-30-2005, 12:27 AM   #2
masand
LQ Guru
 
Registered: May 2003
Location: INDIA
Distribution: Ubuntu, Solaris,CentOS
Posts: 5,522

Rep: Reputation: 58
hi there

to get the service that are running

run this

chkconfig --list

this will give u the list of the service that are running
to disable the services in ur runlevel

run this

chconfig <service name> off

or to start

chkconfig <servioce name> on

regards
 
Old 03-30-2005, 07:16 AM   #3
macgyver007
Member
 
Registered: Oct 2004
Location: Eastern US
Posts: 38

Original Poster
Rep: Reputation: 15
If I turn them off, will then the service be suspended at boot the next time I turn the machine on?

Thanks
 
Old 03-30-2005, 08:41 AM   #4
Proud
Senior Member
 
Registered: Dec 2002
Location: England
Distribution: Used to use Mandrake/Mandriva
Posts: 2,794

Rep: Reputation: 116Reputation: 116
Man chkconfig to see it does what you want.

It's probably the harddrake (a hardware autodetecting and configuring) service that's messing with your mouse. Disable that at boot and the problem should clear.
 
Old 04-04-2005, 09:12 AM   #5
macgyver007
Member
 
Registered: Oct 2004
Location: Eastern US
Posts: 38

Original Poster
Rep: Reputation: 15
I disabled harddrake and there is no resolve. Has anyone else expieranced a similar issue? Can anyone suggest any other possible course of action?


Thanks for your time all.
 
Old 06-06-2005, 07:24 AM   #6
fortezza
Member
 
Registered: Mar 2003
Location: Colorado
Distribution: Fedora Core 4
Posts: 297

Rep: Reputation: 30
Quote:
Also along similar lines, I have a wifi card and a wired network card, how do I disable the eth0 (Wired card) from starting on bootup.


Also I'm experiencing a weird problem with my mouse (Dell Inspiron 8200 Laptop)...When it boots I have no mouse control.....If I change the mouse type in the Mandrake Control Panel to 2-3 different types, then back to one that represents mine, it works. However once I reboot.....its back to the same old....Any ideas?
To disable the ethernet card, you can go ( as root ) to /etc/sysconfig/network-scripts/ifcfg-eth0 and edit that file. There is a line that says "onboot=yes", change it to "no" to stop the card from starting on bootup.



As far as your second question is concerned, I don't have any ideas on that one. Sorry.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Stop services from starting at boot augu2000 Slackware 6 11-04-2005 07:24 PM
Need to stop KDE from auto-loading at boot. Zombie13 Mandriva 2 12-16-2004 05:56 PM
How do I stop modules from loading on boot? brandor Fedora 14 08-05-2004 08:16 AM
How to stop services at boot? G-fahmah Slackware 2 02-24-2004 12:44 PM
Mandrake 9.2, how to stop ethernet card from loading at boot alexchannell Linux - Newbie 6 11-05-2003 06:27 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 01:48 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration