LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   managed to make files owned by 1016 and cannot delete, i'm using slackware 12 (https://www.linuxquestions.org/questions/linux-newbie-8/managed-to-make-files-owned-by-1016-and-cannot-delete-im-using-slackware-12-a-623614/)

The_spacekadet 02-25-2008 01:05 AM

managed to make files owned by 1016 and cannot delete, i'm using slackware 12
 
alright i am extremely new to lunix and slackware lunix, so i was following this tutorial "http://www.howtoforge.com/the_perfect_desktop_slackware12_p6"

and it seems that i cannot properly install about half of the programs at the bottom of this page and when i try to run:
"tar -xzvf filename.tar.gz." it says:
"tar: filename.tar.gz.: Cannot open: No such file or directory
tar: Error is not recoverable: exiting now
tar: Child returned status 2
tar: Error exit delayed from previous errors"

and when i run "tar -xzvf filename.tar.gz" on the files it makes their folders owned by 1016

then when i try to run "cd filename <!--" it says " !--: event not found"
but it works without the "<!--" part but then the sources for these specific files do not download properly after the folders are made, they seem to just disappear or not download at all or something.

when i finger 1016 it says "finger: 1016: no such user."
when i id 1016 using "find / -uid 1016 -print" it says:
"find: /proc/3768/task/3768/fd/4: No such file or directory
find: /proc/3768/fd/4: No such file or directory"
then lists all the files owned by 1016
when i run "lsattr filename" it does the "----------" so i'm assuming the
attributes are fine
and i cannot delete them with Konquerer it denies access saying:
"Access denied to
/home/spacekadet/.local/share/Trash/files/'foldername'"

I think the very first error i got from trying to install openoffice.org (the first one i had problems with) was a little different but i didnt manage to record it because i didnt think it was going to do all of this...
I've managed to do this with openoffice.org, scribus, and guarddog

Is this an actual user or is this something faulty with the scripts i am running?

How do i override this access denied and delete these messed up files? Isn't there something i can do to delete them from terminal or something?

Is there something i didn't update properly when i was trying to make sure everything was up-to-date? (downloaded slackware 10-07 installed 2-08)

And are the steps through that part of the tutorial even accurate? or am i just skrewing them up?

all help will be gladly appreciated ;) just remember i'm noob with this so if its something simple that you think i've tried, i may not have cause i dunno better yet...

Tinkster 02-25-2008 01:15 AM

Nothing to worry about, that happens ... some package makers bake
their own identity into an archive, and on your machine there's no
numerical user-id that matches. Just become root and chown the
whole extracted tree to your normal user account.

chown -R your_user:users extracted_directory




Cheers,
Tink

The_spacekadet 02-25-2008 02:09 AM

::huggz:: thank you so much, this was eating my lunch


All times are GMT -5. The time now is 07:08 PM.