-   Linux - Newbie (
-   -   managed to delete /lib/ (

murder 09-29-2005 01:35 PM

managed to delete /lib/
i managed to replace the "/lib/" i have tried replacing the file with one from a diff. box but i still get this error "/bin/sh: error while loading shared libraries: /lib/ file too short" any suggestions? the box is running Fedora 4 and its 2000 miles away from me. i can still access it from Webmin & Ftp but no ssh

Komakino 09-29-2005 01:45 PM

I guess you'll need to replace it with the exact same one from another FC4 distro.

But the question remains....WHY and HOW?!!!?! It never ceases to amaze me what people feel they have to fiddle with...

murder 09-29-2005 01:47 PM

i replaced it from another fedora core 4. the reason it happend is i was tring to get mysqld to start and it was giving me a error regarding that file so i googled it and it said to update the file with a rpm so i did then nothing worked after that so i tried deleted it and replacing it with the one from the other box and still get the same error.

freakyg 09-29-2005 02:47 PM

the reason it won't work is this............the glibc libraries are compiled against the particular version of kernel headers your system has....... just can't take a that was compiled against kernel 2.4.26 headers and use it in a box that is using 2.4.24 or 2.4.29'll get oddball errors as well as Seg Faults!!...........

tkedwards 09-30-2005 01:43 AM

You can easily fix this by doing a

rpm --freshen --allfiles
Find the glibc rpm on your CDs or on one of the Fedora mirrors (make sure you get the one for Fedora4!

As for only having webmin and FTP access, that might be a bit of a problem - are you sure you can't restart the ssh daemon (using webmin) and have it work? Also how much of the file system can u access through FTP - if you can access the /etc directory you could drop a statically compiled ssh or telnet or rlogin daemon somewhere, create a script in /etc/init.d to start it and then use the service control thing in webmin to start it.

murder 09-30-2005 03:30 PM

i tried all of that but no such luck i guess im just gonna have to re-image the system but thanks for all your help

All times are GMT -5. The time now is 12:49 PM.