LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   make install problem on vsftpd (https://www.linuxquestions.org/questions/linux-newbie-8/make-install-problem-on-vsftpd-440789/)

dragunu 05-02-2006 01:58 AM

make install problem on vsftpd
 
when i do make install its giving me this :

Code:

if [ -x /usr/local/sbin ]; then \
        install -m 755 vsftpd /usr/local/sbin/vsftpd; \
else \
        install -m 755 vsftpd /usr/sbin/vsftpd; fi
if [ -x /usr/local/man ]; then \
        install -m 644 vsftpd.8 /usr/local/man/man8/vsftpd.8; \
        install -m 644 vsftpd.conf.5 /usr/local/man/man5/vsftpd.conf.5; \
elif [ -x /usr/share/man ]; then \
        install -m 644 vsftpd.8 /usr/share/man/man8/vsftpd.8; \
        install -m 644 vsftpd.conf.5 /usr/share/man/man5/vsftpd.conf.5; \
else \
        install -m 644 vsftpd.8 /usr/man/man8/vsftpd.8; \
        install -m 644 vsftpd.conf.5 /usr/man/man5/vsftpd.conf.5; fi
if [ -x /etc/xinetd.d ]; then \
        install -m 644 xinetd.d/vsftpd /etc/xinetd.d/vsftpd; fi

i have the gcc installed and it still giving me this problem. im using fc 3

thanks

Amuro-Ray2020 05-02-2006 02:39 AM

That doesn't look like it's giving you an error. You see that sort of thing during many compiles. Is it giving you any other information?

zulfilee 05-02-2006 02:42 AM

Where did it show any problem ?

It says that it has installed vsftp in /usr/local/sbin/

Check the directory and see if vsftpd has got installed.

To enable vsftpd use "ntsysv" and enable vsftpd.

dragunu 05-02-2006 02:51 AM

Quote:

Originally Posted by Amuro-Ray2020
That doesn't look like it's giving you an error. You see that sort of thing during many compiles. Is it giving you any other information?

thats the only info its giving me

Quote:

Originally Posted by zulfilee
To enable vsftpd use "ntsysv" and enable vsftpd.

i did not understand exactly what do u mean by that command.

thanks a lot for ur help guys. rly appreciated :)

zulfilee 05-02-2006 02:58 AM

Cool
Then that is an info not error.

And if you want to see if vsftpd has got installed or not do the following

cd /usr/local/sbin/
ls vsftpd

If it shows vsftpd then it is installed.

Ok if vsftpd is installed you have to enable it with some command right

For that login as root
type

ntsysv

This will show u a menu where you can select 'vsftpd' and enable it.

dragunu 05-02-2006 03:16 AM

Quote:

Originally Posted by zulfilee
Cool
Then that is an info not error.

And if you want to see if vsftpd has got installed or not do the following

cd /usr/local/sbin/
ls vsftpd

If it shows vsftpd then it is installed.

Ok if vsftpd is installed you have to enable it with some command right

For that login as root
type

ntsysv

This will show u a menu where you can select 'vsftpd' and enable it.

ok i shall try when i am at home cause at the moment im at wrk:P

thanks a lot!

dudulz 05-02-2006 03:27 AM

You should have to enable vsftpd in /etx/xinetd.conf.

dragunu 05-02-2006 03:31 AM

Quote:

Originally Posted by dudulz
You should have to enable vsftpd in /etx/xinetd.conf.

how do i enable it in the config?

and now when im running /usr/local/sbin/vsftpd its giving me

500 OOPS: vsftpd: not configured for standalone, must be started from inetd

i have googled the problem a bit but everyone seems to give a solution that i being a noob cnt understand hehe


All times are GMT -5. The time now is 03:53 PM.