-   Linux - Newbie (
-   -   Make a CD Directory Available For Execution (

gakusei 12-09-2008 08:09 PM

Make a CD Directory Available For Execution
How can I access a directory on a CD so that programs can use the data in the directory? It appears on my Desktop. I tried doing a cd command using the DVD's name that was on the desktop but was unsuccessful. Embedded blanks were in the name, and I tried it with " and ' and without them, all to no avail.

I worked around it by using the "Copy/Paste" functions of the "Applications --> System Tools --> File Browser" to copy the directory from the DVD to my home directory and rpm worked successfully. But, I would like to learn how to do it without having to first copy from the DVD

Background on the question: Dec 7th, Fedora 10 issued a security update to dbus that prevents several of the Fedora functions from working - including obtaining Updates.

A solution was posted in "fedora forums" that explained how to use rpm to revert to the prior-to-the-update dbus (

Here is a snippet:

"Insert Fedora DVD go to Packages dir ..."

I inserted the DVD and it appears on the Desktop, but is not part of the Desktop directory.

rylan76 12-10-2008 03:03 AM

Don't you maybe need to manually mount the DVD to access it?

E. g.

1. Open a terminal
2. Become root
3. Go to /mnt and make a dvd subdirectory, e. g.

(In /mnt)
# mkdir dvd

4. Manually mount the DVD:

# mount /dev/dvd /mnt/dvd

This depends on as what your DVD drive is listed in your /dev - on my system (FC6 it is "/dev/dvd" but it can also be /dev/hda1 or something similar.

dandelot 12-10-2008 12:17 PM

Another way to recover from the problem is to fix configuration files
(rather than installing older stuff). [Addressing the reason-for-question
here rather than the question itself.]

I'm running FC9, not FC10, --- I am not positive the above is
100% applicable to FC10. It worked for me on FC9 though.

gakusei 12-10-2008 02:51 PM

Thank you rylan76 That worked just fine. Dumb me. I assumed that because the DVD's icon appeared on the desktop and I could display its contents with a double-click, that it was mounted. I learned something new. Thanks again. (I re-drew the "assume diagram" to remind me once again about the word's hazards. :-)) )

dandelot: "Another way to recover from the problem is to fix configuration files
(rather than installing older stuff)" I agree, but do not have enough knowledge to do that. Hopefully that will come as I go along. Anyone who doesn't have enough knowledge to mount a CD should definitely not be messing with config files).

All times are GMT -5. The time now is 06:26 AM.