LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
LinkBack Search this Thread
Old 03-23-2013, 10:38 AM   #1
vwinnecke
LQ Newbie
 
Registered: Mar 2013
Posts: 14

Rep: Reputation: Disabled
make: *** [makedata] Error 127


I get an error when I try to use a makedata file that was provided to me, using Linux terminal.

[Michelle@localhost HW05]$ make makedata
cc makedata.c -o makedata
make: cc: Command not found
make: *** [makedata] Error 127

Do I need to install a compiler, or is there something in the file that needs to be corrected? Maybe in the command line?

I have Linux RedHat guest on Windows host running through VirtualBox. Any ideas on what I should do with this? If I need to install a compiler, can you suggest one that is easy to install? The one that I tried to install before was only 79MB, and was taking too long to install, more than 30 minutes.
 
Old 03-23-2013, 12:29 PM   #2
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2013.07, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 13,188

Rep: Reputation: 2369Reputation: 2369Reputation: 2369Reputation: 2369Reputation: 2369Reputation: 2369Reputation: 2369Reputation: 2369Reputation: 2369Reputation: 2369Reputation: 2369
Welcome to LQ.

Installing the default Redhat compiler : # yum install gcc-c++
Provides : /usr/bin/ cc gcc g++
 
Old 03-23-2013, 01:12 PM   #3
vwinnecke
LQ Newbie
 
Registered: Mar 2013
Posts: 14

Original Poster
Rep: Reputation: Disabled
Thank you.

I still get the same error. When I use which gcc it says...
/usr/bin/which: no gcc in (/usr/kerberos/bin:/usr/local/bin:/usr/bin:/bin:/usr/X11R6/bin:/home/Michelle/bin)
 
Old 03-23-2013, 01:27 PM   #4
colucix
Moderator
 
Registered: Sep 2003
Location: Bologna
Distribution: CentOS 6.5 OpenSuSE 12.3
Posts: 10,361

Rep: Reputation: 1910Reputation: 1910Reputation: 1910Reputation: 1910Reputation: 1910Reputation: 1910Reputation: 1910Reputation: 1910Reputation: 1910Reputation: 1910Reputation: 1910
Actually /usr/bin/cc is provided by the gcc package, but installing gcc-c++ as suggested should have installed gcc as dependency. What is the output from the following?
Code:
yum list 'gcc*'
or from the more concise
Code:
rpm -qa gcc*
 
Old 03-23-2013, 01:46 PM   #5
vwinnecke
LQ Newbie
 
Registered: Mar 2013
Posts: 14

Original Poster
Rep: Reputation: Disabled
[Michelle@localhost HW05]$ yum list 'gcc*'
Loaded plugins: rhnplugin, security
*Note* Red Hat Network repositories are not listed below. You must run this command as root to access RHN repositories. Error: No matching Packages to list.

Also, rpm -qa gcc* does nothing, it just goes down to another line.

Any other ideas on what to do?
 
Old 03-23-2013, 01:55 PM   #6
colucix
Moderator
 
Registered: Sep 2003
Location: Bologna
Distribution: CentOS 6.5 OpenSuSE 12.3
Posts: 10,361

Rep: Reputation: 1910Reputation: 1910Reputation: 1910Reputation: 1910Reputation: 1910Reputation: 1910Reputation: 1910Reputation: 1910Reputation: 1910Reputation: 1910Reputation: 1910
Quote:
Originally Posted by vwinnecke View Post
[Michelle@localhost HW05]Also, rpm -qa gcc* does nothing, it just goes down to another line.
This means that no gcc package has been installed on your system (and most likely it hasn't got any C compiler at all). Instead the yum error is clear: You must run this command as root to access RHN repositories. Therefore, please switch to root and try to install gcc again:
Code:
yum install gcc gcc-c++ gcc-gfortran
 
Old 03-23-2013, 02:07 PM   #7
vwinnecke
LQ Newbie
 
Registered: Mar 2013
Posts: 14

Original Poster
Rep: Reputation: Disabled
I got an error the system is not registered with RHN. Could it have something to do with running on VirtualBox? I downloaded this version from my school website, so I know it is ok to use. the full error when i use you list 'gcc*' is

Loaded plugins: rhnplugin, security
This system is not registered with RHN.
RHN support will be disabled.
Error: No matching Packages to list.

When I run you install gcc gcc-cc++ gcc-gfortran
The error is similar

It also includes:

Setting up Install Process
Parsing package install arguments
No package gcc available.
No package gcc-cc++ available.
No package gcc-gfortran available.
Nothing to do.
 
Old 03-23-2013, 02:36 PM   #8
colucix
Moderator
 
Registered: Sep 2003
Location: Bologna
Distribution: CentOS 6.5 OpenSuSE 12.3
Posts: 10,361

Rep: Reputation: 1910Reputation: 1910Reputation: 1910Reputation: 1910Reputation: 1910Reputation: 1910Reputation: 1910Reputation: 1910Reputation: 1910Reputation: 1910Reputation: 1910
Does the school website provide instructions about the system activation? Most likely they have purchased an academic license but every single system should be activated in order to access the Red Hat Network repositories. Maybe asking to the IT team of your school should clarify. They should provide an activation key somehow.
 
Old 03-23-2013, 03:01 PM   #9
vwinnecke
LQ Newbie
 
Registered: Mar 2013
Posts: 14

Original Poster
Rep: Reputation: Disabled
You are very helpful, thank you.

How do I access a file in my user desktop from the root?
The directions are to fully root the terminal with su - then run a command chmod 700, and a file path to this bootstrap system.
 
Old 03-23-2013, 03:57 PM   #10
colucix
Moderator
 
Registered: Sep 2003
Location: Bologna
Distribution: CentOS 6.5 OpenSuSE 12.3
Posts: 10,361

Rep: Reputation: 1910Reputation: 1910Reputation: 1910Reputation: 1910Reputation: 1910Reputation: 1910Reputation: 1910Reputation: 1910Reputation: 1910Reputation: 1910Reputation: 1910
You can change directory to /home/Michelle/Desktop or work with absolute paths. For example:
Code:
# cd /home/Michelle/Desktop
# chmod 700 file
# ./file
or without changing directory:
Code:
# chmod 700 /home/Michelle/Desktop/file
# /home/Michelle/Desktop/file
In both cases the last statement is to execute the file: the difference is that in the former you use a relative path (relative to the current working directory) whereas in the latter you use the absolute path of the file.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
make: CC: Command not found make: *** [main.o] Error 127 on opensuse 11.3 Leo89 Linux - Newbie 6 11-30-2012 05:13 PM
How can I resolve this error: make: *** [HelloWorld.o] error 127 for Eclipse C++ ? drcshavers Red Hat 4 06-05-2010 10:32 AM
Unable to compile C++ programs.make:g++ command not found error.Error 127 PrathuD Programming 3 03-16-2009 12:44 PM
make: *** [primer.o] Error 127 Insomnia6 Linux - Newbie 1 12-16-2008 10:49 AM
make: cc: command not found make: *** [gzip.o]error 127 zyjk Linux - Newbie 5 02-08-2002 09:58 AM


All times are GMT -5. The time now is 12:04 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration