-   Linux - Newbie (
-   -   lvm2 Newly created Volume Group lost after reboot (

seanikins 05-20-2008 09:36 AM

lvm2 Newly created Volume Group lost after reboot
I have RHEL 5.1 and I have created a lvm2 volume group on new EMC Powerpath connected SAN volume. All seems OK . I can create a ext3 file system ,on the new logical volume (/dev/VolGroup01/LogVol00) and all is fine, until I reboot the server. Upon reboot the Volume Group and Logical Volume entries are missing in /dev and consequently the file system fails to mount. I can then quite happily, vgscan --mknodes followed by a vgchange -a y and they are back again, but any ideas why I have this problem on reboot?? Any help much appreciated...trying to refresh my Linux knowledge after a few years break and tearing my hair out with this one. Hopefully it's something silly that someone will spot straight away.

gmoore 08-31-2009 08:44 AM

SAN attached volume groups disappear on Reboot
Has anyone found a solution to this problem. It happened to me last night (Sunday) 10 hours before we went live with a major production system. I rebooted the database server to make sure everything was ready for the following morning. My San attached volume groups were gone. Of course my database would not come up. I used Seanikins methodology to bring things back, but I sure would like to find out what causes this.



chrism01 08-31-2009 06:34 PM

Did you add the LVM entry to /etc/fstab before reboot (dumb qn I know, but it happens)

gmoore 09-01-2009 06:44 AM

Yes, we do have the correct entries is FSTAB. The thing is, it's not just that the volumes weren't mounted, but the volume group and logical volume entries disappear from /dev. After vgscan and vgchange they come back and I am able to mount the volumes. I would like to find out why they go away in the first place.

yzhong 09-01-2009 07:08 PM

We had a NAS ...We added a LVM on this disk and added entry to the fstab as well, after reboot, not mounted but can scan & mount later.

The problem is when system doing auto mount (entry in fstab), the connection to the NAS is not ready at that time. And until the whole system up, the connection is ready, that's why we can scan & mount later.

Solution is you can add some command to mount that disk in rc.local (double check connection before you mount)...

Hope that can give you so clue ...

draino 04-11-2010 12:55 PM

I just had this occur, myself. It turned out to be a corrupted /etc/lvm/lvm.conf entry. Prior to the reboot, I had modified the 'filter' parameter. About a day later, upon reboot, the exact issue began to occur.

I copied my original lvm.conf back into place. After reboots, my vgs remained persistent.

All times are GMT -5. The time now is 07:01 AM.