Register a domain and help support LQ
Go Back > Forums > Linux Forums > Linux - Newbie
User Name
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!


  Search this Thread
Old 03-24-2009, 01:57 AM   #1
LQ Newbie
Registered: Mar 2009
Posts: 2

Rep: Reputation: 0
LVM mount as /dev/vg00/lv00 instead of /dev/mapper/vg00-lv00


Is there a way of getting LVs mounted via /dev/<VolGroup>/<LogVol> instead of via /dev/mapper/<VolGroup>-<LogVol>?

If I execute the following command:
> mount /dev/vg00/lv00 /oracle

it shows in mount and df as:
"/dev/mapper/vg00-lv00 on /oracle"
I would expect
"/dev/vg00/lv00 on /oracle"

My fstab is set to mount all the LVs as /dev/vg0n/lv0n but, as above, once the system is booted they show up in df and mount as /dev/mapper/vg0n-lv0n. It's not a show-stopper as everything works. It makes the spacing in the df output too big to fit on one screen though, as each entry takes up 2 lines!

Thanks in advance.
Old 03-27-2009, 06:29 PM   #2
Registered: Jul 2007
Location: Germany
Distribution: Debian, Mac OS X
Posts: 134

Rep: Reputation: 22

I am not on my Linux machine right now so I cannot check, but from /dev/vg00/lv00 and /dev/mapper/vg00-lv00 one is a symlink to the other one. So they are 100% equivalent. You should be able to chose on which one you want to mount the fs, the choice is usually done on the kernel line (for the root) or later, in fstab (for the rest, most likely so for oracle).
Old 03-29-2009, 05:44 PM   #3
LQ Newbie
Registered: Mar 2009
Posts: 2

Original Poster
Rep: Reputation: 0
Thanks. I also found the df -P (POSIX compliant output) formats the df output in a better way than default (combined with the -h option).


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
xfe : mount point /dev/.static/dev is not responding frenchn00b Linux - Software 0 10-06-2008 06:12 PM
OpenSUSE x86_64 does not mount /dev/tape (or /dev/st0 or /dev/nst0) yankeeinga Linux - Newbie 6 08-21-2008 12:51 PM
Where is /dev/mapper? Swift&Smart Fedora 1 12-08-2007 02:09 AM
filesystem on VG00 not writable anymore Linux - Enterprise 0 03-09-2007 12:52 PM
Mount command says / is mounted from /dev/hda4, but I know its /dev/hda1 trewsfan Linux - Software 2 08-30-2006 10:01 PM

All times are GMT -5. The time now is 02:06 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration